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History of Computer 
Introduction to Computers: 

The word 'computer' originally referred to people who performed mathematical calculations. 
Before modern computers existed, these human 'computers' were employed to carry out complex 
arithmetic operations, often used in fields like astronomy, engineering, and navigation. This 
practice dates back to at least the 17th century. 

The first recorded use of the word 'computer' in English was in 1613, describing a person who 
computes. Over the centuries, as technology progressed, mechanical and electronic devices took 
over the computational role. This evolution marked the transition from manual computing to the 
automated systems we rely on today. 

Understanding the history of computing helps us appreciate the innovations and challenges faced 
by early scientists and inventors who laid the foundation for today’s digital age. 

The Mechanical Era (1600–1900) 

During the Mechanical Era, inventors developed physical devices to assist in computation. These 
devices worked without electricity and were typically operated by hand. 

Tally Sticks 

Tally sticks were simple tools used since ancient times to record numbers, debts, or messages. 
They were not calculators but rather record-keeping aids. A notch on a stick represented a unit of 
value or count. These were used extensively in medieval Europe, especially for tax collection. 

Abacus (c. 2400 BC) 

The abacus is one of the oldest calculating tools known to humanity. First used in Babylon around 
2400 BC and later perfected in China around 500 BC, the abacus consists of beads that can be 
moved along rods to perform arithmetic operations. It was especially useful in trading and finance 
and is still used today in parts of Asia. 
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 Summary of Key Developments 

Machine Year Type Contribution 

Z1 1936–38 Mechanical First programmable mechanical 
computer 

ABC 1939–42 Electronic (non-
programmable) 

Introduced binary, electronic 
computation 

Harvard 
Mark I 

1943 Electromechanical Used for military ballistics 

ENIAC 1946 Electronic First general-purpose digital 
computer 

EDVAC 1952 Electronic First stored-program design 
UNIVAC I 1951 Commercial First computer sold commercially 
Osborne 1 1981 Portable First widely-used portable computer 
IBM PC 1981 Personal Standardized and popularized 

personal computing 

 Generations of Computers 

The history of modern computing is often categorized into five generations, each defined by a 
major technological breakthrough. These generations highlight the evolution in speed, size, 
reliability, and capability of computers — from bulky vacuum tubes to intelligent AI systems. 

 1st Generation Computers (1946–1956) 

Key Technology: Vacuum Tubes 
Father Figure: Charles Babbage (conceptually), Eckert & Mauchly (practical implementation) 

Overview: 

• First true electronic computers 
• Relied on vacuum tubes for processing and storage 
• Required special air-conditioned rooms due to heat 
• Extremely large and expensive 
• Consumed huge amounts of electricity 
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MCQs – History of Computers 

1. What did the term "computer" originally refer to? 
A) Machines 
B) Programmers 
C) People who calculated 
D) Typewriters 

2. In which year was the term "computer" first used 
in English? 
A) 1500 
B) 1613 
C) 1705 
D) 1801 

3. Which of the following was used for keeping 
records rather than calculation? 
A) Abacus 
B) Napier’s Bones 
C) Tally Sticks 
D) Slide Rule 

4. The abacus was first used around: 
A) 1600 AD 
B) 500 AD 
C) 2400 BC 
D) 1000 BC 

5. Which device used rods to simplify 
multiplication? 
A) Stepped Reckoner 
B) Napier’s Bones 
C) Pascaline 
D) Slide Rule 

6. Who invented the Slide Rule? 
A) John Napier 
B) Blaise Pascal 
C) William Oughtred 
D) Gottfried Leibniz 

7. Pascaline could perform which two operations? 
A) Addition and division 
B) Subtraction and multiplication 

C) Addition and subtraction 
D) Multiplication and division 

8. The Stepped Reckoner was an improvement of 
which machine? 
A) Abacus 
B) Slide Rule 
C) Pascaline 
D) Arithmometer 

9. Which was the first commercially successful 
mechanical calculator? 
A) Z1 
B) Stepped Reckoner 
C) Pascaline 
D) Arithmometer 

10. Who built the Difference Engine and Analytical 
Engine? 
A) Ada Lovelace 
B) Charles Babbage 
C) Alan Turing 
D) Konrad Zuse 

11. Who is considered the first computer 
programmer? 
A) Grace Hopper 
B) Augusta Ada Byron 
C) Charles Babbage 
D) William Shockley 

12. What was the purpose of the Jacquard Loom? 
A) Store data 
B) Weave fabric patterns using punch cards 
C) Perform arithmetic 
D) Program binary code 

13. The Tabulating Machine was developed by: 
A) Charles Babbage 
B) John von Neumann 
C) Herman Hollerith 
D) Ted Hoff 

14. The Tabulating Machine was first used in: 
A) US Army 
B) British Parliament 
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Past Papers Questions 

1. Charles Babbage is the father of computer was an English polymath. 

2. The term 'Computer' is derived from Latin. 

3. Father of C 'programming language' Dennis Ritchie. 

4. Allen Turing is the father of computer science. 

5. IBM first pioneered floppy disc. 

6. PC was originally a trademark of IBM. 

7. SPSS (Statistical Package for the Social Sciences) developed by IBM. 

8. ENIAC was the first truly electronic computer. 

9. The first computer virus Brain. 

10. Marcian Hoff produced the first microprocessor named as 4004. 

11. Hewlett Packard (HP) famous computer company was born in a garage near Palo 

Alto. California. 

12. Abacus often referred to as the ancient computers. 

13. AutoCAD is used in architectural design. 
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Introduction to Computer 
What is a Computer? 

A computer is an electronic device that accepts input, processes it according to a set of instructions 
(software), and produces output. It can also store data for future use and retrieve it when needed. 
Computers follow logical steps known as algorithms to perform tasks ranging from simple 
calculations to complex problem-solving. 

Basic Functions of a Computer: 

• Input: Receiving data and instructions from devices like keyboard, mouse, or sensors
• Processing: Performing calculations or operations using the Central Processing Unit

(CPU)
• Storage: Saving data temporarily (RAM) or permanently (Hard Drive, SSD)
• Output: Displaying or sending results to output devices such as monitors, printers, or

speakers 

Definition: 

"A computer is a programmable machine that stores, retrieves, and processes data based on a set 
of commands." – General Definition 

Key Characteristics with Examples: 

• Speed: Computers can perform millions of operations per second. For instance, a simple
calculator on a phone can solve complex equations instantly.

• Accuracy: Unlike humans, computers do not make errors unless the input or logic is
wrong.

• Automation: Once programmed, a computer can complete tasks without human
intervention (e.g., automatic backup of data at midnight).

• Storage Capacity: Computers can store large amounts of data. A 1TB hard drive can store
around 250,000 songs.

• Versatility: A computer can switch from word processing to gaming or video editing by
simply running different software.

Real-Life Examples: 

• In Education: Used for online learning, research, presentations
• In Banking: ATM machines process transactions
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Judgment Can make moral and ethical decisions Cannot judge, only follows logic 

Computers are tools that extend human capability but lack emotional intelligence and ethical 
reasoning. 

Glossary 

Term Definition 

Computer An electronic device that processes data into information. 
Data Raw facts and figures without any context. 
Information Organized or processed data that is meaningful and useful. 
IT (Information 
Technology) 

The use of computers and software to manage information. 

Hardware The physical components of a computer system. 
Software A set of instructions or programs that tell a computer what to 

do. 
Input Device Devices used to enter data into a computer (e.g., keyboard, 

mouse). 
Output Device Devices that show the result of processed data (e.g., monitor, 

printer). 
CPU Central Processing Unit – the brain of the computer where 

processing takes place. 
RAM Random Access Memory – temporary memory used during 

processing. 
ROM Read-Only Memory – permanent memory that contains startup 

instructions. 
Operating System Software that manages computer hardware and software 

resources. 
Application Software Software used for specific tasks (e.g., Word processors, 

browsers). 
Network A system of connected computers and devices that share data. 

Internet A global network connecting millions of computers for 
information sharing. 

AI Artificial Intelligence – computers mimicking human 
intelligence. 
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MCQ- Introduction to Computer 

1. What is a computer? 
A) A machine that washes clothes 
B) A device that flies 
C) An electronic machine that processes 
data 
D) A storage device 

2. Which of the following is not a basic 
function of a computer? 
A) Input 
B) Processing 
C) Transportation 
D) Output 

3. Temporary data is stored in: 
A) SSD 
B) Hard disk 
C) RAM 
D) CD-ROM 

4. What does CPU stand for? 
A) Computer Processing Unit 
B) Central Processing Unit 
C) Control Process Utility 
D) Core Processing Unit 

5. Which of the following is an example of 
input device? 
A) Monitor 
B) Printer 
C) Scanner 
D) Speaker 

6. What does ROM store? 
A) Temporary instructions 
B) Operating system 
C) Startup instructions 
D) Audio files 

7. Which is an example of application 
software? 
A) Windows 
B) Linux 
C) MS Word 
D) BIOS 

8. What is the role of a modem? 
A) Save files 
B) Run programs 
C) Connect to internet 
D) Increase speed 

9. Information is: 
A) Raw data 
B 

10. Which of the following is qualitative 
data? 
A) 45 
B) 97.5 
C) Green 
D) 100°C 

11. Which of these is not an output 
device? 
A) Monitor 
B) Printer 
C) Mouse 
D) Speaker 

12. What type of computer is used in MRI 
and ECG machines? 
A) Analog 
B) Digital 
C) Hybrid 
D) Super 

13. Example of a general-purpose 
computer: 
A) ATM 
B) Traffic light controller 
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Past Papers Questions 

1. When sound is included in the animations, it becomes Multimedia. 

2. Multimedia software is used to create visual presentations with the help of audio and 

video clips. 

3. Adobe flash player is an example of multimedia software. 

4. Encyclopedia is an example of reference. 

5. Graphic software is used to draw pictures, 3D-images and animation. 

6. 3D printing is also known as additive manufacturing. 

7. Image viewer is a program that is used to view and manage images. 

8. Adobe Acrobat convert the file in pdf. 

9. The most commonly used type of software in industry, offices and WAN is Horizontal 

market software. 

10. Operating system, editors and debuggers comes under system software. 

11. Many programmers call writing the software Program is Coding. 

12. Checks that should be performed before downloading a software include System 

requirements verification. 

13. Generally, the most useful help document during the installation of software is License 

information. 

14. Licensed CD/DVD can be the most trusted source to the software installation. 

15. Generally one of the best practices during the installation of software is close all the user's 

running programs. 

16. Most of the installation begin by auto run feature otherwise the installation can be started 

by selecting Setup.exe 

17. The software that are available free of cost is called Freeware. 

18. Another name for free software is Public Domain Software. 

19. If you want to repair software bug, it is available free of cost on internet called Free 

Tutorial. 

20. Installation is used to store software in the computer. 
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Data Communication 
Introduction to Data Communication 

Data Communication is the exchange of digital information between two or more devices using a 
medium such as cables, fiber optics, or wireless signals. These devices can be computers, 
smartphones, sensors, or other digital systems. 

Definition: Data communication is the process of using computing and telecommunication 
technologies to transmit data between devices or systems. 

It is essential in enabling modern applications such as emails, messaging, cloud storage, and 
internet browsing. Without it, modern digital services could not function. 

Importance of Data Communication 

Data communication plays a vital role in every sector: 

• Education: Supports e-learning, online exams, digital libraries 
• Healthcare: Enables telemedicine, remote diagnostics, data sharing 
• Business: Drives communication tools like email, video calls, data transfer 
• Government: Supports secure data systems and public service portals 
• Daily Life: Powers online banking, social media, streaming, gaming 

In today’s digital world, data communication is as essential as electricity. 

Basic Components of Data Communication 

Every communication system has these five core components: 

Component Role 

Message The data (text, image, video, etc.) to be communicated 

Sender The device or person initiating the message 

Receiver The device or person receiving the message 
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DATA COMMUNICATION –
MCQs 

1. Which component of data communication 
determines the format and timing of 
messages? 

(a) Protocol 
(b) Sender 
(c) Receiver 
(d) Medium 

2. In which mode of transmission is data 
sent in both directions simultaneously? 

(a) Simplex 
(b) Half Duplex 
(c) Full Duplex 
(d) Asynchronous 

3. The term "bit synchronization" is most 
closely associated with which encoding 
method? 

(a) NRZ 
(b) AM 
(c) Manchester 
(d) FM 

4. Which signal type is ideal for transmitting 
digital data over analog media? 

(a) Analog 
(b) Binary 
(c) Pulse 
(d) Modulated 

5. Which of the following transmission 
media provides the highest speed and 
security? 

(a) Twisted pair 
(b) Coaxial cable 
(c) Fiber optics 
(d) Radio waves 

6. Which device provides wireless access to 
a wired LAN? 

(a) Router 
(b) Modem 
(c) Access Point 
(d) Switch 

7. Which of the following allows secure 
communication over a public network? 

(a) PAN 
(b) LAN 
(c) VPN 
(d) MAN 

8. Which network type connects computers 
within a school? 

(a) PAN 
(b) MAN 
(c) WAN 
(d) LAN 

9. What ensures data integrity in the 
presence of transmission errors? 

(a) Modulation 
(b) Encoding 
(c) Error detection 
(d) Compression 

10. What method involves adding extra bits 
to detect data errors? 

(a) CRC 
(b) NRZ 
(c) Ping 
(d) Protocol 

11. Which OSI layer is responsible for 
routing data using logical addresses? 

(a) Network 
(b) Data Link 
(c) Physical 
(d) Session 
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Past Papers Questions: 

1. Multiplexing is a technique that is used to send more than one call over a single 
line. 

2. The inner core of an optical fiber is Glass or plastic in composition. 

3. Cable consists of an inner copper core and a second conducting outer sheath is 
Coaxial. 

4. A television broadcast is an example of SIMPLEX transmission. 

5. Full duplex transmission mode is the communication two-way with the channel 
being used by both connected devices simultaneously. 

6. Optical fiber is made of purified Silica. 
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Network and Internet 
Introduction to Internet and Networking 

What is the Internet? 

The Internet is a vast global communication network that connects millions of private, public, academic, 
business, and government networks. It provides access to a wealth of knowledge, tools, entertainment, 
communication platforms, and services. This interconnectivity is made possible through protocols that 
standardize how data is sent and received across different systems and devices. 

At its core, the Internet works like a postal system for digital information, allowing data to be packaged, 
addressed, transmitted, and delivered across the world in seconds. 

Key Characteristics of the Internet: 

• Decentralized: No single entity owns or governs it entirely. 
• Scalable: Easily grows to support billions of users. 
• Open Standards: Uses protocols like TCP/IP that are universally accepted. 

What is Networking? 

Networking is the interconnection of computers and devices using either cables (wired) or wireless 
signals. It allows for the exchange of data, the sharing of resources (like printers and files), and 
communication through applications such as email or video conferencing. 

Networks are the backbone of the Internet, allowing devices to talk to each other within homes, schools, 
businesses, and beyond. 

Basic Concepts in Networking: 

• Node: Any device connected to a network (computer, printer, router). 
• Link: The communication pathway between nodes. 
• Bandwidth: The amount of data that can pass through a network connection in a given time. 
• Latency: The delay before a data transfer begins. 

Types of Communication Models: 

• Client-Server Model: Centralized model where a client requests and a server provides services. 
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IoT (Internet of Things): Smart homes, wearable devices 

Glossary 

Term Definition 

IP Address Unique identifier assigned to a device on the internet 

DNS System that converts domain names to IP addresses 

ISP Organization that provides internet access 

Protocol A standard set of rules for data communication 

Firewall System designed to prevent unauthorized access 

Router Device that directs data across networks 

TCP/IP Protocols used for data transmission over the internet 

LAN Network in a small area like a home or school 

HTTP Protocol used to transfer web pages 

Phishing Online fraud attempt to steal personal data 

Packet Small unit of data transmitted over a network 

Modem Device that connects your network to the internet 

Malware Malicious software that harms your device 

Topology Layout of how computers are connected in a network 

 

. 
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MCQ – Network and Internet 

1. What is the main function of 
protocols like TCP/IP in the 
Internet?  

A) Encrypt user data 
B) Define rules for data transmission 
C) Block suspicious content 
D) Allocate bandwidth 

2. Which characteristic of the Internet 
allows it to function without a single 
point of failure?  

A) Open Standards 
B) Centralized Control 
C) Decentralization 
D) Firewalls 

3. In networking, what is a "node"?  

A) A server only 
B) Any connected device 
C) Only routers and switches 
D) A protocol address 

4. What does latency in a network refer 
to?  

A) Number of users 
B) Delay before data transfer starts 
C) Maximum speed 
D) Device location 

5. Which communication model 
features both client and server roles 
in every device?  

A) Star topology 
B) Hybrid model 
C) Peer-to-Peer 
D) Client-Server 

6. What year was ARPANET 
launched?  

A) 1973 
B) 1969 
C) 1983 
D) 1990 

7. Who invented the first network-
based email system?  

A) Vint Cerf 
B) Bob Kahn 
C) Ray Tomlinson 
D) Tim Berners-Lee 

8. Which of the following marked the 
official birth of the Internet?  

A) Launch of Google 
B) Introduction of WWW 
C) Standardization of TCP/IP 
D) Creation of DNS 

9. What was the name of the first 
graphical web browser?  

A) Netscape 
B) Internet Explorer 
C) Mosaic 
D) Firefox 

10. What technological development 
enabled the rise of mobile internet?  

A) Modem 
B) Fiber optics 
C) Smartphones 
D) DNS 

11. Which network type would be used 
to connect devices in a home?  
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Past Papers Questions 
1. Ethernet cable type of connection would be used to connect a printer directly to a 

network. 

2. The communication protocol used for Internet is TCP/IP. 

3. 67 percentage of world's population has internet access. 

4. Internet is commonly known as WAN. 

5. Father of internet is Vincent Cerf. 

6. Internet is Network of network. 

7. SMTP protocol provides email facility among different hosts. 

8. Every computer connected to an intranet or extranet must have a distinct Proxy 

server. 

9. The Internet developed in 1969 with the creation of ARPANET, or the Advanced 

Research Projects Agency Network. 

10. The first Network is called ARPANET. 

11. Default port of HTTP Is 80. 

12. AVI (Audio Video Interleaved) is widely used for transmitting streaming videos 

data on the internet. 

13. Internet 2 is it research consortium for advance internet and research and 

development. 

14. URL is used for webpage and web address. 

15. URL is the name for a Web page Address. 

16. By using a firewall, the risk of unauthorized computer system access is reduced 

when connected to an internet. 

17. Search engine maintain a date base of webpages containing information on 

variety of topics. 

18. Commonly used method to access internet is Broadband with Coaxial Cable, 

Fiber optics or Wi-Fi Copper Wires. 

19. Domain Server is down is not a major reason for an email bounce. 

20. Website used intonation is called Tracker. 
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Internet Browsing 
What is Internet Browsing? 

Internet browsing, also known as web browsing, refers to the process of navigating and accessing 
content on the World Wide Web using a software tool called a web browser. 

How It Works: 

• A user opens a web browser (e.g., Chrome, Firefox, Safari). 
• They type a web address (URL) into the address bar. 
• The browser sends a request to a web server to fetch the required web page. 
• The server responds with data (HTML, CSS, images, etc.) which the browser displays to the 

user. 

Purpose of Internet Browsing: 

• To access websites, articles, images, videos, and web applications. 
• To search for information using search engines like Google, Bing, or Yahoo. 
• To use online services such as email, social media, banking, and e-learning. 

Common Activities While Browsing: 

• Reading news or blogs 
• Watching YouTube videos 
• Checking weather forecasts 
• Sending emails via webmail (like Gmail) 
• Shopping online 

Devices Used for Browsing: 

• Desktop and laptop computers 
• Smartphones and tablets 
• Smart TVs and other internet-enabled devices 

Evolution and History of Web Browsers 

Web browsers have come a long way since the early days of the internet. They are now essential tools 
for accessing and interacting with online content. 
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MCQ – Internet Browsing 

1. What is Internet browsing?  

A) Creating websites 
B) Programming web servers 
C) Accessing the World Wide Web 
via a browser 
D) Managing email accounts 

2. What is the main role of a web 
browser?  

A) Send emails 
B) Provide cloud storage 
C) Retrieve and display web content 
D) Host websites 

3. Which of the following is NOT a 
purpose of internet browsing?  

A) Playing offline games 
B) Accessing websites 
C) Using email and social media 
D) Online shopping 

4. What software is required for 
browsing the internet? A) Antivirus 
B) Web browser 
C) Firewall 
D) Operating system 

5. Which device is commonly used for 
internet browsing? A) Printer 
B) Smartphone 
C) Scanner 
D) Webcam 

6. What does a URL represent? A) User 
Recognition Level 
B) Universal Resource Lock 
C) Uniform Resource Locator 
D) Universal Routing Link 

7. What is typically typed into the 
address bar of a browser? A) IP 
address only 
B) Website name 
C) Username 
D) MAC address 

8. What happens after a user enters a 
web address?  

A) Computer shuts down 
B) Browser sends request to server 
C) Files are deleted 
D) Password prompt appears 

9. Which browser was the first to 
support graphics and text?  

A) Internet Explorer 
B) Chrome 
C) Mosaic 
D) Firefox 

10. Who developed the first web 
browser?  

A) Larry Page 
B) Bill Gates 
C) Tim Berners-Lee 
D) Steve Jobs 

11. Which browser became dominant in 
the early 2000s?  

A) Safari 
B) Netscape 
C) Internet Explorer 
D) Chrome 

12. Which browser is known for strong 
privacy features?  
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Past Papers Questions 

1. Internet is mostly used for Email. 

2. In 1971 first ever email sent. 

3. In email address name of the email service provider comes after @sign. 

4. Email consist of two parts one is username and other is password. 

5. In email account, address book contains a list of name and email addresses. 

6. @ is a sign of email. @ Symbol is essential for email. 

7. Username is a unique name chosen by a user while creating an email. 

8. Answering a received Email is called Reply an Email. 

9. Slowest response while collecting data is called Email. 

10. Email bankruptcy is deleting or ignoring all emails older than a certain date, due to an 

overwhelming volume of messages. 

11. Email fatigue is a state that occurs when consumers get tired of receiving email. They 

start to ignore messages, delete them, unsubscribe, or even worse - they send your 

emails to their spam folder. 

12. Tim Berners Lee gave the idea to combine the internet with Hypertext concept. 

13. Exe. type of file cannot be attached with email. 

14. Google is the largest internet search engine. 

15. Google + is an example of flicker. 

16. Bing is the second largest search engine developed by Microsoft. 

17. Yahoo is the third largest search engine. 

18. Oldest search engine of internet is Yahoo. Founded in 1995. 

19. Search engine, which is most popular in China, is Baidu. And 4th largest search engine 

in world. 

20. Twitter is a social network service. 

21. Yahoo is a news website and search engine. 

22. Hotmail, Gmail and Yahoo are Email server. 

23. First widely available web browser, Mosaic released in 1993. 

24. The browser cache keeps a list of web pages you have visited in the current session. 
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Windows 
What is Windows? 

Microsoft Windows is a graphical operating system developed by Microsoft. It provides a user-
friendly environment that enables users to interact with their computer using windows, icons, menus, 
and a pointer (mouse cursor), often referred to as the WIMP model. 

Originally launched in 1985 as a graphical shell for MS-DOS, Windows has evolved into the most widely 
used desktop operating system in the world. 

Basic Functions of Windows: 

• Provides a graphical interface (GUI) to access files and applications
• Manages system resources like memory, storage, and connected devices
• Supports multitasking and multiple user environments
• Ensures security with user authentication and system updates
• Offers accessibility features and customization options

Real-Life Examples of Windows Use: 

• Students using Windows for writing assignments and attending virtual classes
• Office workers using Excel and PowerPoint
• Designers using Adobe Creative Suite on Windows PCs

History and Versions 

The history of Windows began in the mid-1980s and has seen many changes in both design and 
functionality. Windows has developed through decades of innovation, continuously adapting to meet 
user needs. 

Timeline of Key Windows Releases: 

Version Release 
Year Highlights 

Windows 1.0 1985 First GUI shell for MS-DOS; introduced overlapping windows 
concept 

Windows 3.1 1992 Widely adopted; introduced TrueType fonts, multimedia, and 
File Manager 
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Popular Operating Systems Compared: 

Feature Windows macOS Linux Android iOS 

Developed by Microsoft Apple Open Source 
(Community) 

Google Apple 

Interface Graphical 
(Start 
Menu, 
Taskbar) 

Graphical 
(Dock, 
Finder) 

Varies by 
distro 

Touchscreen-
focused 

Touchscreen-
focused 

Target Users Home, 
Business, 
Education 

Creative, 
Design, 
Business 

Developers, 
Servers 

Mobile users Apple mobile 
users 

Customizability Moderate Low High Low to 
moderate 

Low 

Security Regular 
updates, 
antivirus 
needed 

Highly 
secure 

Very secure 
(open-source) 

Secure with 
Play Store 
policies 

Secure with 
App Store 
policies 

Cost Paid or 
pre-
installed 

Paid (with 
Apple 
devices) 

Free Free Paid (with 
Apple 
devices) 

1. Windows vs. macOS 

• Windows is available on a wide variety of hardware from different manufacturers, offering 
flexibility. 

• macOS runs only on Apple hardware, offering tight integration and a clean user experience. 
• Windows is more widely used in offices and schools, while macOS is popular among creative 

professionals. 

2. Windows vs. Linux 

• Linux is an open-source system that is free to use and can be customized extensively. 
• Windows is easier for beginners, while Linux is often favored by developers and advanced users. 
• Linux is more commonly used on servers, while Windows dominates the consumer desktop 

market. 
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MCQ – Windows 

1. What is Microsoft Windows?  

A) An internet browser 
B) A programming language 
C) A graphical operating system 
D) A hardware device 

2. What model does Windows use for 
user interaction?  

A) WIMP (Windows, Icons, Menus, 
Pointer) 
B) GUI (Graphical User Interface) 
only 
C) CLI (Command Line Interface) 
D) DOS 

3. What is the primary function of 
Windows?  

A) Run antivirus 
B) Browse the internet only 
C) Manage hardware and software 
D) Design websites 

4. Which of the following is a basic 
function of Windows?  

A) Creating hardware components 
B) Providing a command line 
interface only 
C) Managing system resources 
D) Accessing only emails 

5. How does Windows support 
multitasking?  

A) Allows only one app to run 
B) Uses two processors 
C) Allows multiple applications to 

run simultaneously 
D) Runs without internet 

6. Which version of Windows 
introduced the Start Menu?  

A) Windows 3.1 
B) Windows 95 
C) Windows XP 
D) Windows ME 

7. Which Windows version was 
released in 2001?  

A) Windows ME 
B) Windows 98 
C) Windows XP 
D) Windows Vista 

8. What major interface change was 
introduced in Windows Vista?  

A) Start Menu 
B) Snap Layouts 
C) Aero Glass interface 
D) Cortana 

9. What is a major feature of Windows 
7?  

A) Poor performance 
B) File Manager introduction 
C) Improved speed and usability 
D) Centered Start Menu 

10. Which version introduced the tile-
based Start screen?  

A) Windows 7 
B) Windows 10 
C) Windows 8 
D) Windows XP 
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Past Papers Question 

1. File manager Helps user to locate, rename, move, copy, and delete files. 

2. Disk cleanup is a utility program. 

3. Disk cleanup is used as a disk scanner in Microsoft window. 

4. Window explorer is utility program. 

5. Add or remove is utility program. 

6. The most important examples of operating systems are Microsoft Windows, DOS, and 
UNIX, Linux, and Mac OS etc. 

7. From ROM BIOS the 1st computer instruction available on boot up. 

8. BIOS are used for Loading Operating system. 

9. BIOS is stored in Flash Memory Chip. 

10. POST is program run by BIOS to check hardware components are working properly 
while computer is Turned ON. 

11. The process of starting an operating system when the user turns on a computer is 
known as Booting. 

12. The primary purpose of an operating system is to make the most efficient use of the 
computer hardware. 

13. Help Menu is available at Start button. 

14. In Microsoft Window 7, Gadget can give you information about weather. 

15. Weather, Date and Time and News Gadget in Window (Recycle Bin is not Gadget). 

16. "Add new hardware" option exists in control panel. 

17. Window 8 does not have Start button. 

18. From Control Panel user account can be changed. 



MS OFFICE 

PUBLICATIONS 
L E T ’ S   M A K E   I T   H A P P E N 

+92 333 2605045 , +92 342 4470091

https://www.instagram.com/mkpreparations

https://youtube.com/@mkpreparations

https://www.facebook.com/MkPreparations

https://www.tiktok.com/@mkpreparations

Join Us For All Jobs Preparation



 

  MK PREPARATIONS  

 

P a g e  0 | 9 

 

  

7
. M

S O
ffice

 
  

M 
K 
 

P 
R 
E 
P 
A 
R 
A 
T 
I 
O 
N 
S 

MK PREPARATIONS: Let’s Make It Happen 
+92 333 2605045, +92 342 4470091 
 

Microsoft Office (MS Office) 
Microsoft Office is a software which was developed by Microsoft in 1988. This Office suite 
comprises various applications which form the core of computer usage in today’s world. 

MS Office Applications & its Functions 

Currently, MS Office 2016 version is being used across the world and all its applications are 
widely used for personal and professional purposes. 

Discussed below are the applications of Microsoft Office along with each of their functions. 

1. MS Word 

• First released on October 25, 1983  
• Extension for Doc files is “.doc” 
• It is useful in creating text documents 
• Templates can be created for Professional use with the help of MS Word 
• Work Art, colours, images, animations can be added along with the text in the same file 

which is downloadable in the form of a document 
• Authors can use for writing/ editing their work 

2. MS Excel 

• Majorly used for making spreadsheets 
• A spreadsheet consists of grids in the form of rows and columns which is easy to manage 

and can be used as a replacement for paper 
• It is a data processing application 
• Large data can easily be managed and saved in tabular format using MS Excel 
• Calculations can be done based on the large amount of data entered into the cells of a 

spreadsheet within seconds 
• File extension, when saved in the computer, is “.xls” 

3. MS PowerPoint 

• It was released on April 20, 1987 
• Used to create audiovisual presentations 
• Each presentation is made up of various slides displaying data/ information 
• Each slide may contain audio, video, graphics, text, bullet numbering, tables etc. 
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Microsoft Office Versions 

When the Office suite was first released, it was entirely devoted for usage in computer systems 
but later with time the Office suite was modified for use in Laptops, Tablets and Mobile phones. 

Given below are the various versions of Microsoft Office along with the years in which the 
version was released: 

All the above-mentioned dates are for the Office suite released for Windows. Apart from these, 
the versions Online, for Mac and for Mobile Phones were released separately 

  

Version name Release Date/ Year 

Microsoft Office for Windows October 1990 

Microsoft Office 3.0 August 30, 1992 

Microsoft Office 4.x 1994 

Microsoft Office 1995 August 24, 1995 

Microsoft Office 1997 1997 

Microsoft Office 2000 June 7, 1997 

Microsoft Office XP May 31, 2001 

Microsoft Office 2003 October 21, 2003 

Microsoft Office 2007 January 30, 2007 

Microsoft Office 2010 June 15, 2010 

Microsoft Office 2013 January 30, 2012 

Microsoft Office 2016 September 22, 2015 
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. 

MCQ– Microsoft Office 

1. When was Microsoft Office first 
developed? 
A) 1995 
B) 1988 
C) 1992 
D) 2001 

2. Which company developed 
Microsoft Office? 
A) Apple 
B) IBM 
C) Microsoft 
D) Google 

3. What is the extension of MS Word 
files? 
A) .xls 
B) .doc 
C) .ppt 
D) .txt 

4. MS Word is primarily used to: 
A) Create presentations 
B) Manage databases 
C) Write and edit documents 
D) Send emails 

5. Which MS Office application is used 
to create spreadsheets? 
A) MS Word 
B) MS Excel 
C) MS Access 
D) MS Outlook 

6. What is the extension of files created 
in MS Excel? 
A) .doc 
B) .ppt 

C) .xls 
D) .accdb 

7. MS Excel organizes data in: 
A) Pages 
B) Slides 
C) Grids (rows and columns) 
D) Paragraphs 

8. Which MS Office application is used 
to create presentations? 
A) MS Word 
B) MS Outlook 
C) MS PowerPoint 
D) MS Excel 

9. What is the file extension for MS 
PowerPoint? 
A) .ppt 
B) .doc 
C) .xls 
D) .pst 

10. Presentations in PowerPoint consist 
of: 
A) Pages 
B) Slides 
C) Tables 
D) Worksheets 

11. MS Access is used for: 
A) Sending emails 
B) Creating spreadsheets 
C) Managing databases 
D) Writing notes 

12. What is the file extension of MS 
Access? 
A) .docx 
B) .pst 



 
 

  MK PREPARATIONS  

 

P a g e  1 | 9 

 

  

7
. M

S O
ffice

 
    

M 
K 
 

P 
R 
E 
P 
A 
R 
A 
T 
I 
O 
N 
S 

MK PREPARATIONS: Let’s Make It Happen 
+92 333 2605045, +92 342 4470091 
 

Past Papers Questions 

1. Outlook Tasks use for Manage to-do items. 

2. PST is the filename extension for an outlook data file. 

3. Messaging client term describes outlook. 

4. Microsoft outlook is an Email service. 

5. Outlook Software application was not part of the first version of Microsoft Office. 

6. MS Access is a DBMS type of software. 

7. MS Access can be used by data architects, software developers and power users. 
Store data in the form of tables are the major use of MS Access. 

8. MS Access is an example of Application Software. 

9. MS Access is famous brand of Microsoft Company. 

10. MS Access is a product of Microsoft which is not available in Linux operating 
system. 

11. 1992 first version of MS Access was released. 

12. In MS-Access to create a new table, in which method you, do not need to specific the 
field type and size (Create Table by Entering Data). 

13. MDB is the extension of Microsoft access. 

14. TEXT data type allows alphanumeric characters and special symbols in MS-
ACCESS. 

15. Picture is not a valid data type in MS Access. 

16. To create a form Wizard, we use 4 Tables. (Columnar, Tabular, Data Sheet and 
Justified). 

17. From Wizard, 1h MS-Access can build form that can display field from MANY 
tables. 
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Microsoft Word (MS Word) 
With Word you can: 

 Create a document from scratch or from a template . 
 Add text, images, art, and videos. 
 Research a topic and find credible sources. 
 Access your documents from a computer, tablet, or phone via OneDrive. 
 Share your documents and collaborate with others. 
 Track and review changes. 

Create a new document 

1. On the File tab, select New. 
2. Select Blank document, or double-click a template image or type the kind of document into 

the Search for online templates box and press Enter. 
Tip:  For practice using Word features, try a learning guide like Welcome to Word or Insert your 
first table of contents. 

Add and format text 

1. Click on your new blank page and type some text. 

  

https://create.microsoft.com/word-templates
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Pick the effect you want. 

3. Click outside of your text box to see the effect. 

Rotate it 

1. Select the WordArt, and then drag the circular rotation handle at the top of the box. 

2. To flip WordArt or rotate it 90 degrees, go to Shape Format or Drawing Tools 
Format > Rotate, and then select an option. 
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MCQ – Microsoft Word 

1. Which tab is used to create a new 
blank document in Word? 
A) Home 
B) File 
C) Insert 
D) View 

2. What tab do you use to insert 
pictures, tables, and charts? 
A) Design 
B) View 
C) Insert 
D) Format 

3. Which tool lets you copy formatting 
from one part of text to another? 
A) Format Copier 
B) Style Brush 
C) Format Painter 
D) Font Cloner 

4. How can you add text to a Word 
document? 
A) Click Insert > Text Field 
B) Drag and Drop 
C) Place cursor and type 
D) Click Format > Add Text 

5. How do you replace existing text in 
Word? 
A) Click Edit > Replace 
B) Select and type over it 
C) Use the Erase Tool 
D) Click Format > Replace 

6. Which ribbon tab includes Bold, 
Italic, and Underline? 
A) View 
B) Insert 
C) Home 
D) Format 

7. What does Word use to store and 
sync files online? 
A) Outlook 
B) Bing 
C) OneDrive 
D) Skype 

8. Which format is best for adding 
bullet points? 
A) Insert tab 
B) Home tab 
C) Layout tab 
D) Design tab 

9. What feature automatically saves 
your work in OneDrive? 
A) AutoBackup 
B) AutoStore 
C) AutoSave 
D) QuickSave 

10. To insert a table in Word, go to: 
A) Insert > Table 
B) File > Table 
C) Design > Table 
D) Layout > Table 

11. What allows you to wrap text around 
a picture? 
A) Picture Tools > Layout Options 
B) View > Wrap Text 
C) Format > Fit Text 
D) Insert > Text Options 

12. What is WordArt used for? 
A) Data entry 
B) Artistic text design 
C) Font replacement 
D) Document templates 

13. Which option rotates a picture or 
shape? 
A) Insert > Rotate Image 

B) Layout > Turn 
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Microsoft Excel (MS Excel) 
What is Excel? 

Excel makes it easy to crunch numbers. With Excel, you can streamline data entry with AutoFill. Then, 
get chart recommendations based on your data, and create them with one click. Or easily spot trends and 
patterns with data bars, color coding, and icons. 

Create a workbook 

1. Open Excel. 

2. Select Blank workbook. Or press Ctrl+N. 

Enter data 

To manually enter data: 

1. Select an empty cell, such as A1, and then type text or a number. 

2. Press Enter or Tab to move to the next cell. 

To fill data in a series: 

1. Enter the beginning of the series in two cells: such as Jan and Feb; or 2014 and 2015. 
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AutoSum vertically 

In the figure above, the AutoSum feature is seen to automatically detect cells B2:B5 as the range 
to sum. All you need to do is press ENTER to confirm it. If you need to add/exclude more cells, 
you can hold the Shift Key + the arrow key of your choice until your selection matches what you 
want. Then press Enter to complete the task. 

Intelligence function guide: the SUM(number1,[number2], …) floating tag beneath the function 
is its Intelligence guide. If you click the SUM or function name, it will change o a blue hyperlink 
to the Help topic for that function. If you click the individual function elements, their representative 
pieces in the formula will be highlighted. In this case, only B2:B5 would be highlighted, since 
there is only one number reference in this formula. The Intellisense tag will appear for any 
function. 
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Number formats 

To see all available number formats, select the Dialog Box Launcher next to Number on 

the Home tab in the Number group. 

Format Description 

General The default number format that Excel applies when you type a number. For the most 
part, numbers that are formatted with the General format are displayed just the way 
you type them. However, if the cell is not wide enough to show the entire number, 
the General format rounds the numbers with decimals. The General number format 
also uses scientific (exponential) notation for large numbers (12 or more digits). 

Number Used for the general display of numbers. You can specify the number of decimal 
places that you want to use, whether you want to use a thousands separator, and how 
you want to display negative numbers. 

Currency Used for general monetary values and displays the default currency symbol with 
numbers. You can specify the number of decimal places that you want to use, 
whether you want to use a thousands separator, and how you want to display 
negative numbers. 

Accounting Also used for monetary values, but it aligns the currency symbols and decimal 
points of numbers in a column. 

Date Displays date and time serial numbers as date values, according to the type and 
locale (location) that you specify. Date formats that begin with an asterisk (*) 
respond to changes in regional date and time settings that are specified in Control 
Panel. Formats without an asterisk are not affected by Control Panel settings. 
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3. Use a different formula to find days. 

Now we need to find the number of remaining days. We'll do this by writing a different kind of 
formula, shown above. This formula subtracts the first day of the ending month (5/1/2016) from 
the original end date in cell E17 (5/6/2016). Here's how it does this: First the DATE function 
creates the date, 5/1/2016. It creates it using the year in cell E17, and the month in cell E17. Then 
the 1 represents the first day of that month. The result for the DATE function is 5/1/2016. Then, 
we subtract that from the original end date in cell E17, which is 5/6/2016. 5/6/2016 minus 5/1/2016 
is 5 days. 

Warning: We don't recommend using the DATEDIF "md" argument because it may calculate 
inaccurate results. 

4. Optional: Combine three formulas in one. 

You can put all three calculations in one cell like this example. Use ampersands, quotes, and text. 
It’s a longer formula to type, but at least it’s all in one. Tip: Press ALT+ENTER to put line 
breaks in your formula. This makes it easier to read. Also, press CTRL+SHIFT+U if you can’t 
see the whole formula. 
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In general, it's best to place constants in individual cells where they can be easily changed if 
needed, then reference those cells in formulas. 

Using references in Excel formulas 

A reference identifies a cell or a range of cells on a worksheet, and tells Excel where to look for 
the values or data you want to use in a formula. You can use references to use data contained in 
different parts of a worksheet in one formula or use the value from one cell in several formulas. 
You can also refer to cells on other sheets in the same workbook, and to other workbooks. 
References to cells in other workbooks are called links or external references. 

The A1 reference style 

By default, Excel uses the A1 reference style, which refers to columns with letters (A through 
XFD, for a total of 16,384 columns) and refers to rows with numbers (1 through 1,048,576). 
These letters and numbers are called row and column headings. To refer to a cell, enter the 
column letter followed by the row number. For example, B2 refers to the cell at the 
intersection of column B and row 2. 

To refer to Use 

The cell in column A and row 10 A10 

The range of cells in column A and rows 10 through 20 A10:A20 

The range of cells in row 15 and columns B through E B15:E15 

All cells in row 5 5:5 

All cells in rows 5 through 10 5:10 

All cells in column H H:H 

All cells in columns H through J H:J 

The range of cells in columns A through E and rows 10 through 20 A10:E20 
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examples use the formula =SUM(Sheet2:Sheet6!A2:A5) to add cells A2 through A5 on 
worksheets 2 through 6. 

 Insert or copy     If you insert or copy sheets between Sheet2 and Sheet6 (the endpoints in 
this example), Excel includes all values in cells A2 through A5 from the added sheets in the 
calculations. 

 Delete     If you delete sheets between Sheet2 and Sheet6, Excel removes their values from 
the calculation. 

 Move     If you move sheets from between Sheet2 and Sheet6 to a location outside the 
referenced sheet range, Excel removes their values from the calculation. 

 Move an endpoint     If you move Sheet2 or Sheet6 to another location in the same workbook, 
Excel adjusts the calculation to accommodate the new range of sheets between them. 

 Delete an endpoint     If you delete Sheet2 or Sheet6, Excel adjusts the calculation to 
accommodate the range of sheets between them. 

The R1C1 reference style 

You can also use a reference style where both the rows and the columns on the worksheet are 
numbered. The R1C1 reference style is useful for computing row and column positions in 
macros. In the R1C1 style, Excel indicates the location of a cell with an "R" followed by a 
row number and a "C" followed by a column number. 

Reference Meaning 

R[-2]C A relative reference to the cell two rows up and in the same column 

R[2]C[2] A relative reference to the cell two rows down and two columns to the right 

R2C2 An absolute reference to the cell in the second row and in the second column 

R[-1] A relative reference to the entire row above the active cell 

R An absolute reference to the current row 

When you record a macro, Excel records some commands by using the R1C1 reference style. 
For example, if you record a command, such as selecting the AutoSum button to insert a 
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Some Sample Formulas 

Basic Formulas 

Formula Structure Explanation 

AVERAGE =AVERAGE(A2:A10) Returns a mathematical average of a given cell range 
COUNT =COUNT(A2:A10) Returns the count of the numbers in given cell range 
MAX =MAX(A2:A10) Finds the largest value in a given cell range 
MEDIAN =MEDIAN(A2:A10) Returns the median value, or middle value, in a given 

cell range 
MIN =MIN(A2:A10) Finds the smallest value in a given cell range 
SUM =SUM(A2:A10) Totals numbers in a given cell range 

Cell range A2:A10 is used above to indicate that each formula uses a cell range as it 
arguments 

Time Formulas 

Formula Structure Explanation 

TODAY =TODAY() Volatile – takes no arguments – returns today’s date 
NOW =NOW() Volatile – takes no arguments – returns today’s date and time 
DATEDIF =DATEDIF(Start 

Date, End Date, 
Unit) 

Returns the number of years, months or days between two dates 
• Start Date – date furthest in the past 
• Unit could be “Y” for years, “M” for months or “D” for days 
• Units must be in double quotes 
• This formula is NOT in the function library 

YEAR =YEAR(Date) • Returns the year portion of date 
• Example =YEAR(7/16/2005) would return 2005 

MONTH =MONTH(Date) • Returns the month portion of date 
• Example =MONTH(7/16/2005) would return 7 

DAY =DAY(Date) • Returns the day portion of date 
• Example =DAY(7/16/2005) would return 16 

Use a time formula and get an answer you didn’t expect? If you got a date and were expecting 
a number, remember to change the formatting from date to number. If you got a number and 
were expecting a date, change the formatting to date
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MCQ – Microsoft Excel 

1. What is the primary use of MS 
Excel?  

A) Writing letters 
B) Creating databases 
C) Making spreadsheets 
D) Designing graphics 

2. A file created in MS Excel is saved 
with which extension?  

A) .docx 
B) .ppt 
C) .xls 
D) .accdb 

3. What is the intersection of a row and 
a column in Excel called?  

A) Box 
B) Grid 
C) Cell 
D) Field 

4. Which feature in Excel allows you to 
perform calculations quickly on 
data?  

A) Chart 
B) Table 
C) Formula 
D) Text Box 

5. What is the vertical arrangement in 
an Excel spreadsheet called?  

A) Row 
B) Column 
C) Cell 
D) Grid 

6. In Excel, what do we call a group of 
cells?  

A) Matrix 
B) Table 
C) Range 
D) Section 

7. What tab is used to insert a chart in 
Excel?  

A) View 
B) Insert 
C) Data 
D) Layout 

8. How do you create a new Excel 
workbook?  

A) File > New > Workbook 
B) Home > Insert > Workbook 
C) View > New > Workbook 
D) Insert > File 

9. Which function in Excel is used for 
addition?  

A) =ADD 
B) =SUM 
C) =PLUS 
D) =TOTAL 

10. Which tab contains formatting tools 
like font and alignment?  

A) File 
B) Review 
C) Home 
D) Data 

11. What is the smallest unit in an Excel 
worksheet?  
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Past Papers Questions 

1. First spreadsheet program for personal computer was VisiCalc. 

2. VisiCalc is the oldest spreadsheet package. 

3. Microsoft introduced a spreadsheet program called Multiplan in 1982. 

4. Lotus 1-2-3 was a Spreadsheet. 

5. Lotus 1-2-3 is a popular DOS based spreadsheet package. 

6. Files created with Lotus 1-2-3 have extension 123. 

7. The first version of Excel 1.0 was released in 1985 only for Macintosh. 

8. First version of Microsoft Excel to run on Microsoft's new Windows operating system 
was released in 1987. 

9. Excel 2.0 is the first version of Microsoft Excel to run on Microsoft's new Windows. 

10. First 32-bit version of Microsoft Excel was Excel 95. 

11. Excel 2021 is the latest version of Excel. 

12. MS Excel is used to organize data. 

13. Microsoft Excel is a powerful Spreadsheet package. 

14. MS- EXCEL is based on WINDOWS. 

15. In MS Excel no of rows 1,048,576. And 16,384 columns. 

16. ROWS in excel are labelled as 1, 2, 3. 

17. Columns in excel are labelled as A, B, C. 

18. Excel uniquely identifies cells within a worksheet with a cell name Column letters and 
row numbers. 

19. In excel row corresponds to cell. 
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Microsoft PowerPoint (MS PowerPoint) 
What is PowerPoint? 

Overview 

 With PowerPoint on your PC, Mac, or mobile device, you can: 
 Create presentations from scratch or a template. 
 Add text, images, art, and videos. 
 Select a professional design with PowerPoint Designer. 
 Add transitions, animations, and cinematic motion. 
 Save to OneDrive, to get to your presentations from your computer, tablet, or phone. 
 Share your work and work with others, wherever they are. 

Create a presentation in PowerPoint 

Create presentations from scratch or start with a professionally designed, fully customizable 
template from Microsoft Create. 

Tip: If you have Microsoft Copilot it can help you create a presentation, add slides or images, 
and more. To learn more see Create a new presentation with Copilot in PowerPoint. 

Create a presentation 

1. Open PowerPoint. 
2. In the left pane, select New. 
3. Select an option: 

 To create a presentation from scratch, select Blank Presentation. 
 To use a prepared design, select one of the templates. 

https://go.microsoft.com/fwlink/?linkid=2226436
https://go.microsoft.com/fwlink/?linkid=2226436
https://support.microsoft.com/en-us/office/create-a-new-presentation-with-copilot-in-powerpoint-3222ee03-f5a4-4d27-8642-9c387ab4854d
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  Save in PowerPoint 

Save your presentation to OneDrive 

When you save your files to the cloud, you can share and collaborate with others, and get to your 
files from anywhere - on your computer, tablet, or phone. 

1. Select File > Save As. 

2. Select OneDrive. 

Save personal files to OneDrive - Personal, and work files to your company OneDrive. 
You can also save to another location, like your device. 

Offline 

When you're online, AutoSave is always on and saves your changes as you work. If at any time 
you lose your Internet connection or turn it off, any pending changes will sync as soon as you’re 

back online. 

https://www.facebook.com/sharer.php?u=https%3A%2F%2Fsupport.microsoft.com%2Fen-us%2Foffice%2Fcreate-a-presentation-in-powerpoint-422250f8-5721-4cea-92cc-202fa7b89617
https://www.facebook.com/sharer.php?u=https%3A%2F%2Fsupport.microsoft.com%2Fen-us%2Foffice%2Fcreate-a-presentation-in-powerpoint-422250f8-5721-4cea-92cc-202fa7b89617
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Give a presentation in PowerPoint 

Start a presentation 

 On the Slide Show tab select From Beginning. Now, if you are working with PowerPoint 
on a single monitor and you want to display Presenter view, in Slide Show view, on the 
control bar at the bottom left select the three dots, and then Show Presenter View. 

 To move to the previous or next slide, select Previous or Next. 

 To view all the slides in your presentation, select See all slides. 

Notes 

During your presentation, the speaker notes are visible on your monitor, but aren't visible to the 
audience. 

 The Notes pane is a box that appears below each slide. Tap it to add notes. 

  

 If you don’t see the Notes pane or it is completely minimized, click Notes on the task bar 
across the bottom of the PowerPoint window 
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Insert a picture into the slide master 

If you want a picture to appear on every slide of a specific type in your PowerPoint template, add 
it to the slide master.  

Insert a picture into the background 

If you want a picture to appear as background without affecting all slides in a Master, change the 
background settings for the slide.  
Add a background picture to your slides 

Insert a background picture on a slide 

1. Right-click the margin of the slide and then select Format Background. 

2. In the Format Background pane, choose Picture or texture fill. 

3. Under Picture source, select Insert, and select where to get the picture from: 

Option Use it to 

From a File Insert a picture from your computer or network drive 

Stock Images Insert a picture from the stock image library 

Online Pictures Search the web for an image 

From Icons Insert a picture from the icon collection 

4. Note: To insert a picture using the Clipboard source option, you must copy a picture to the 
clipboard first. This option is unavailable if you haven't copied a picture. 

5. To adjust the picture's relative lightness, slide the Transparency bar to the right. 
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 To view a detail in your slide up close, select Zoom into slide, and then point to the part 

you want to see. 

 
 To point to or write on your slides as you present, select Pen and laser pointer tools. 

 
Press the Esc key when you want to turn off the pen, laser pointer, or highlighter. 

 To hide or unhide the current slide in your presentation, select Black or unblack slide 
show. 
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MCQ – MS PowerPoint 

1. What feature allows text to 
automatically continue on a new line 
in a text box?  

A) Merge text 
B) Text overflow 
C) Text wrap 
D) Auto fit 

2. How can you add slide numbers to 
all slides?  

A) View > Slide Number > Apply 
B) Insert > Header & Footer > Slide 
Number > Apply to All 
C) Design > Format > Slide Number 
D) File > Slide Info 

3. Which option allows the date and 
time to update each time the 
presentation is opened?  

A) Fixed date 
B) Manual entry 
C) Update automatically 
D) Time format only 

4. What is the smallest editable unit on 
a slide?  

A) Layout 
B) Text 
C) Shape 
D) Text Box 

5. Which tab is used to insert a picture?  

A) Home 
B) Insert 

C) Design 
D) Format 

6. Which of the following changes the 
text direction in a shape?  

A) Format > Rotate Text 
B) Insert > Text Direction 
C) Format Shape > Text Direction 
D) Home > Orientation 

7. How do you insert a stock image in 
PowerPoint?  

A) Insert > Online Pictures 
B) Insert > Icons 
C) Insert > Stock Images 
D) Insert > Shapes 

8. What does 'Shrink text on overflow' 
do?  

A) Cuts extra text 
B) Scrolls the text 
C) Reduces font size to fit in the 
shape 
D) Expands the shape 

9. How do you access Presenter View?  

A) View > Normal > Presenter Tools 
B) Slide Show > From Beginning > 
Presenter View 
C) File > Presenter Settings 
D) Design > Show Presenter View 

10. How can you change vertical 
alignment of text in a text box?  

A) Home > Align 
B) View > Text Settings 
C) Format Shape > Layout & 
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Past Papers Questions 

1. Spell check in PowerPoint is F7. 

2. Slide show shortcut key is F 5. 

3. By using Shift + F5 short key, presentation starts from current slide. 

4. Hyperlink in PowerPoint shortcut key is CTRL+K. 

5. To insert a hyperlink in a slide (a) Choose insert > Hyperlink (b)Press Ctrl+ K. 

6. Ctrl + Click each slide allow you to select more than one slide in a presentation. 

7. To insert a new slide in power point presentation shortcut key is CTR +M. 

8. To access directly font dialogue box in power point CTRL+T is used. 

9. CTRL+P key to print PowerPoint presentation. 

10. Shortcut key to next slide is SPACE. 

11. In MS Powerpoint we can go to next slide by ENTER BUTTON, MOUSE, SPACEBAR. 

12. Ctrl+Home is key used to come on first slide of presentation. 

13. Ctrl+End is key used to come on last slide of presentation. 

14. To open the existing presentation, press Ctrl +0. 

15. Press Escape you can stop a slide show. 

16. To Print the PowerPoint presentation, press Ctrl +P. 

17. To start slide show to a presentation (a) Hit F5 key (b) From Slide Show menu choose 
View Show option. 

18. Robert Gaskins is the creator of PowerPoint. 

19. PowerPoint exe command is used to open PowerPoint file. 
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Key-Board and Shortcut Keys 
What is KEYBOARD? 

• A panel/plate/board of keys that operates a computer or typewriters. 

• A piece of computer hardware used to input text, characters, and other commands into a 
computer or similar device 

Types of Keys Setup on Keyboard: 

Keyboard Shortcut keys: 

1. Set of one or more keys that generates a particular command to be executed. 

2. Generally executed by using Alt or Ctrl keys with some other keys 

3. A plus (+) sign between two or more keys indicates that these keys 
should pressed in combination. For example Ctrl+Shift+A means to press 
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Microsoft Power Point Shortcut Keys 

Shortcut Keys Operation 

12 Save As. 

Alt + F4 Close PowerPoint 

Ctrl + M Insert a new slide. 

Ctrl + D Duplicate the selected slide. 

Ctrl + Shift + D Duplicate the selected slide. 

Page Up/Down Navigate to the previous/next slide 

Ctrl + G Group objects. 

Ctrl + Spacebar Reset manual character formatting 

Shift + F3 Change the case of selected text. 

Alt + Q "Tell me what you want to do". 

Ctrl + T Open the Font window. 

Ctrl + K Insert a hyperlink. 

Ctrl + Tab Switch between open presentations. 

Alt + F9 Show/hide gridlines and guides 

Alt + F10 Show/hide selection pane. 
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Special Computer Shortcut Keys: 

Shortcut Keys Operation 

Home Move to the begging of the line 

Ctrl + End Move to the last character 

Ctrl + Home Move to the first character 

Ctrl + Right Arrow To move the insertion point to the begging of the next word 

Ctrl + Left Arrow To move the insertion point to the begging of the Previous 
word 

Ctrl + Up Arrow To move the insertion point to the begging of the next 
paragraph 

Ctrl + Down Arrow To move the insertion point to the begging of the Previous 
paragraph 

Ctrl + Del Cut selected item 

Ctrl + Esc Display the start menu 

Windows Shortcut Keys: 

Shortcut Keys Operation 

Win Display or hide the start menu 

Win + B Set focus in the notification area 

Win + D Show or hide desktop area 

Win + E Open file explorer 

Win + H Open the share charm (voice command) 

Win + I Open the settings 

Win + K Open the devices charm (nearby device sharing) 

Win + L Lock your computer (Windows Xp and later) 
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MCQ– Keyboard & Shortcut Keys 

1. What does the "Ctrl + C" shortcut 
do?  

A) Cut selected item 
B) Copy selected item 
C) Close the window 
D) Paste copied item 

2. What is the function of the "Alt + 
F4" shortcut?  

A) Refresh the page 
B) Open a new document 
C) Close the current program 
D) Save the file 

3. What does the "Ctrl + A" command 
do in most programs?  

A) Cut all 
B) Undo all 
C) Select all content 
D) Save all 

4. Which key is used to cancel the 
current operation?  

A) Enter 
B) Ctrl 
C) Escape (Esc) 
D) Tab 

5. What does "Ctrl + P" do in most 
applications?  

A) Print the document 
B) Paste the text 
C) Power off 
D) Preview the slide 

6. What is the use of "Shift + F3" in 
MS Word?  

A) Search 
B) Change case of selected text 
C) Insert formula 
D) Exit program 

7. What does the "Ctrl + Z" shortcut 
do?  

A) Redo the action 
B) Cut the item 
C) Undo the last action 
D) Zoom out 

8. What happens when you press "Ctrl 
+ X"?  

A) Select all 
B) Paste item 
C) Cut selected item 
D) Cancel action 

9. What is the result of pressing "Ctrl + 
V"?  

A) View menu 
B) Paste copied content 
C) Print file 
D) Save 

10. What does "Win + L" do?  

A) Log in 
B) Lock the computer 
C) Launch program 
D) List files 

11. Which shortcut is used to open the 
Run dialog box?  

A) Ctrl + R 
B) Win + R 
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Computer Language 
What is a Computer Language? 

A computer language is a system of communication used to give instructions to a computer. 
These instructions help the computer perform tasks such as calculations, data processing, website 
creation, game development, and much more. 

Definition: 

A computer language is a formal language consisting of symbols, syntax, and semantics that 
instruct a computer to carry out specific tasks. 

Purpose of Computer Languages: 

• To create software, applications, and games 
• To control the behavior of computers and electronic devices 
• To allow communication between the user and the hardware 
• To store, retrieve, and manipulate data 
• To build and maintain websites, databases, and AI systems 

Real-Life Examples: 

• Using Python to create a weather app 
• Writing HTML and CSS to design a school website 
• Using SQL to manage student records in a database 

Basic Categories of Computer Languages: 

• Programming Languages (e.g., Python, Java, C++) – for software development 
• Markup Languages (e.g., HTML, XML) – for webpage structure 
• Query Languages (e.g., SQL) – for database access 
• Scripting Languages (e.g., JavaScript, Bash) – for automation and dynamic content 

Importance of Computer Languages 

Computer languages are the building blocks of technology. Without them, we would not have 
computers, apps, or the internet. Their importance spans education, healthcare, entertainment, 
communication, science, and more. 
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How Compilers Work: 

1. The entire source code is written and saved. 
2. The compiler processes the whole code. 
3. It identifies and reports all errors in one go. 
4. If there are no errors, it creates an executable file. 

Examples of Compiled Languages: 

• C 
• C++ 
• Java (compiled to bytecode, then run by a virtual machine) 
• Go 

Advantages of Compilers: 

• Faster execution once compiled 
• Provides better optimization of code for performance 
• Suitable for large, complex programs 

Disadvantages: 

• Slower to test code changes (requires full recompilation) 
• More difficult to debug during early development 

Comparison Table: 

Feature Interpreter Compiler 

Execution Style Line-by-line Whole program at once 
Output Executes directly Produces a separate executable file 
Speed Slower Faster (after compilation) 
Error Handling Stops at first error Detects all errors in one pass 
Usage Learning, scripting, quick testing Application development, production 
Examples Python, JavaScript, Ruby C, C++, Java, Go 

Which One Should You Use? 

• Choose an interpreter if you want quick results and easier debugging. 
• Choose a compiler if you need performance, standalone applications, or complex 

software development. 



 
 

  MK PREPARATIONS  

 

P a g e  10 | 16 

 

  

1
2

. 
C

o
m

p
u

te
r L

a
n

g
u

a
g

e
 

 
 

M 
K 
 

P 
R 
E 
P 
A 
R 
A 
T 
I 
O 
N 
S 

MK PREPARATIONS: Let’s Make It Happen 
+92 333 2605045, +92 342 4470091 
 

Term Definition 

Code A set of instructions written in a programming language to perform a 
task 

Syntax The set of rules that define how a program must be written to be valid 

Variable A named container that stores data used in programs 

Loop A sequence that repeats instructions multiple times until a condition is 
met 

Function A reusable block of code that performs a specific task 

Compiler A translator that converts entire programs into machine code before 
execution 

Interpreter A translator that reads and executes code line-by-line 
Assembler Converts assembly language into machine code 
Debugging Identifying and removing errors or bugs in code 

Binary A numeric system using only 0 and 1, which computers use to operate 

IDE (Integrated 
Development 
Environment) 

Software used to write, test, and debug programs (e.g., VS Code) 

Source Code The original code written by a programmer before translation 
Executable File A file generated by a compiler that runs as a program (e.g., .exe) 
Algorithm A logical sequence of steps to solve a problem 

Pseudocode A simplified version of code written in plain language to plan before 
actual coding 
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MCQ – Computer Languages 

1. What is a computer language?  

A) A device for storing files 
B) A communication tool between 
people 
C) A system of communication to 
instruct a computer 
D) A way to play games on computers 

2. Which of the following is a purpose of 
computer languages?  

A) Watching movies 
B) Playing music 
C) Building and maintaining websites 
D) Cleaning computer hardware 

3. HTML is an example of which type of 
computer language?  

A) Programming Language 
B) Query Language 
C) Scripting Language 
D) Markup Language 

4. SQL is mainly used for:  

A) Animating websites 
B) Database access 
C) Editing images 
D) Typing text 

5. Which of the following is a high-level 
programming language?  

A) MOV 
B) 10101100 
C) Python 
D) HTML 

6. Which language is closest to the 
machine?  

A) Java 
B) Assembly Language 
C) HTML 
D) Machine Language 

7. Assembly language uses:  

A) Real numbers 
B) Keywords 
C) Mnemonics 
D) Functions 

8. Which of the following is NOT a 
programming language?  

A) Python 
B) Java 
C) SQL 
D) BIOS 

9. Which tool translates the whole program 
into machine code at once?  

A) Interpreter 
B) Debugger 
C) Compiler 
D) Assembler 

10. What does an interpreter do?  

A) Translates code line-by-line 
B) Converts binary to text 
C) Creates machine hardware 
D) Compresses code 

11. Which of the following is an interpreted 
language?  

A) C++ 
B) Java 
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Past Papers Questions 

1. The UNIX operating system is written in the C-language. 

2. COBOL is widely used in Commercial applications. 

3. FOX PRO is a programming language. 

4. JAMES GOSLING invented the JAVA language. 

5. C language is developed by Dennis M. Ritchie. 

6. BASIC language is easiest to learn. 

7. BASIC is a Procedural language. 

8. FORTRAN earliest language. 

9. Software is represented from high level to low level in C++, COBOL, and JAVA. 

10. .NET is Microsoft's latest entry in to the programming arena. 

11. Programming language built into user programs such as Word and Excel are 

known as Visual programming languages. 
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Programing and Program Language 
What is a Programming Language? 

A programming language is a formal set of instructions and syntax that allows humans to 
communicate with computers and control their behavior. These languages are used to write 
software, applications, scripts, websites, and more. 

Definition: 

A programming language is a set of rules that defines how to write instructions for a computer to 
perform specific tasks. 

Why Programming Languages Matter: 

• Provide a bridge between human logic and machine operations 
• Allow the creation of everything from mobile apps to smart devices 
• Enable problem-solving and algorithmic thinking 

Common Syntax Components:  

• Keywords: Reserved words like if, while, function 
• Operators: Symbols like +, -, =, == 
• Data Types: String, Integer, Boolean, etc. 
• Control Structures: if, else, loop, switch 

History and Evolution of Programming Languages 

The development of programming languages has followed the advancement of computer science: 

First Generation (1940s): Machine Language 

• Only 0s and 1s 
• Directly executed by the CPU 
• Difficult and error-prone 

Second Generation (1950s): Assembly Language 

• Mnemonics like MOV A, B 
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Types of Programming Languages 

Programming languages can be categorized by abstraction level and purpose: 

Category Description Examples 

Low-Level Operates close to hardware; hard to write Assembly, Machine Code 

High-Level Easier to read, write, and maintain Python, Java, C++ 

Procedural Organized as step-by-step commands C, Pascal, BASIC 

Object-Oriented Focuses on reusable objects and classes Java, C#, Python 

Scripting Automates tasks or interacts with software JavaScript, Shell, Perl 

Markup Describes data structure and presentation HTML, XML 

Query Used to access and manipulate data SQL, SPARQL 

Popular Programming Languages and Their Applications 

Language Type Common Uses Features 

Python Interpreted, OOP AI, web, scripting Easy syntax, vast libraries 

Java Compiled, OOP Enterprise, Android Portable (JVM), strong typing 

C++ Compiled Games, system tools High-performance, control 

JavaScript Interpreted Web interactivity Runs in browser, dynamic 

C# Compiled, OOP Windows, games Microsoft ecosystem, Unity 

Swift Compiled iOS/macOS apps Secure, fast, modern syntax 

Kotlin Compiled Android apps Interoperable with Java 

PHP Interpreted Web servers Easy server-side scripting 
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MCQ – Programming and 
Programming Languages 

1. What is a programming language? 
A) A way to play computer games 
B) A formal way to tell computers 
what to do 
C) A tool for watching videos 
D) A language used to speak to 
humans 

2. Programming languages are used to: 
A) Wash dishes 
B) Water plants 
C) Write software and control 
machines 
D) Cook food 

3. Which of these is a syntax 
component? 
A) Monitor 
B) Keyword 
C) Mouse 
D) Printer 

4. Which keyword is commonly used in 
programming? 
A) blue 
B) if 
C) window 
D) table 

5. The '+' symbol in programming is 
known as: 
A) Keyword 
B) Loop 
C) Operator 
D) Class 

6. What is a Boolean data type used 
for? 
A) Storing images 
B) Storing true or false values 

C) Making music 
D) Drawing graphics 

7. Machine language uses: 
A) English sentences 
B) Mnemonics 
C) Binary digits 
D) Visual blocks 

8. Assembly language uses: 
A) Photos 
B) Graphs 
C) Mnemonics 
D) Colors 

9. FORTRAN and COBOL are 
examples of: 
A) First generation languages 
B) Second generation languages 
C) Third generation languages 
D) Fifth generation languages 

10. C++ and Java are examples of: 
A) Assembly language 
B) First generation languages 
C) Structured/OOP languages 
D) Markup languages 

11. Which generation includes Python 
and Swift? 
A) First 
B) Second 
C) Fourth 
D) Fifth 

12. Which of the following is a scripting 
language? 
A) C++ 
B) JavaScript 
C) Assembly 
D) SQL 



 
 

  MK PREPARATIONS  

 

P a g e  12 | 12 

 

  

1
3

. 
P

ro
g

ra
m

in
g

 a
n

d
 P

ro
g

ra
m

 L
a

n
g

u
a

g
e

 
 

 

M 
K 
 

P 
R 
E 
P 
A 
R 
A 
T 
I 
O 
N 
S 

MK PREPARATIONS: Let’s Make It Happen 
+92 333 2605045, +92 342 4470091 
 

Past Papers Questions 

1. The UNIX operating system is written in the C-language. 

2. COBOL is widely used in Commercial applications. 

3. FOX PRO is a programming language. 

4. JAMES GOSLING invented the JAVA language. 

5. C language is developed by Dennis M. Ritchie. 

6. BASIC language is easiest to learn. 

7. BASIC is a Procedural language. 

8. FORTRAN earliest language. 

9. Software is represented from high level to low level in C++, COBOL, and 

JAVA. 

10. NET is Microsoft's latest entry in to the programming arena. 

11. Programming language built into user programs such as Word and Excel 

are known as Visual programming languages. 
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Entrepreneurship 
What is Entrepreneurship? 

Entrepreneurship is the foundation of innovation and modern business. It involves identifying 
opportunities, gathering resources, taking risks, and launching ventures that provide value to society. 

Definition: 

Entrepreneurship is the dynamic process of vision, change, and creation that requires an application of 
energy and passion toward the creation and implementation of new ideas and creative solutions. 

Key Activities in Entrepreneurship: 

• Recognizing market gaps and customer needs 
• Designing a viable business model 
• Organizing resources (finance, people, tools) 
• Launching a product/service 
• Scaling the business 

Example: A university student in Lahore creates an app that connects home tutors with students in real-
time. They later scale it nationally by partnering with ed-tech investors. 

Importance of Entrepreneurship 

Entrepreneurship is a major engine of economic development and societal progress. 

Economic Contributions: 

• In Pakistan, SMEs (mostly entrepreneurial) contribute over 40% of GDP and employ 78% of 
the non-agricultural labor force. 

• In the U.S., startups create 3 million jobs annually. 

Why Entrepreneurship Matters: 

• Job Creation: Startups often become large employers (e.g., Careem, started with 2 employees, 
now thousands). 



 
 

  MK PREPARATIONS  

 

P a g e  3 | 12 

 

  

1
4

. 
E

n
tre

p
re

n
e

u
rsh

ip
 

 
 

M 
K 
 

P 
R 
E 
P 
A 
R 
A 
T 
I 
O 
N 
S 

MK PREPARATIONS: Let’s Make It Happen 
+92 333 2605045, +92 342 4470091 
 

Corporate 
Entrepreneurship 

New business units within large 
firms 

Jazz creating fintech arm 
(JazzCash) 

Digital Entrepreneurship Internet-based business models Instagram shop, YouTube 
channel 

AgriTech 
Entrepreneurship Combines farming and tech Pak Agri Market (info for 

farmers) 

Green Entrepreneurship Environmentally sustainable 
startups 

Daastan (eco-publications, 
green model) 

Key Terminology Related to Entrepreneurship 

Term Definition 

MVP (Minimum Viable 
Product) Basic version of a product to test with real users 

Bootstrapping Starting a business without external funding 

Unicorn Startup valued at over $1 billion (e.g., Careem before Uber 
acquisition) 

Incubator Institution that supports early-stage startups with space and 
mentoring 

Pivot Changing business direction based on feedback or failure 

Burn Rate Speed at which a startup spends its capital 

Exit Strategy Plan for founders/investors to sell ownership (IPO or acquisition) 

Crowdfunding Raising small amounts from many individuals via online 
platforms 

Co-founder Person who joins another in starting a business 

 Introduction to E-Commerce 

E-commerce is now a pillar of the global economy. In 2023, global e-commerce sales exceeded $6.3 
trillion. 
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MCQ – Entrepreneurship 

1. What is entrepreneurship? 
A) A cooking style 
B) Government employment 
C) Process of creating and running 
new businesses 
D) A form of entertainment 

2. Which of the following is a key 
activity in entrepreneurship? 
A) Watching TV 
B) Organizing a picnic 
C) Recognizing market gaps 
D) Playing games 

3. Launching a product or service is a 
part of: 
A) Shopping 
B) Entrepreneurship 
C) Marketing only 
D) Banking 

4. SMEs contribute what percent to 
Pakistan’s GDP? 
A) 10% 
B) 20% 
C) 40% 
D) 80% 

5. How many jobs do U.S. startups 
create annually? 
A) 300,000 
B) 3 million 
C) 1 million 
D) 10 million 

6. What does Careem’s growth 
demonstrate? 
A) Corporate taxes 
B) Slow business development 
C) Job creation by startups 
D) Interest rates 

7. Sehat Kahani is an example of: 
A) Government agency 
B) School 
C) Social startup providing 
healthcare 
D) Food delivery app 

8. Which skill is crucial for a successful 
entrepreneur? 
A) Sleeping skills 
B) Visionary thinking 
C) Laziness 
D) Avoiding technology 

9. What does financial literacy include? 
A) Writing novels 
B) Memorizing poems 
C) Budgeting and fundraising 
knowledge 
D) Grammar rules 

10. A strong entrepreneur must be: 
A) Shy and isolated 
B) Careless with money 
C) Resilient and adaptable 
D) Against teamwork 

11. What is bootstrapping? 
A) Importing boots 
B) Starting a business without 
external funding 
C) Repairing shoes 
D) Hiring a manager 

12. What is an MVP in 
entrepreneurship? 
A) Most valuable person 
B) Minimum Viable Product 
C) Manual venture process 
D) Market viewing platform 

13. What does an incubator provide? 
A) Game consoles 
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Cybersecurity 
What is Cybersecurity? 

Cybersecurity is the practice of protecting digital systems, networks, devices, and data from malicious 
attacks. These attacks aim to steal, damage, or manipulate sensitive information and disrupt digital 
operations. 

Definition: Cybersecurity is the combination of tools, policies, techniques, and best practices that ensure 
the safety of internet-connected systems and the data they process. 

Examples of what cybersecurity protects: 

• Your passwords and login information 
• Bank account and credit card data 
• Social media accounts 
• Educational platforms (e.g., LMS, Zoom, Google Classroom) 
• Government and health databases 

Without cybersecurity, we risk: 

• Identity theft 
• Data leaks 
• Financial fraud 
• Reputation loss 
• Even national security threats 

Why Cybersecurity Matters Today 

We live in a hyperconnected digital world — every click, post, or email involves data exchange. 
Protecting that data is no longer optional. 

Key Reasons Cybersecurity is Essential: 

1. Online Threats Are Increasing: Cyberattacks occur every 39 seconds. 

2. Remote Learning & Work: Cloud systems are vulnerable if not secured. 

3. Digital Economy: Online banking, e-commerce, and e-wallets need protection. 
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4. IoT Devices: From smartwatches to home appliances, everything is connected. 

5. National & Military Security: Countries face cyberwarfare and hacking threats. 

Fact: In 2024, Pakistan's largest telecom suffered a massive data breach affecting over 2 million users. 

Evolution and History of Cybersecurity 

Timeline of Cybersecurity Milestones: 

• 1971: First known computer virus, “Creeper” 

• 1986: First documented case of hacking by “The 414s” 

• 1990s: Rise of commercial internet → phishing, worms, and Trojans appear 

• 2000s: Introduction of firewalls, antivirus software, encryption tools 

• 2017: Global WannaCry ransomware attack cripples UK hospitals 

• 2020–2025: AI-driven threats, state-sponsored hacking, and deepfakes emerge 

Cybersecurity has evolved from just “protecting computers” to guarding networks, devices, identities, 
national defense, and even democracy. 

Types of Cyber Threats and Attacks 

Cyberattacks come in various forms. Here are the most common and dangerous ones: 

Type How it Works Example 

Malware Malicious software that infects devices Trojans, worms, keyloggers 

Ransomware Locks files and demands payment WannaCry, CryptoLocker 

Phishing Tricks you into revealing info Fake bank or university emails 

Spyware Secretly monitors your actions Keylogging programs 

DDoS Overloads and shuts down websites Website goes offline unexpectedly 
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MCQ – Cybersecurity 

1. What is the primary goal of 
cybersecurity?  

A) Increasing internet speed 
B) Protecting digital systems and 
data 
C) Printing documents 
D) Developing games 

2. Which of the following is an 
example of what cybersecurity 
protects?  

A) Your calendar colors 
B) Social media accounts 
C) Desk decorations 
D) Weather updates 

3. What is identity theft?  

A) Forgetting your name 
B) Stealing someone's online identity 
C) Creating passwords 
D) Using emojis 

4. Cyberattacks are increasing because:  

A) People watch TV more 
B) There are more connected devices 
C) Passwords are too short 
D) Browsers are colorful 

5. Which of the following is a 
cyberattack?  

A) Shaking hands 
B) Sending malware to someone's 
computer 

C) Installing updates 
D) Writing a diary 

6. The first known computer virus was:  

A) ILOVEYOU 
B) Creeper 
C) Trojan 
D) CryptoLocker 

7. What is ransomware designed to do?  

A) Update files 
B) Lock files and demand payment 
C) Organize folders 
D) Scan documents 

8. What is phishing?  

A) A water sport 
B) Trick to gain personal 
information 
C) Catching fish 
D) Website designing 

9. What does DDoS stand for?  

A) Direct Download on Server 
B) Distributed Denial of Service 
C) Double Data Operations System 
D) Data Distribution on Site 

10. What is the purpose of the CIA 
Triad?  

A) Intelligence gathering 
B) Protecting data through 
confidentiality, integrity, and 
availability 
C) Military mission 

D) Encrypting social media 



 
 

  MK PREPARATIONS  

 

P a g e  13 | 14 

 

  

1
5

. 
C

y
b

e
r Se

cu
rity

 
 

 

M 
K 
 

P 
R 
E 
P 
A 
R 
A 
T 
I 
O 
N 
S 

MK PREPARATIONS: Let’s Make It Happen 
+92 333 2605045, +92 342 4470091 
 

Past Paper Questions 

1. E-mail hacking means Illegal access to open email accounts or others. 

2. Unauthorized and illegal accessing of computer program, often with criminal intent is 

Hacking. 

3. Firewall in a computer to protect a network server from damage by these who log into. 

4. Firewall's main purpose is to prohibit unauthorized access to your computer via the 

internet. 

5. Any crime that involves a computer and internet is called cybercrime. 

6. Encryption is to protect data and passwords. 

7. The prevention of electronic crimes Act was passed in Pakistan in the year 2016. 

8. WPA2 is used for security in WI-FI. 

9. HTML viruses infect a Web page in the HTML code. 

10. Cyber security is related to security of computer, network, and software. 

11. A self-replicating program, similar to a virus, which was taken from a 1970s science 

fiction novel by John Bruner entitled the Shockwave Rider, is Worm. 

12. A virus that replicates itself called Worm. 

13. The thing that eventually terminates a worm virus is a lack of memory or disk space. 

14. A result of a computer virus cannot lead to Mother Board Crash. 

15. The majority of computer crimes are committed by Insiders. 

16. An intentionally disruptive program that spreads from program to program or from disk to 

disk is known as a virus. 

17. Malicious software is known as Malware. 

18. Malware, short for Malicious Software, is an umbrella term used to refer to a variety of 

forms of hostile or intrusive software, including computer viruses, worms, Trojan horses, 

ransomware, spyware, adware. Scareware, and other malicious programs. 

19. In 1999, the Melissa virus was a widely publicized e-mail virus. 

20. Biometrics is the measurement of things such as fingerprints and retinal scans used for 

security access. 
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Digital Ethics 
What is Computer Ethics? 

Computer ethics refers to the moral principles and rules that guide how we use computers and 
the internet. 

Definition: Computer ethics is the responsible, fair, and respectful use of technology, with 
attention to privacy, legality, honesty, and accountability. 

Examples of Ethical vs. Unethical Behavior: 

Ethical Unethical 
Giving credit when using online resources Copying and pasting content without credit 

Reporting a discovered vulnerability Exploiting or selling security loopholes 

Respecting others’ privacy Snooping through messages or emails 

Using licensed software Downloading pirated software 

“With great power comes great responsibility” — this is especially true online. 

 Ethical vs. Unethical Behavior Online 

 Ethical Behavior: 

• Respecting others' digital content and identity 
• Practicing fair use of media and code 
• Engaging in healthy, supportive online dialogue 
• Protecting others' personal data 

Unethical Behavior: 

• Cyberbullying and harassment 
• Plagiarizing code or research 
• Spreading false information or rumors 
• Bypassing school or exam rules using tech 
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MCQ – Digital Ethics 

1. What does computer ethics focus on?  

A) Faster hardware 
B) Responsible and fair use of 
technology 
C) Downloading free software 
D) High-speed gaming 

2. Which of these is an example of 
ethical behavior?  

A) Copying someone’s code without 
permission 
B) Giving credit when using content 
C) Hacking into school systems 
D) Sharing pirated movies 

3. What is unethical in the digital 
world?  

A) Logging out after use 
B) Respecting privacy 
C) Cyberbullying 
D) Citing sources 

4. Using licensed software is 
considered:  

A) Expensive behavior 
B) Ethical 
C) Illegal 
D) Time-wasting 

5. What does the quote “With great 
power comes great responsibility” 
mean in the digital world?  

A) Use technology only at school 
B) Share as much content as possible 
C) Use technology wisely and 

respectfully 
D) Sell software online 

6. Which student acted ethically?  

A) Student B who copied code from 
StackOverflow 
B) Student A who understood and 
wrote his own code 
C) Student B who sold code 
D) None 

7. What does copyright protect?  

A) Computer speed 
B) Original works of authorship 
C) Internet connection 
D) Hardware devices 

8. Which right protects brand names 
and logos?  

A) Patent 
B) Copyright 
C) Trademark 
D) Licensing 

9. A patent is used to protect:  

A) Songs and lyrics 
B) Inventions and designs 
C) Logos only 
D) Data backups 

10. Creative Commons licenses allow:  

A) Plagiarism of content 
B) Unlimited use without rules 
C) Use with certain conditions 
D) No public sharing 

11. Why should we give credit when 
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More Past Papers Questions 

1. Disk scanner is used to detect physical and logical problems of a disk. 

2. Fax viewer is a utility program. 

3. Window media player is an example of entertainment software. 

4. Entertainment is not a system software. 

5. WinZip program compress large files into smaller file. 

6. Oracle is not anti-virus software. 

7. Computer hard disk was first introduced by IBM. 

8. LAN card is not necessary for working of a standalone computer. 

9. CRT (Cathode Ray Tube) technology is used in Monitor. 

10. Data stored on a hard disk can also be saved on CD, Floppy Disk and magnetic tape. 

11. LINUX is an open source operating system. 

12. Creator of LINUX is Linus Torvalds. 

13. UNIX was made by Dennis Ritchie and Ken Thompson. 

14. Real time OS time intervals to process and responds to input is very small. 

15. Real time system is the name of the operating system that reads and reacts in terms of actual 
time. 

16. BCC means Blind Carbon Copy, whereas CC means Carbon Copy. 

17. Log In can be used to open your account. 

18. If you want to close your email account, you should click on Sign out. 
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