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Introduction to Computing and ICT 
Information and Communication Technology (ICT) 

Information and Communication Technology (ICT) is defined as a comprehensive set of 
computing tools that collectively allow people and organizations to interact in the digital world. 
It is an umbrella term encompassing communication devices (television, cell phones), 
computer and network hardware, satellite systems, and various associated services and 
applications such as video conferencing, distance learning, and e-commerce. ICT also 
represents the technological convergence of telephone networks with computer networks via a 
single link system, enabling integrated data, voice, and video communication. 

What is a System? 

A system is a collection of interconnected components working together cohesively to achieve 
specific goals or objectives by processing inputs to produce desired outputs. Systems exist in 
both natural and artificial domains. Understanding a system's structure allows for better design, 
management, and optimization across fields like engineering, biology, and computing. 

A system is described by four fundamental concepts: 

1. Objective/Purpose: The primary goal the system is designed to achieve. 

2. Components: The essential building blocks or parts that constitute the system. 

3. Environment: Everything external to the system that interacts with or influences it. 

4. Communication/Interaction: The mechanisms through which components and the system 
itself exchange information and coordinate their functions. 

Types of Systems 

Systems are broadly categorized into two main types: 
1.3.1 Natural Systems 
These occur organically in nature without human intervention. They are characterized by 
self-regulation, adaptability, stability, and are governed by natural laws (physics, chemistry, 
biology). They are highly intricate and interdependent. 

• Examples: Ecosystems (forests, oceans), weather patterns, the solar system, the human body 
(circulatory, nervous systems), DNA, psychological systems (thoughts, emotions). 

Chapter 1 
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1.3.2 Artificial Systems 
These are intentionally designed and built by humans to fulfill specific needs or solve 
problems. They are structured, require maintenance, and operate under predefined human-set 
rules and protocols. 

• Examples: 

o Knowledge Systems: Mathematics, logic, databases, information management systems. 

o Engineering Systems: Civil (bridges, roads), mechanical (robotic arms), chemical (water 
treatment plants), electrical (home automation), software (library management systems). 

o Social Systems: Academic institutions, governments, corporations. 

o Computer Systems: The primary focus of this chapter. 

Key Differences: 

Feature Natural Systems Artificial Systems 

Origin Occur naturally. Designed and built by humans. 

Complexity Highly intricate and 
interdependent. 

Structured and relatively simpler. 

Energy Source Natural (sunlight, water flow). Artificial (electricity, fuel). 

Adaptation Evolve autonomously over time. Require human updates/redesign. 

Governance Natural laws. Human-defined rules and 
protocols. 

Systems and Science 

The study of systems aligns with different scientific approaches: 

• Natural Science: Focuses on understanding and describing existing natural systems (e.g., 
studying a forest ecosystem). 

• Design Science: Focuses on creating new artificial systems to solve problems (e.g., 
developing conservation software). 
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• Computer Science: Utilizes methods from both. It studies the natural laws of computation 
(e.g., algorithm efficiency) and engages in the design science of creating new software and 
hardware systems. 

The Computer as a System 

Definition of a Computer 

A computer is a programmable electronic device that accepts raw data as input, processes it 
according to a set of stored instructions (a program), produces useful output, and stores 
(storage) the results for future use. It performs arithmetic and logical operations automatically 
and without human intervention during processing. 

Objectives of a Computer System 

The main objectives are to perform computations, process data, and execute tasks efficiently 
to provide useful information to the user. This includes running software applications, 
managing files, facilitating communication, and automating complex processes. 

Core Components of a Computer System (Hardware) 

Computer hardware consists of physical, tangible components. 

Input Devices 
Tools that allow users to enter data and instructions into the computer. 

• Keyboard: For entering text, numbers, and commands. The standard layout is QWERTY. 

• Mouse/Pointing Device: Controls the cursor on the screen for selection and navigation. 
Includes touchpads on laptops. 

• Scanner: Converts physical documents and images into a digital format. 

• Microphone: Inputs audio data. 

• Webcam: Captures live video and images. 

• Barcode Reader: Scans barcodes to input product information quickly. 

• Touch Screen: Serves as both an input (touch) and output (display) device. 

• Joystick/Gamepad: Used for gaming and simulations. 

• Light Pen: A historical pointing device for drawing directly on CRT screens. 



 

  MK PREPARATIONS  

 

P a g e  24 | 37 

 

  

1
. In

tro
d

u
ctio

n
 to

 C
o

m
p

u
tin

g
 a

n
d

 IC
T

 
  

M 
K 
 

P 
R 
E 
P 
A 
R 
A 
T 
I 
O 
N 
S 

MK PREPARATIONS: Let’s Make It Happen 
+92 333 2605045, +92 342 4470091 
 

One Liners: Introduction to Computing and ICT 

1. ICT is an umbrella term for computing tools enabling interaction in the digital world, 
representing the convergence of telephone and computer networks. 

2. A system is a collection of interconnected components working cohesively to achieve a 
specific objective by processing inputs into outputs. 

3. The four fundamental concepts describing any system are its Objective, Components, 
Environment, and Communication/Interaction. 

4. Natural systems occur organically, are self-regulated, adaptable, and governed by natural 
laws, such as ecosystems and the human body. 

5. Artificial systems are human-designed, structured, require maintenance, and operate under 
predefined rules, like engineering, social, and computer systems. 

6. Natural systems are governed by natural laws, while artificial systems operate under 
human-defined rules and protocols. 

7. Design Science focuses on creating new artificial systems, like conservation software, to 
solve problems. 

8. A computer is a programmable electronic device that accepts input, processes it according 
to stored instructions, produces output, and stores results. 

9. The primary objectives of a computer system are to perform computations, process data, 
and execute tasks efficiently to provide useful information. 

10. An input device allows users to enter data and instructions into a computer, such as a 
keyboard, mouse, or scanner. 

11. The standard keyboard layout is QWERTY. 
12. A touch screen serves as both an input (touch) and output (display) device. 
13. The system unit houses the primary electronic components of a computer, including the 

motherboard and CPU. 
14. The motherboard is the main circuit board connecting all components like the CPU, RAM, 

storage, and ports. 
15. The CPU, or microprocessor, is the computer's "brain," responsible for fetching, decoding, 

and executing instructions. 
16. The Control Unit (CU) directs and coordinates operations within the processor and 

manages data flow. 
17. The Arithmetic Logic Unit (ALU) performs all mathematical calculations and logical 

comparisons. 
18. Registers are high-speed temporary storage locations within the CPU for data and 

addresses being processed. 
19. The Memory Address Register (MAR) holds the memory location of data to be fetched or 

stored. 
20. The Memory Data Register (MDR) holds the data fetched from or to be written to 

memory. 
21. The Program Counter (PC) holds the address of the next instruction to be executed. 
22. The Current Instruction Register (CIR) holds the instruction currently being decoded and 

executed. 
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Practice MCQs
1. In the context of systems, which of the 
following is NOT one of the four 
fundamental concepts that describe any 
system? 
a) Objective/Purpose 
b) Components 
c) Efficiency 
d) Environment 
Answer: c) Efficiency 

2. What is the key, revolutionary 
principle proposed by John von 
Neumann that underlies almost all 
modern computer architectures? 
a) The use of vacuum tubes 
b) The stored-program concept 
c) The Harvard architecture separation 
d) Binary arithmetic logic 
Answer: b) The stored-program 
concept 

3. During the Fetch stage of the 
instruction cycle, what happens to the 
Program Counter (PC) after an 
instruction is retrieved? 
a) It is decremented 
b) It is loaded with the address of the 
fetched instruction 
c) It is incremented 
d) It is compared with the CIR 
Answer: c) It is incremented 

4. Which component of the CPU is 
specifically responsible for performing 
all mathematical calculations and logical 
comparisons? 
a) Control Unit (CU) 
b) Memory Data Register (MDR) 
c) Arithmetic Logic Unit (ALU) 
d) Cache Memory 
Answer: c) Arithmetic Logic Unit 
(ALU) 

5. What is the primary vulnerability 
associated with the Von Neumann 
architecture that can be exploited in 
attacks like buffer overflows? 
a) Slow processing speed due to the 
bottleneck 
b) Instructions and data residing in 
separate memory units 
c) Instructions and data residing in the 
same memory space 
d) The use of a single system bus 
Answer: c) Instructions and data 
residing in the same memory space 

6. Which of the following best 
distinguishes a compiler from an 
interpreter? 
a) A compiler is used for system 
software, an interpreter for application 
software. 
b) A compiler translates code line-by-
line, while an interpreter translates the 
entire program at once. 
c) A compiler translates the entire source 
code into machine code at once, 
producing an executable. 
d) An interpreter produces an object file, 
while a compiler does not. 
Answer: c) A compiler translates the 
entire source code into machine code 
at once, producing an executable. 

7. A software that is copyrighted and 
distributed free of charge, but whose 
source code is typically not modifiable 
by the user, is classified as: 
a) Open Source Software 
b) Shareware 
c) Freeware 
d) Firmware 
Answer: c) Freeware 
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History of Computers 
Introduction to Computers: 

The word 'computer' originally referred to people who performed mathematical calculations. 
Before modern computers existed, these human 'computers' were employed to carry out complex 
arithmetic operations, often used in fields like astronomy, engineering, and navigation. This 
practice dates back to at least the 17th century. 

The first recorded use of the word 'computer' in English was in 1613, describing a person who 
computes. Over the centuries, as technology progressed, mechanical and electronic devices took 
over the computational role. This evolution marked the transition from manual computing to the 
automated systems we rely on today. 

Understanding the history of computing helps us appreciate the innovations and challenges faced 
by early scientists and inventors who laid the foundation for today’s digital age. 

The Mechanical Era (1600–1900) 

During the Mechanical Era, inventors developed physical devices to assist in computation. These 
devices worked without electricity and were typically operated by hand. 

Tally Sticks 

Tally sticks were simple tools used since ancient times to record numbers, debts, or messages. 
They were not calculators but rather record-keeping aids. A notch on a stick represented a unit of 
value or count. These were used extensively in medieval Europe, especially for tax collection. 

Abacus (c. 2400 BC) 

The abacus is one of the oldest calculating tools known to humanity. First used in Babylon around 
2400 BC and later perfected in China around 500 BC, the abacus consists of beads that can be 
moved along rods to perform arithmetic operations. It was especially useful in trading and finance 
and is still used today in parts of Asia. 

Chapter 2 
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One Liners: History of Computer 
1. The word 'computer' originally referred to a person who performed mathematical 

calculations. 
2. The first recorded use of the word 'computer' in English was in 1613. 
3. The Mechanical Era of computing (1600-1900) involved physical devices operated 

without electricity. 
4. Tally sticks were ancient record-keeping aids, not calculators, often used in medieval 

Europe for tax collection. 
5. The abacus, dating to 2400 BC in Babylon, is one of the oldest calculating tools, using 

beads on rods. 
6. Napier's Bones (1614), invented by John Napier, used inscribed rods to simplify 

multiplication and division. 
7. The slide rule (1622), developed by William Oughtred, used logarithmic scales for 

complex calculations. 
8. The Pascaline (1642) was a mechanical calculator created by Blaise Pascal to perform 

addition and subtraction. 
9. Gottfried Wilhelm Leibniz designed the Stepped Reckoner (1672), capable of all four 

basic arithmetic operations. 
10. The Arithmometer (1820) by Charles Xavier Thomas de Colmar was the first 

commercially successful mechanical calculator. 
11. Charles Babbage, the Father of the Computer, proposed the Difference Engine and 

Analytical Engine. 
12. The Difference Engine was designed to compute polynomial functions and print results 

automatically. 
13. The Analytical Engine is considered the first design for a general-purpose mechanical 

computer. 
14. Ada Lovelace wrote the first algorithm intended for the Analytical Engine, making her the 

first programmer. 
15. Ada Lovelace suggested using binary and conceptualized machine-generated music. 
16. The Scheutzian Engine (1843) was the first mechanical calculator to automatically print 

its results. 
17. The Jacquard Loom (1881) used punch cards to control weaving patterns, inspiring future 

computer data input. 
18. Herman Hollerith's Tabulating Machine (1890) used punched cards for data processing, 

starting with the U.S. Census. 
19. The Tabulating Machine's innovation led to the founding of IBM. 
20. The Electronic Era brought faster, smaller, more reliable machines using electricity and 

introduced programmability. 
21. Konrad Zuse's Z1 (1936-1938) is considered the first freely programmable mechanical 

computer. 
22. The Z1 used binary floating-point arithmetic and input via punched tape. 
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Practice MCQs

1. What was the original meaning of the word 
"computer"? 
a) An electronic calculating device 
b) A person who performs mathematical 
calculations 
c) A mechanical automation tool 
d) A data storage unit 
Answer: b) A person who performs 
mathematical calculations 

2. The Pascaline, invented by Blaise Pascal, 
was primarily designed to: 
a) Perform multiplication and division 
b) Weave complex fabric patterns 
c) Assist with tax collection through addition 
and subtraction 
d) Solve polynomial equations 
Answer: c) Assist with tax collection 
through addition and subtraction 

3. Which device is considered the first design 
for a general-purpose mechanical computer? 
a) Difference Engine 
b) Analytical Engine 
c) Stepped Reckoner 
d) Arithmometer 
Answer: b) Analytical Engine 

4. Ada Lovelace is historically significant for: 
a) Inventing the first mechanical calculator 
b) Writing the first algorithm intended for 
machine processing 
c) Developing the stored-program concept 
d) Building the first electronic computer 
Answer: b) Writing the first algorithm 
intended for machine processing 

5. The Tabulating Machine, which used 
punched cards for data processing, directly 
led to the founding of which company? 
a) Microsoft 
b) IBM 
c) Intel 
d) Apple 
Answer: b) IBM 

6. Konrad Zuse's Z1 is notable for being the: 
a) First electronic digital computer 
b) First computer to use vacuum tubes 
c) First freely programmable mechanical 
computer 
d) First commercial computer 
Answer: c) First freely programmable 
mechanical computer 

7. The Atanasoff-Berry Computer (ABC) 
introduced which of the following concepts? 
a) Stored-program architecture 
b) Use of transistors 
c) Binary representation and electronic 
calculation using vacuum tubes 
d) Integrated circuits 
Answer: c) Binary representation and 
electronic calculation using vacuum tubes 

8. What was the primary use of the Harvard 
Mark I during World War II? 
a) Code-breaking 
b) Ballistics calculations for the U.S. Navy 
c) Predicting election results 
d) Running business payroll 
Answer: b) Ballistics calculations for the 
U.S. Navy 
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Computer System: Architecture and Components 

Introduction To Computer And Its Basic Operations 

In today's information age, computers are used in every walk of life. They are found in 
devices ranging from MP3 players and toys to industrial robots, fighter aircraft, and beyond, 
making life easier and more comfortable. 

Definition of a Computer 

A computer is an electronic device that accepts input data and instructions via input devices, 
stores them until needed, processes the data, and produces output through output devices. 

Basic Operations of a Computer 

All computers perform four fundamental operations to carry out any task: Input, Processing, 
Output, and Storage.  

• Input Operation: The process of capturing or accepting data or information using input 
devices (e.g., keyboard, mouse). 

• Processing Operation: The transformation of input into output. The Central Processing 
Unit (CPU) performs this task under the direction of a program. 

• Output Operation: The result or outcome of the processing, delivered via output devices 
(e.g., monitor, printer, speakers). 

• Storage Operation: The process of retaining data, information, or instructions so the user can 
retrieve them when required. Storage can be temporary (e.g., RAM) or permanent (e.g., Hard 
Disk). 

Evolution of Computing Devices 

The term "computing device" refers to any machine that can perform calculations, from 
simple addition to managing complex systems. 

• Early Computing Devices: 

o Abacus (c. 3000 BC): Considered the first computer, using a system of sliding beads for 
calculations. 

Chapter 3 
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One Liners: Computer Systems, Architecture and components 
1. A computer is an electronic device that accepts input data and instructions, stores them, 

processes the data, and produces output. 
2. The four fundamental operations of a computer are Input, Processing, Output, and Storage. 
3. Input operation involves capturing or accepting data using input devices like a keyboard or 

mouse. 
4. The Central Processing Unit (CPU) performs the transformation of input into output, which 

is the processing operation. 
5. Output operation delivers the result or outcome of processing via devices like a monitor, 

printer, or speakers. 
6. Storage operation retains data, instructions, or information for future retrieval, and can be 

temporary (RAM) or permanent (Hard Disk). 
7. The Abacus (c. 3000 BC) is considered the first computing device, using sliding beads for 

calculations. 
8. Charles Babbage proposed the Difference Engine (1822) to solve differential equations. 
9. The Analytical Engine was Charles Babbage's later concept for a general-purpose computer. 
10. Herman Hollerith's Tabulating Machine (1889) used punched cards and was developed for 

the U.S. census. 
11. The Z3 (1941), developed by Konrad Zuse, was used for designing airplanes and missiles. 
12. The Harvard Mark I (1944) was an electromechanical relay computer. 
13. ENIAC (1946) was the first general-purpose electronic computer. 
14. EDVAC (1945), designed by John von Neumann, introduced the stored-program concept. 
15. UNIVAC-I (1951) was one of the first commercially available computers. 
16. Microcomputers (Personal Computers) are the smallest and least expensive class, originally 

for individual users. 
17. Types of microcomputers include Desktop, Notebook, Laptop, and Handheld devices 

(Palmtop, PDA, Smartphone). 
18. Mainframe computers are the second most powerful and expensive, used by large 

organizations for critical, bulk-data processing. 
19. Mainframes support many terminals simultaneously and are used for census, ERP, financial 

transactions, and airline reservations. 
20. Supercomputers are the most powerful and expensive, designed for intense scientific, 

engineering, and business applications. 
21. Supercomputers are used for weather forecasting, weapon research, space exploration, and 

complex simulations. 
22. Mobile Computers are devices enabling mobile computing—processing and transmitting data 

wirelessly. 
23. Mobile computers include laptops, smartphones, tablets, and PDAs, featuring wireless 

connectivity and portability. 
24. Computer hardware refers to the physical, tangible components of a computer system (e.g., 

monitor, keyboard, mouse, CPU). 
25. The primary function of hardware is to store and execute software. 
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Practice MCQs

1. Which of the following is NOT one of 
the four fundamental operations 
performed by all computers? 
a) Input 
b) Processing 
c) Communication 
d) Storage 
Answer: c) Communication 

2. Which early computing device, 
considered the first computer, used a 
system of sliding beads for calculations? 
a) Analytical Engine 
b) Difference Engine 
c) Abacus 
d) Pascaline 
Answer: c) Abacus 

3. The concept where both program 
instructions and data are stored in the 
same memory was introduced by which 
computer? 
a) ENIAC 
b) Harvard Mark I 
c) EDVAC 
d) UNIVAC-I 
Answer: c) EDVAC 

4. Which type of computer is specifically 
designed for intense scientific 
applications and is the most powerful and 
expensive? 
a) Mainframe Computer 
b) Microcomputer 
c) Minicomputer 
d) Supercomputer 
Answer: d) Supercomputer 

5. What is the primary functional 
distinction between computer hardware 
and software? 

a) Hardware is logical, software is 
physical. 
b) Hardware provides instructions, 
software executes them. 
c) Hardware is tangible and performs 
physical work, software is intangible and 
provides instructions. 
d) Hardware is stored permanently, 
software is temporary. 
Answer: c) Hardware is tangible and 
performs physical work, software is 
intangible and provides instructions. 

6. Which type of software acts as an 
interface between the computer hardware 
and the application software? 
a) Utility Software 
b) System Software 
c) Firmware 
d) Customized Software 
Answer: b) System Software 

7. A software translator that converts the 
entire source code into machine code at 
once, producing an object file, is called 
a(n): 
a) Interpreter 
b) Assembler 
c) Compiler 
d) Linker 
Answer: c) Compiler 

8. Customized banking software 
developed for a specific bank is an 
example of which category of application 
software? 
a) General-Purpose Software 
b) Productivity Software 
c) Special-Purpose Software 
d) System Software 
Answer: c) Special-Purpose Software 
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Number Systems, Digital Logics and Data 
Basics 

Introduction to Digital Systems and Data 

Modern technology is built upon the principles of digital systems. These systems process 
information using discrete values—primarily the binary digits 0 and 1—as opposed to the 
continuous signals found in the natural world. This chapter provides a comprehensive 
foundation in the core concepts that bridge data representation, logical processing, and 
structured data management. We will explore how computers represent numbers, text, and 
multimedia, how they perform logical and arithmetic operations using Boolean algebra and 
logic gates, and how complex data is organized and managed in database systems. Mastery of 
these topics is essential for understanding the inner workings of all computational devices. 

Data and Number Systems 

Data, Information, and Operations 

• Data is a raw collection of facts, figures, and statistics related to an object. It is an 
organizational asset used to view past activities and make future decisions. 

• Information is data that has been processed, manipulated, and organized into a meaningful 
and useful context (e.g., a student's percentage result). 

• Data Processing Operations involve a series of actions to convert data into information: 

1. Data Capturing: Recording data via source documents or input devices. 

2. Data Manipulation: This includes: 

 Classifying: Organizing data into groups using codes. 

 Calculating: Performing arithmetic operations. 

 Sorting: Arranging data in a logical sequence. 

 Summarizing: Condensing data into a concise form. 

3. Managing Output Results: This involves storing, retrieving, communicating, and 
reproducing the processed information. 

Chapter 4 
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One Liners: Number Systems, Digital Logics and Data Basics 
1. Data is a raw collection of facts, figures, and statistics related to an object, used for viewing 

past activities and making future decisions. 
2. Information is data that has been processed, manipulated, and organized into a meaningful and 

useful context. 
3. The first data processing operation is Data Capturing, which involves recording data via 

source documents or input devices. 
4. Data Manipulation includes the actions of Classifying, Calculating, Sorting, and Summarizing 

data. 
5. The decimal number system uses a base of 10 and the digits 0-9, and is primarily for human 

everyday use. 
6. The binary number system uses a base of 2 and the digits 0 and 1, and is used for internal 

computer processing. 
7. The octal number system uses a base of 8 and digits 0-7, historically used for compact binary 

representation (3 bits/digit). 
8. The hexadecimal number system uses a base of 16 and digits 0-9 and A-F, used for modern 

compact binary representation (4 bits/digit) and memory addressing. 
9. Binary representation is used because digital circuits are built from transistors with two stable 

states: ON (1) and OFF (0). 
10. To convert a decimal number to another base, repeatedly divide the decimal number by the 

target base and record remainders from bottom to top. 
11. To convert binary to octal, group bits into sets of three from the right, pad with leading zeros 

if needed, and convert each group to its octal digit. 
12. To convert binary to hexadecimal, group bits into sets of four from the right, pad with leading 

zeros if needed, and convert each group to its hex digit. 
13. To convert octal to binary, convert each octal digit to its 3-bit binary equivalent. 
14. To convert hexadecimal to binary, convert each hex digit to its 4-bit binary equivalent. 
15. Whole numbers (unsigned integers) use all bits for magnitude; for n bits, the range is 0 to (2ⁿ 

– 1). 
16. Signed integers use the Most Significant Bit (MSB) as a sign bit: 0 for positive, 1 for negative. 
17. The Two's Complement method is used to represent negative integers: invert all bits of the 

positive number and add 1 to the result. 
18. For an n-bit signed integer using two's complement, the range is -2ⁿ⁻¹ to (2ⁿ⁻¹ – 1). 
19. Real numbers (with fractions) are represented using floating-point notation: Sign × Mantissa × 

2^Exponent. 
20. Single-precision floating-point format uses 32 bits: 1 sign bit, 8 exponent bits, and 23 

mantissa bits. 
21. Double-precision floating-point format uses 64 bits: 1 sign bit, 11 exponent bits, and 52 

mantissa bits. 
22. To convert a fractional decimal part to binary, multiply the fraction by 2 repeatedly, recording 

the integer part each time. 
23. Binary addition follows the rules: 0+0=0, 0+1=1, 1+0=1, 1+1=0 with a carry of 1. 
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Practice MCQs
1. What is the key difference between 
data and information? 
a) Data is processed, information is raw. 
b) Data is meaningful, information is a 
collection of facts. 
c) Data is raw, information is processed 
and meaningful. 
d) Data is stored electronically, 
information is printed. 
Answer: c) Data is raw, information is 
processed and meaningful. 

2. Which of the following is NOT a step 
in data manipulation? 
a) Classifying 
b) Capturing 
c) Calculating 
d) Summarizing 
Answer: b) Capturing 

3. Which number system uses a base of 8 
and is historically significant for 
representing 3 binary bits per digit? 
a) Decimal 
b) Hexadecimal 
c) Octal 
d) Binary 
Answer: c) Octal 

4. What is the primary reason computers 
use the binary number system internally? 
a) It is easy for humans to understand. 
b) It allows for complex mathematical 
operations. 
c) It aligns with the two stable states 
(ON/OFF) of transistors in digital 
circuits. 
d) It provides the most compact 
representation of numbers. 
Answer: c) It aligns with the two stable 

states (ON/OFF) of transistors in 
digital circuits. 

5. To convert the decimal number 29 to 
binary, what is the correct sequence of 
remainders from the repeated division-
by-2 process? 
a) 10111 
b) 11101 
c) 11011 
d) 11110 
Answer: b) 11101 

6. The binary number 11010101 is 
equivalent to which hexadecimal 
number? 
a) D5 
b) C5 
c) D4 
d) E5 
Answer: a) D5 

7. What is the range of values for an 8-bit 
unsigned integer? 
a) -128 to +127 
b) 0 to 255 
c) -255 to +255 
d) 0 to 511 
Answer: b) 0 to 255 

8. In the two's complement 
representation, how is the negative 
equivalent of a positive binary number 
formed? 
a) Invert all bits. 
b) Invert all bits and subtract 1. 
c) Invert all bits and add 1. 
d) Add 1 to the number. 
Answer: c) Invert all bits and add 1. 
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Operating Systems 

Introduction to Software and Operating Systems 

What is Software? 

Software is a collection of computer programs, procedures, and associated documentation that 
instructs a computer on what to do and how to do it. Without software, a computer's hardware 
is a useless collection of electronic components. 

Types of Software 

Software is broadly classified into two main categories: 

1. System Software: This software is designed to manage and operate the computer hardware, 
providing a platform for running application software. It acts as an intermediary between the 
hardware and the user applications. 

o Examples: Operating Systems (Windows, macOS, Linux), Device Drivers (printer, graphics 
card drivers), Utility Programs (antivirus, disk cleanup, backup tools). 

o Purpose: To manage hardware resources and create a stable environment for other software. 

2. Application Software: This software is designed to help users perform specific tasks or solve 
particular problems. These programs fulfill user needs directly. 

o Examples: Word Processors (Microsoft Word, Google Docs), Web Browsers (Chrome, 
Firefox), Spreadsheet Software (Microsoft Excel), Graphic Design Software (Adobe 
Photoshop, GIMP), Games. 

o Purpose: To enable users to accomplish productive, creative, or entertainment-oriented tasks. 

Key Differences: 

• Control: System software controls the hardware; application software is controlled by the user 
to perform tasks. 

• Necessity: A computer cannot run without system software; application software is optional 
and installed based on user needs. 

• Installation: System software (especially the OS) is usually pre-installed; application software 
is installed by the user. 

Chapter 5 
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The history of Windows began in the mid-1980s and has seen many changes in both design and 
functionality. Windows has developed through decades of innovation, continuously adapting to 
meet user needs. 

Timeline of Key Windows Releases: 

Version Release 
Year Highlights 

Windows 1.0 1985 First GUI shell for MS-DOS; introduced overlapping 
windows concept 

Windows 3.1 1992 Widely adopted; introduced TrueType fonts, multimedia, 
and File Manager 

Windows 95 1995 Start menu, taskbar, plug-and-play hardware support; major 
breakthrough 

Windows 98 1998 Improved hardware compatibility, better web integration 
with Internet Explorer 

Windows ME 2000 Focused on home users; included System Restore and 
improved multimedia support 

Windows 2000 2000 Built for business users; introduced Active Directory 

Windows XP 2001 Highly stable; major redesign, used extensively in homes 
and businesses 

Windows Vista 2007 Introduced Aero Glass interface and better security; known 
for performance issues 

Windows 7 2009 Improved speed and usability; became a very popular 
version 

Windows 8 2012 Introduced tile-based Start screen; designed for touchscreens 

Windows 8.1 2013 Refined Windows 8 with better user experience and app 
integration 

Windows 10 2015 Returned to classic Start menu; added Cortana, virtual 
desktops, regular updates 

Windows 11 2021 Modernized interface, centered Start menu, enhanced 
gaming and productivity 

Notable Milestones: 

• Windows 95 introduced the Start Menu, revolutionizing navigation 

• Windows XP ran for more than a decade and was beloved for its stability 
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One Liners: Operating Systems 
1. Software is a collection of computer programs, procedures, and documentation that instructs 

a computer on what to do and how to do it. 
2. Without software, a computer's hardware is a useless collection of electronic components. 
3. System Software is designed to manage and operate computer hardware, providing a 

platform for running application software. 
4. System Software acts as an intermediary between hardware and user applications. 
5. Examples of System Software include Operating Systems, Device Drivers, and Utility 

Programs. 
6. The purpose of System Software is to manage hardware resources and create a stable 

environment for other software. 
7. Application Software is designed to help users perform specific tasks or solve particular 

problems. 
8. Application Software fulfills user needs directly, such as word processing or web browsing. 
9. System Software controls the hardware, whereas Application Software is controlled by the 

user to perform tasks. 
10. A computer cannot run without System Software; Application Software is optional and 

installed based on user needs. 
11. System Software (especially the OS) is usually pre-installed, while Application Software is 

installed by the user. 
12. An Operating System (OS) is the most critical type of System Software, acting as an 

interface between the user and hardware. 
13. The OS controls the execution of all programs and manages the computer's resources. 
14. The primary purpose of an OS is to act as a Resource Manager for hardware and software 

resources (CPU, memory, disk, I/O). 
15. An OS provides a User Interface, offering a stable, consistent way for users and applications 

to interact with hardware. 
16. A Command Line Interface (CLI) is a text-based interface where users type specific 

commands to instruct the computer. 
17. CLI is powerful and flexible but has a steep learning curve and requires command 

memorization. 
18. DOS (Disk Operating System) was one of the first widely-installed OS for IBM-compatible 

PCs, using commands like DIR and COPY. 
19. UNIX is a powerful, multi-user, multitasking OS developed at Bell Labs, forming the basis 

for Linux and macOS. 
20. A Menu-Driven Interface (MDI) presents users with a series of screens with list options, 

requiring no command memorization. 
21. MDI is simpler than CLI but less flexible, ideal for systems like ATMs and information 

kiosks. 
22. A Graphical User Interface (GUI) uses graphics (icons, windows, buttons) and is interacted 

with via a pointing device like a mouse. 
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Practice MCQs

1. What is the fundamental role of System 
Software? 
a) To help users perform specific tasks like 
word processing. 
b) To manage and operate computer 
hardware, providing a platform for 
application software. 
c) To provide entertainment and games for 
users. 
d) To connect the computer to the internet. 
Answer: b) To manage and operate 
computer hardware, providing a 
platform for application software. 

2. Which of the following is a key 
distinction between System Software and 
Application Software? 
a) System Software is optional, 
Application Software is essential. 
b) System Software is installed by the 
user, Application Software is pre-installed. 
c) A computer cannot run without System 
Software, but Application Software is 
optional. 
d) Application Software controls the 
hardware directly. 
Answer: c) A computer cannot run 
without System Software, but 
Application Software is optional. 

3. The most critical type of system 
software that acts as an interface between 
the user and the computer hardware is the: 
a) Device Driver 
b) Utility Program 
c) Operating System (OS) 
d) Compiler 
Answer: c) Operating System (OS) 

4. Which type of user interface is 
characterized by a text-based environment 

where users must type specific 
commands? 
a) Graphical User Interface (GUI) 
b) Menu-Driven Interface (MDI) 
c) Command Line Interface (CLI) 
d) Touch Interface 
Answer: c) Command Line Interface 
(CLI) 

5. Which early operating system was one 
of the first widely-installed for IBM-
compatible PCs and used commands like 
DIR and COPY? 
a) UNIX 
b) Windows 95 
c) DOS (Disk Operating System) 
d) macOS 
Answer: c) DOS (Disk Operating 
System) 

6. What is a primary advantage of a 
Graphical User Interface (GUI) over a 
Command Line Interface (CLI)? 
a) It offers more precise control over the 
file system. 
b) It is faster for experienced users to 
perform complex tasks. 
c) It is more user-friendly and easier to 
learn, using visual recognition. 
d) It uses fewer system resources like 
RAM and CPU. 
Answer: c) It is more user-friendly and 
easier to learn, using visual recognition. 

7. An OS that allows only one user to run 
multiple applications concurrently is 
classified as: 
a) Multi-User, Single-Tasking 
b) Single-User, Multitasking 
c) Multi-User, Multitasking 
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Office Automation 

Introduction to Office Automation 

Office Automation refers to the use of computer software and systems to digitally create, 
collect, store, manipulate, and relay office information to accomplish core tasks. The primary 
applications involved are Word Processors, Spreadsheets, Database Management Systems, and 
Presentation Software. This chapter provides a comprehensive guide to Word Processing and 
Spreadsheet software, their features, interfaces, and practical operations. 

Word Processing 

What is a Word Processor? 

A Word Processor is application software used for the composition, editing, formatting, and 
printing of text-based documents. It goes beyond simple typing by allowing the manipulation 
of text, insertion of images, sounds, charts, graphics, and even video clips. Documents can be 
saved in various formats (.txt, .rtf, .html, .doc, .docx) and published on the web with hyperlinks. 
Its greatest advantage over a typewriter is the ability to make changes without retyping the entire 
document. 

Examples of Word Processing Software: MS Word, WordPerfect, OpenOffice Writer, 
Google Docs, AbiWord, Apple iWork. 

Categories of Word Processors 

Text Editors (Simple Word Processors) 

These support basic features only. Examples include WordPad and Notepad. 
Basic Features: 

• Insert & Delete Text: Add or erase characters, words, lines, or pages. 

• Cut, Copy & Paste: Move or duplicate sections of text. 

• Page Size & Margins: Define page layout; text readjusts automatically. 

• Search & Replace: Find and optionally replace specific words/phrases. 

• Word Wrap: Text automatically moves to the next line. 

Chapter 6 
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One Liners: Office Automation 
1. Office Automation uses computer software to digitally create, collect, store, manipulate, and 

relay office information to accomplish core tasks. 
2. Primary applications of office automation include Word Processors, Spreadsheets, Database 

Management Systems, and Presentation Software. 
3. A Word Processor is application software used for the composition, editing, formatting, and 

printing of text-based documents. 
4. A key advantage of a word processor over a typewriter is the ability to make changes without 

retyping the entire document. 
5. Text Editors (simple word processors) support only basic features like insert, delete, cut, copy, 

paste, and word wrap. 
6. Full-Featured Word Processors support advanced capabilities like mail merge, macros, 

footnotes, and table of contents generation. 
7. The WYSIWYG (What You See Is What You Get) feature ensures the on-screen display 

matches the printed output. 
8. The Title Bar in a word processor window displays the name of the active document and the 

application. 
9. The Ribbon in modern word processors replaced menus and contains tabs grouping related 

commands. 
10. The Quick Access Toolbar is a customizable bar for frequently used commands like Save, 

Undo, and Redo. 
11. The Ruler shows text positioning, tabs, margins, and indents both horizontally and vertically. 
12. The Document Window is the main area for creating and editing, with a blinking cursor 

indicating the insertion point. 
13. The Status Bar shows document information such as page number, word count, and zoom 

level. 
14. Ctrl+N is the keyboard shortcut to create a new document in most word processors. 
15. Ctrl+S is the shortcut to save a document, while Ctrl+O is used to open an existing document. 
16. Ctrl+P opens the Print dialog box for printing a document. 
17. In Insert Mode (default), new text pushes existing text forward. 
18. In Overtype Mode, new text overwrites existing text at the cursor position. 
19. Ctrl+A selects the entire document's content. 
20. The Backspace key deletes characters to the left of the cursor, while the Delete key deletes 

characters to the right. 
21. Cut (Ctrl+X), Copy (Ctrl+C), and Paste (Ctrl+V) are used to move or duplicate text via the 

Clipboard. 
22. The Clipboard is a temporary memory space managed by the operating system for transferring 

data between applications. 
23. Undo (Ctrl+Z) reverses the last action, and Redo (Ctrl+Y) reapplies it. 
24. Font Formatting involves changing the appearance of characters, including type, size, style, 

and color. 
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Practice MCQs
1. What is the primary purpose of Office 
Automation? 
a) To replace human workers entirely 
b) To use computer software to digitally 
create, store, manipulate, and relay office 
information 
c) To design hardware for office use 
d) To provide entertainment in the 
workplace 
Answer: b) To use computer software 
to digitally create, store, manipulate, 
and relay office information 

2. Which of the following is NOT a 
primary application of office automation? 
a) Word Processor 
b) Spreadsheet 
c) Operating System 
d) Database Management System 
Answer: c) Operating System 

3. The greatest advantage of a word 
processor over a traditional typewriter is: 
a) It is more expensive 
b) It makes a louder sound 
c) It allows changes without retyping the 
entire document 
d) It uses more paper 
Answer: c) It allows changes without 
retyping the entire document 

4. Which word processing feature ensures 
that the on-screen display exactly 
matches the printed output? 
a) AutoCorrect 
b) WYSIWYG (What You See Is What 
You Get) 
c) Word Wrap 
d) Mail Merge 
Answer: b) WYSIWYG (What You See 
Is What You Get) 

5. In a word processor window, which 
component is a customizable bar for 
frequently used commands like Save and 
Undo? 
a) Title Bar 
b) Ribbon 
c) Quick Access Toolbar 
d) Status Bar 
Answer: c) Quick Access Toolbar 

6. What is the keyboard shortcut to select 
all text in a document? 
a) Ctrl+C 
b) Ctrl+V 
c) Ctrl+A 
d) Ctrl+X 
Answer: c) Ctrl+A 

7. Which typing mode causes new text to 
overwrite existing text at the cursor 
position? 
a) Insert Mode 
b) Overtype Mode 
c) Replace Mode 
d) Typeover Mode 
Answer: b) Overtype Mode 

8. The temporary memory space used by 
the operating system to hold cut or copied 
data for pasting is called the: 
a) Cache 
b) Clipboard 
c) RAM 
d) Hard Drive 
Answer: b) Clipboard 

9. Which font type has small decorative 
strokes at the ends of characters and is 
generally better for printed body text? 
a) Sans-serif 
b) Script 
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Microsoft Word (MS Word) 
With Word you can: 

 Create a document from scratch or from a template . 
 Add text, images, art, and videos. 
 Research a topic and find credible sources. 
 Access your documents from a computer, tablet, or phone via OneDrive. 
 Share your documents and collaborate with others. 
 Track and review changes. 

Create a new document 

1. On the File tab, select New. 
2. Select Blank document, or double-click a template image or type the kind of document into 

the Search for online templates box and press Enter. 
Tip:  For practice using Word features, try a learning guide like Welcome to Word or Insert your 
first table of contents. 

Add and format text 

1. Click on your new blank page and type some text. 

  

Chapter 8 
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For a basic table, click Insert > Table and move the cursor over the grid until you highlight the 
number of columns and rows you want. 

For a larger table, or to customize a table, select Insert > Table > Insert Table. 

 
Tips:  

 If you already have text separated by tabs, you can quickly convert it to a table. 
Select Insert > Table, and then select Convert Text to Table. 

 To draw your own table, select Insert > Table > Draw Table 

Save a document 

Save your document to OneDrive so you can get to it from anywhere – at work, at home, or on the go. 
Or save to another location, like your desktop. 

1. On the File tab, select Save As or Save a Copy. 
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3. Select the layout you want. 

Tip:  In Line with Text puts the picture in a paragraph, just as if it were text. The picture will 
change position as text is added or removed. The other choices let you move the picture around on 
the page, with text flowing around it. 

Save a document 

Save your document to OneDrive so you can get to it from anywhere – at work, at home, or on the go. 
Or save to another location, like your desktop. 

1. On the File tab, select Save As or Save a Copy. 

2. In the Save dialog, select OneDrive. 

3. Update the name and file type if you want, and select  Save.  

Save personal files to OneDrive - Personal, and work files to your company OneDrive or 
SharePoint site. 

4. Select Browse, and navigate to any location including the Desktop. 

5. Enter a name, and select  Save. 
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One Liners: MS Word 
1. Microsoft Word allows you to create documents from scratch or from an online template. 
2. You can research topics and find credible sources directly within Microsoft Word. 
3. Documents can be accessed from a computer, tablet, or phone via OneDrive. 
4. Word facilitates document sharing and collaboration with others. 
5. The Track and Review changes feature is available in Microsoft Word. 
6. A new blank document is created from the File tab by selecting New and then Blank 

document. 
7. To create a document from a template, you can double-click a template image or search in 

the Search for online templates box. 
8. Learning guides like Welcome to Word are available for practice with Word features. 
9. Text is formatted using options on the Home tab such as Bold, Italic, Bullets, 

and Numbering. 
10. The Insert tab is used to add elements like Tables, Pictures, Shapes, SmartArt, Charts, and 

Screenshots. 
11. A table is inserted by selecting Insert > Table and hovering over a grid to choose the 

number of rows and columns. 
12. For a larger or customized table, use Insert > Table > Insert Table. 
13. Existing text separated by tabs can be converted to a table using Insert > Table > Convert 

Text to Table. 
14. You can draw a custom table using Insert > Table > Draw Table. 
15. To add text, place the cursor at the desired location and start typing. 
16. To replace text, select it and start typing; double-click selects a single word. 
17. Clicking to the left of a line selects the entire line. 
18. Text formatting can be applied from the pop-up toolbar or the Home tab's Font group. 
19. The Format Painter tool copies formatting from one text selection to another. 
20. Double-clicking the Format Painter allows copying formatting to multiple locations. 
21. To save a document to OneDrive, use File > Save As or Save a Copy and 

select OneDrive. 
22. Save personal files to OneDrive - Personal and work files to your company's OneDrive 

or SharePoint site. 
23. You can also save a document to other locations like the Desktop by selecting Browse. 
24. AutoSave automatically saves changes when a document is stored in OneDrive or 

SharePoint. 
25. AutoSave can be toggled on or off from the Quick Access Toolbar. 
26. The Quick Access Toolbar can be shown by right-clicking the ribbon and selecting Show 

Quick Access Toolbar. 
27. Pictures can be inserted from your PC (This Device), from Stock Images, or from the web 

(Online Pictures). 
28. In older Word versions, the option for online pictures may be labeled Online 

Pictures next to Pictures. 
29. To resize a picture, select it and drag a corner handle. 
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Practice MCQs
1. In Microsoft Word, where do you go 
to create a brand new document from a 
blank slate? 
a) Home > New 
b) File > New > Blank document 
c) Insert > New Document 
d) View > New Window 
Answer: b) File > New > Blank 
document 

2. Which feature in Word allows you to 
automatically save changes when your 
document is stored on OneDrive? 
a) AutoRecover 
b) Quick Save 
c) AutoSave 
d) Background Save 
Answer: c) AutoSave 

3. To quickly convert text separated by 
tabs into a structured table, which 
command should you use? 
a) Insert > Table > Draw Table 
b) Insert > Table > Excel Spreadsheet 
c) Insert > Table > Convert Text to Table 
d) Layout > Convert > Text to Table 
Answer: c) Insert > Table > Convert Text 
to Table 

4. What is the primary function of the 
Format Painter tool in Word? 
a) To change the page color 
b) To copy formatting from one text 
selection to another 
c) To insert painterly art effects 
d) To adjust paragraph spacing 
Answer: b) To copy formatting from one 
text selection to another 

5. How do you ensure that the header 
on the first page of your document is 
different from the rest (e.g., blank)? 

a) Delete the header on the first page 
manually. 
b) Insert a section break after the first page. 
c) Check the Different First Page box in 
the Header & Footer Tools. 
d) Use File > Options to disable the first 
page header. 
Answer: c) Check the Different First 
Page box in the Header & Footer Tools. 

6. When inserting a picture, which text 
wrapping option places the picture within 
the text paragraph, causing it to move as 
text is edited? 
a) Square 
b) Tight 
c) Behind Text 
d) In Line with Text 
Answer: d) In Line with Text 

7. You want to start page numbering 
from "1" on the second page of your 
document. What should you set the "Start 
at" value to in the Page Number Format 
dialog? 
a) 1 
b) 0 
c) 2 
d) -1 
Answer: b) 0 

8. To create a custom watermark using 
your company logo, which sequence of 
commands do you follow? 
a) Design > Watermark > Custom 
Watermark > Picture watermark 
b) Insert > Picture > Set as Watermark 
c) Page Layout > Background > Custom 
Watermark 
d) View > Watermark > Insert Picture 
Answer: a) Design > Watermark > 
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Microsoft Excel (MS Excel) 
What is Excel? 

Excel makes it easy to crunch numbers. With Excel, you can streamline data entry with AutoFill. Then, 
get chart recommendations based on your data, and create them with one click. Or easily spot trends and 
patterns with data bars, color coding, and icons. 

Create a workbook 

1. Open Excel. 

2. Select Blank workbook. Or press Ctrl+N. 

Enter data 

To manually enter data: 

1. Select an empty cell, such as A1, and then type text or a number. 

2. Press Enter or Tab to move to the next cell. 

To fill data in a series: 

1. Enter the beginning of the series in two cells: such as Jan and Feb; or 2014 and 2015. 
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AutoSum vertically 

In the figure above, the AutoSum feature is seen to automatically detect cells B2:B5 as the range 
to sum. All you need to do is press ENTER to confirm it. If you need to add/exclude more cells, 
you can hold the Shift Key + the arrow key of your choice until your selection matches what you 
want. Then press Enter to complete the task. 

Intelligence function guide: the SUM(number1,[number2], …) floating tag beneath the function 
is its Intelligence guide. If you click the SUM or function name, it will change o a blue hyperlink 
to the Help topic for that function. If you click the individual function elements, their representative 
pieces in the formula will be highlighted. In this case, only B2:B5 would be highlighted, since 
there is only one number reference in this formula. The Intellisense tag will appear for any 
function. 
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When you copy the formula, ensure that the cell references are correct. Cell references may 
change if they have relative references.  

What can I use in a formula to mimic calculator keys? 

Calculator key Excel method Description, example Result 

+ (Plus key) + (plus) Use in a formula to add numbers. Example: 
=4+6+2 

12 

- (Minus key) - (minus) Use in a formula to subtract numbers or to 
signify a negative number. 
Example: =18-12 
Example: =24*-5 (24 times negative 5) 

 
6 
-120 

x (Multiply key) * (asterisk; also 
called "star") 

Use in a formula to multiply numbers. Example: 
=8*3 

24 

÷ (Divide key) / (forward slash) Use in a formula to divide one number by 
another. Example: =45/5 

9 

% (Percent key) % (percent) Use in a formula with * to multiply by a 
percent. Example: =15%*20 

3 

√ (square root) SQRT (function) Use the SQRT function in a formula to find the 
square root of a number. Example: =SQRT(64) 

8 

1/x (reciprocal) =1/n Use =1/n in a formula, where n is the number 
you want to divide 1 by. 
Example: =1/8 

0.125 

Add a watermark in Excel 

You can use an image, such as a logo, to insert as a watermark that will appear on the 
spreadsheet along with the displayed data.  

Create a watermark 

1. Select Insert > Header & Footer. 
2. Tap on the header and on the Header & Footer Elements tab on the ribbon, click Picture. 
3. Select one of the available options to insert your image. In the header, you'll see & 

[Picture]. 
4. Tap anywhere outside the header to see the watermark. 



 

  MK PREPARATIONS  

 

P a g e  12 | 48 

 

  

9
. M

S E
x

ce
l 

 
 M 

K 
 

P 
R 
E 
P 
A 
R 
A 
T 
I 
O 
N 
S 

MK PREPARATIONS: Let’s Make It Happen 
+92 333 2605045, +92 342 4470091 
 

2. Select Insert > Recommended Charts. 
3. Select a chart on the Recommended Charts tab, to preview the chart. 
4. Select a chart. 
5. Select OK. 

Add a trendline 

1. Select a chart. 
2. Select Chart Design > Add Chart Element. 
3. Select Trendline and then select the type of trendline you want, such 

as Linear, Exponential, Linear Forecast, or Moving Average. 

Available number formats in Excel 

In Excel, you can format numbers in cells for things like currency, percentages, decimals, dates, 
phone numbers, or social security numbers. 

1. Select a cell or a cell range. 
2. On the Home tab, select Number from the drop-down. 

Or, you can choose one of these options: 

 Press CTRL + 1 and select Number. 

 Right-click the cell or cell range, select Format Cells… , and select Number. 

 Select the small arrow, dialog box launcher, and then select Number. 

3. Select the format you want. 
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Number formats 

To see all available number formats, select the Dialog Box Launcher next to Number on 

the Home tab in the Number group. 

Format Description 

General The default number format that Excel applies when you type a number. For the most 
part, numbers that are formatted with the General format are displayed just the way 
you type them. However, if the cell is not wide enough to show the entire number, 
the General format rounds the numbers with decimals. The General number format 
also uses scientific (exponential) notation for large numbers (12 or more digits). 

Number Used for the general display of numbers. You can specify the number of decimal 
places that you want to use, whether you want to use a thousands separator, and how 
you want to display negative numbers. 

Currency Used for general monetary values and displays the default currency symbol with 
numbers. You can specify the number of decimal places that you want to use, 
whether you want to use a thousands separator, and how you want to display 
negative numbers. 

Accounting Also used for monetary values, but it aligns the currency symbols and decimal 
points of numbers in a column. 

Date Displays date and time serial numbers as date values, according to the type and 
locale (location) that you specify. Date formats that begin with an asterisk (*) 
respond to changes in regional date and time settings that are specified in Control 
Panel. Formats without an asterisk are not affected by Control Panel settings. 
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In general, it's best to place constants in individual cells where they can be easily changed if 
needed, then reference those cells in formulas. 

Using references in Excel formulas 

A reference identifies a cell or a range of cells on a worksheet, and tells Excel where to look for 
the values or data you want to use in a formula. You can use references to use data contained in 
different parts of a worksheet in one formula or use the value from one cell in several formulas. 
You can also refer to cells on other sheets in the same workbook, and to other workbooks. 
References to cells in other workbooks are called links or external references. 

The A1 reference style 

By default, Excel uses the A1 reference style, which refers to columns with letters (A through 
XFD, for a total of 16,384 columns) and refers to rows with numbers (1 through 1,048,576). 
These letters and numbers are called row and column headings. To refer to a cell, enter the 
column letter followed by the row number. For example, B2 refers to the cell at the 
intersection of column B and row 2. 

To refer to Use 

The cell in column A and row 10 A10 

The range of cells in column A and rows 10 through 20 A10:A20 

The range of cells in row 15 and columns B through E B15:E15 

All cells in row 5 5:5 

All cells in rows 5 through 10 5:10 

All cells in column H H:H 

All cells in columns H through J H:J 

The range of cells in columns A through E and rows 10 through 20 A10:E20 
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Some Sample Formulas 

Basic Formulas 

Formula Structure Explanation 

AVERAGE =AVERAGE(A2:A10) Returns a mathematical average of a given cell range 
COUNT =COUNT(A2:A10) Returns the count of the numbers in given cell range 
MAX =MAX(A2:A10) Finds the largest value in a given cell range 
MEDIAN =MEDIAN(A2:A10) Returns the median value, or middle value, in a given 

cell range 
MIN =MIN(A2:A10) Finds the smallest value in a given cell range 
SUM =SUM(A2:A10) Totals numbers in a given cell range 

Cell range A2:A10 is used above to indicate that each formula uses a cell range as it 
arguments 

Time Formulas 

Formula Structure Explanation 

TODAY =TODAY() Volatile – takes no arguments – returns today’s date 
NOW =NOW() Volatile – takes no arguments – returns today’s date and time 
DATEDIF =DATEDIF(Start 

Date, End Date, 
Unit) 

Returns the number of years, months or days between two dates 
• Start Date – date furthest in the past 
• Unit could be “Y” for years, “M” for months or “D” for days 
• Units must be in double quotes 
• This formula is NOT in the function library 

YEAR =YEAR(Date) • Returns the year portion of date 
• Example =YEAR(7/16/2005) would return 2005 

MONTH =MONTH(Date) • Returns the month portion of date 
• Example =MONTH(7/16/2005) would return 7 

DAY =DAY(Date) • Returns the day portion of date 
• Example =DAY(7/16/2005) would return 16 

Use a time formula and get an answer you didn’t expect? If you got a date and were expecting 
a number, remember to change the formatting from date to number. If you got a number and 
were expecting a date, change the formatting to date
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One Liners: MS Excel 

1. Excel simplifies numerical calculations and data entry with features like AutoFill. 

2. Chart recommendations based on your data can be created with a single click in Excel. 

3. Trends and patterns can be easily visualized using data bars, color coding, and icons in 

Excel. 

4. A new blank workbook is created by selecting Blank workbook or pressing Ctrl+N. 

5. To enter data manually, select a cell, type, and press Enter or Tab to move to the next cell. 

6. The AutoFill series is created by entering the start of the series in two cells and dragging 

the fill handle. 

7. Excel can perform calculations using simple formulas for addition, subtraction, 

multiplication, and division. 

8. All Excel formulas must begin with an equal sign (=). 

9. The basic arithmetic operators are: plus (+) for addition, minus (-) for subtraction, asterisk 

(*) for multiplication, and forward slash (/) for division. 

10. There is no dedicated SUBTRACT function in Excel; the minus operator (-) is used 

within a formula. 

11. The SUM function can incorporate negative numbers using a minus sign, e.g., 

=SUM(12,5,-3,8,-4). 

12. The AutoSum feature automatically senses a contiguous range and inserts a SUM 

formula. 

13. AutoSum can be applied both vertically (above/below a range) and horizontally (left/right 

of a range). 

14. AutoSum does not work on non-contiguous ranges of cells. 

15. The Intellisense guide for a function appears as a floating tag and provides a hyperlink to 

its Help topic. 

16. After creating a formula, you can copy it to adjacent cells to avoid rewriting it. 

17. When a formula with relative references is copied, the cell references update automatically 

relative to their new position. 
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Practice MCQs
1. Which keyboard shortcut is used to 

create a new blank workbook in Excel? 
a) Ctrl+B 
b) Ctrl+N 
c) Ctrl+W 
d) Ctrl+T 
Answer: b) Ctrl+N 

2. To automatically fill a series like "Jan, 
Feb, Mar..." what must you do first? 
a) Type the entire series once. 
b) Use the Fill Series dialog box. 
c) Enter the beginning of the series in 
two cells and select them. 
d) Select the cells and choose "Fill 
Series" from the Data tab. 
Answer: c) Enter the beginning of the 
series in two cells and select them. 

3. What is a fundamental requirement for 
every Excel formula? 
a) It must contain a function. 
b) It must reference another cell. 
c) It must begin with an equal sign (=). 
d) It must be enclosed in parentheses. 
Answer: c) It must begin with an 
equal sign (=). 

4. How does Excel handle subtraction 
within a formula, given there is no 
SUBTRACT function? 
a) It uses the SUM function with 
negative numbers. 
b) It uses the DIF function. 
c) It uses the minus (-) operator. 
d) Both a and c are correct. 
Answer: d) Both a and c are correct. 

5. The AutoSum feature is designed to 
work with which type of cell ranges? 
a) 3-D references 
b) Non-contiguous ranges 
c) Contiguous ranges 

d) Array ranges 
Answer: c) Contiguous ranges 

6. When you copy a formula containing a 
relative cell reference like =A1 to the 
cell one column to the right, what does it 
become? 
a) =A1 
b) =$A$1 
c) =B1 
d) =A2 
Answer: c) =B1 

7. In Excel, which function is equivalent to 
the calculator's square root (√) key? 
a) SQR 
b) ROOT 
c) SQRT 
d) POWER(...,0.5) 
Answer: c) SQRT 

8. Where is a watermark picture inserted in 
an Excel worksheet to appear behind the 
data? 
a) As a background from the Page 
Layout tab. 
b) Into the header or footer via Insert > 
Header & Footer. 
c) As an inline image on the worksheet. 
d) Using the Watermark option on the 
Design tab. 
Answer: b) Into the header or footer 
via Insert > Header & Footer. 

9. What happens to the contents of cells 
B2, C2, and D2 when they are merged 
into one cell? 
a) All contents are concatenated. 
b) Only the content of the upper-left cell 
(B2) is kept. 
c) The contents are averaged. 
d) An error message appears. 
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Microsoft PowerPoint (MS PowerPoint) 
What is PowerPoint? 

Overview 

 With PowerPoint on your PC, Mac, or mobile device, you can: 
 Create presentations from scratch or a template. 
 Add text, images, art, and videos. 
 Select a professional design with PowerPoint Designer. 
 Add transitions, animations, and cinematic motion. 
 Save to OneDrive, to get to your presentations from your computer, tablet, or phone. 
 Share your work and work with others, wherever they are. 

Create a presentation in PowerPoint 

Create presentations from scratch or start with a professionally designed, fully customizable 
template from Microsoft Create. 

Tip: If you have Microsoft Copilot it can help you create a presentation, add slides or images, 
and more. To learn more see Create a new presentation with Copilot in PowerPoint. 

Create a presentation 

1. Open PowerPoint. 
2. In the left pane, select New. 
3. Select an option: 

 To create a presentation from scratch, select Blank Presentation. 
 To use a prepared design, select one of the templates. 

Chapter 9 

https://go.microsoft.com/fwlink/?linkid=2226436
https://go.microsoft.com/fwlink/?linkid=2226436
https://support.microsoft.com/en-us/office/create-a-new-presentation-with-copilot-in-powerpoint-3222ee03-f5a4-4d27-8642-9c387ab4854d


 
 

  MK PREPARATIONS  

 

P a g e  7 | 65 

 

  

9
. M

icro
so

ft P
o

w
e

r P
o

in
t 

 
 

M 
K 
 

P 
R 
E 
P 
A 
R 
A 
T 
I 
O 
N 
S 

MK PREPARATIONS: Let’s Make It Happen 
+92 333 2605045, +92 342 4470091 
 

Give a presentation in PowerPoint 

Start a presentation 

 On the Slide Show tab select From Beginning. Now, if you are working with PowerPoint 
on a single monitor and you want to display Presenter view, in Slide Show view, on the 
control bar at the bottom left select the three dots, and then Show Presenter View. 

 To move to the previous or next slide, select Previous or Next. 

 To view all the slides in your presentation, select See all slides. 

Notes 

During your presentation, the speaker notes are visible on your monitor, but aren't visible to the 
audience. 

 The Notes pane is a box that appears below each slide. Tap it to add notes. 

  

 If you don’t see the Notes pane or it is completely minimized, click Notes on the task bar 
across the bottom of the PowerPoint window 
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2. If offered, choose a color variation, and then select Create. 

If you change your mind, you can always change the theme or variant later on the Design tab. 

1. On the Design tab, pick a theme with the colors, fonts, and effects that you like. 

2. To apply a different color variation of a particular theme, in the Variants group, pick a 
variant. 
 Note: If you don't see any variants, it could be because you're using a custom theme, an older 
theme designed for earlier versions of PowerPoint, or because you imported some slides from 
another presentation with an older or custom theme. 

3. Select right arrow in the Variants group to select different Colors, Fonts, Effects, 
or Background Styles and choose from built-in options or customize your own. 

Create and save a custom theme 

You can create a custom theme by modifying an existing theme or by starting from scratch with 
a blank presentation. 

1. Select your first slide, and then on the Design tab, select the down arrow in the Variants 
group. 

2. Select Colors, Fonts, Effects, or Background Styles and choose from built-in options or 
customize your own. 

3. When you're done customizing styles, select the down arrow in the Themes group, and then 
select Save Current Theme. 

4. Give your theme a name, and select Save. By default, it is save with your other PowerPoint 
themes and will be available in the Themes group under a Custom header. 

Change the page orientation in PowerPoint between landscape and portrait 

PowerPoint slides are automatically set up in landscape (horizontal) layout , but you can 

change the slide orientation to portrait (vertical) layout . 
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Rotate (mirror) text in a shape or text box 

1. Insert a text box or shape in your document, and then type and format your text. 

2. Right-click the box or shape and select Format Shape. 

3. In the Format Shape pane, under Shape Options, select Effects. 

4. Under 3-D Rotation , in the X Rotation or Y Rotation box, enter 180 . 

5. (Optional) If your text box becomes filled with a color, you can remove the color in 

the Format Shape pane. Under Shape Options , click the Fill & Line tab , 
expand Fill , and select No fill . 

6. (Optional) To remove the text box outline, right-click the text box, click Outline in the mini 
toolbar that appears, and choose No Outline . 

Position text horizontally in a shape or text box 

 



 
 

  MK PREPARATIONS  

 

P a g e  50 | 65 

 

  

9
. M

icro
so

ft P
o

w
e

r P
o

in
t 

 
 

M 
K 
 

P 
R 
E 
P 
A 
R 
A 
T 
I 
O 
N 
S 

MK PREPARATIONS: Let’s Make It Happen 
+92 333 2605045, +92 342 4470091 
 

One Liners: MS Power Point 
1. PowerPoint allows you to create presentations from scratch or from professionally 

designed templates. 

2. With Microsoft Copilot, you can get assistance creating presentations, adding slides, 

images, and more. 

3. To create a new presentation, open PowerPoint, select New in the left pane, and 

choose Blank Presentation or a template. 

4. The Take a Tour option provides tips for using PowerPoint. 

5. A new slide is added by selecting a slide in the thumbnail pane, then going to Home > 

Slides > New Slide. 

6. The layout for a new slide is chosen from the Layout menu in the Slides section on 

the Home tab. 

7. Text is formatted using options like Font, Bold, Italic, Increase Font Size, and Decrease 

Font Size in the Home tab's Font section. 

8. Bulleted or numbered lists are created by selecting text and 

choosing Bullets or Numbering on the Home tab. 

9. Pictures are inserted from the Insert tab, Images section, by selecting Pictures and 

choosing a source. 

10. Illustrations such as Shapes, Icons, 3D Models, SmartArt, and Charts are inserted from 

the Illustrations section of the Insert tab. 

11. To save a presentation to the cloud for access and collaboration, use File > Save As and 

select OneDrive. 

12. Save personal files to OneDrive - Personal and work files to your company OneDrive. 

13. AutoSave is always on when you're online and saves changes as you work; pending 

changes sync when you reconnect. 

14. Themes and their Variants are applied from the Design tab. 

15. PowerPoint Designer suggests design ideas when you insert pictures, a list, or dates; it 

opens automatically. 
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Practice MCQs
1. What is the primary purpose of 

Microsoft Copilot in PowerPoint as 
mentioned in the chapter? 
a) To design custom animations 
b) To help create presentations, add 
slides or images, and more 
c) To automatically record narration 
d) To convert presentations to video 
Answer: b) To help create 
presentations, add slides or images, 
and more 

2. Where is the "Take a Tour" option 
located when creating a new 
presentation? 
a) On the Design tab 
b) In the New pane after 
selecting Blank Presentation 
c) Under File > Options 
d) On the Slide Show tab 
Answer: b) In the New pane after 
selecting Blank Presentation 

3. To apply a professional design 
suggestion automatically after inserting 
a picture, which feature should you 
use? 
a) Slide Master 
b) Transitions 
c) PowerPoint Designer 
d) Animation Painter 
Answer: c) PowerPoint Designer 

4. How do you access the Presenter 
View when running a slide show on a 
single monitor? 
a) Press F5 
b) Select Slide Show > Presenter View 
c) Click the three dots (...) on the 
control bar in Slide Show view 
d) It automatically appears if notes are 

added 
Answer: c) Click the three dots (...) 
on the control bar in Slide Show view 

5. If you want a company logo to appear 
on every slide in the same position, 
where should you place it? 
a) On the first slide only 
b) On the Slide Master 
c) As a watermark from the Design tab 
d) In the Header & Footer dialog 
Answer: b) On the Slide Master 

6. What happens when you edit a layout 
master in Slide Master view? 
a) Only new slides based on that layout 
will reflect the changes. 
b) All existing slides immediately 
update. 
c) Only the title slide changes. 
d) You must manually update each 
slide. 
Answer: a) Only new slides based on 
that layout will reflect the changes. 

7. Which of the following is NOT a 
standard method to delete a sequence of 
contiguous slides? 
a) Press Shift, select the first and last 
slides, right-click, choose Delete Slide. 
b) Press Ctrl, select each slide 
individually, right-click, choose Delete 
Slide. 
c) Go to Slide Sorter view, select the 
slides, and press Delete. 
d) The chapter does not mention using 
the Delete key. 
Answer: b) Press Ctrl, select each 
slide individually, right-click, choose 
Delete Slide. (This is for non-adjacent 
slides) 



 

  MK PREPARATIONS  

 

P a g e  1 | 35 

 

  

1
0

. K
e

y
b

o
a

rd
 a

n
d

 Sh
o

rt K
e

y
s 

  

M 
K 
 

P 
R 
E 
P 
A 
R 
A 
T 
I 
O 
N 
S 

MK PREPARATIONS: Let’s Make It Happen 
+92 333 2605045, +92 342 4470091 
 

Key-Board and Shortcut Keys 
What is KEYBOARD? 

• A panel/plate/board of keys that operates a computer or typewriters. 

• A piece of computer hardware used to input text, characters, and other commands into a 
computer or similar device 

Types of Keys Setup on Keyboard: 

Keyboard Shortcut keys: 

1. Set of one or more keys that generates a particular command to be executed. 

2. Generally executed by using Alt or Ctrl keys with some other keys 

3. A plus (+) sign between two or more keys indicates that these keys 
should pressed in combination. For example Ctrl+Shift+A means to press 
and hold Ctrl and Shift and then press A 

Chapter 10 
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Frequently used Keys: 

 

Key Function 

Alt Key • Key modifier that enables a different input 

Escape (esc) key 
• Cancel the current operation 

• Exit the currant window 

Space bar • Move the curser one space forward 

Tab Key 
• Move the cursor several space foreword 

• Move to next text box on a form or on a table 

Control (ctrl) Key 

• Modifer key 

• Pressed in conjuction with another key performed a specific 

task 

Back Space Key Move the curser one space backward 

 
Enter Key 

• Move the curser to the beginning of the next line 

• In a dialogue box enable the highlighted option 

• In some program start the next operation 
or confirm the current operation 
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Microsoft Power Point Shortcut Keys 

Shortcut Keys Operation 

12 Save As. 

Alt + F4 Close PowerPoint 

Ctrl + M Insert a new slide. 

Ctrl + D Duplicate the selected slide. 

Ctrl + Shift + D Duplicate the selected slide. 

Page Up/Down Navigate to the previous/next slide 

Ctrl + G Group objects. 

Ctrl + Spacebar Reset manual character formatting 

Shift + F3 Change the case of selected text. 

Alt + Q "Tell me what you want to do". 

Ctrl + T Open the Font window. 

Ctrl + K Insert a hyperlink. 

Ctrl + Tab Switch between open presentations. 

Alt + F9 Show/hide gridlines and guides 

Alt + F10 Show/hide selection pane. 
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Tip: Basic text editing and formatting shortcut keys for MS word is same for MS Excel and MS 
Power Point. 

Outlook Shortcut Keys 

Shortcut Keys Operation 

Alt + S Send the E-mail 

Ctrl + C Copy selected text 

Ctrl + X Cut selected text 

Ctrl + P Open Print dialogue box 

Ctrl + K Complete name/E-mail type in address bar 

Ctrl + B Bold highlighted selection 

Ctrl + I Italicized highlighted selection 

Ctrl + U Underline highlighted selection 

Alt + N Access the Insert tab. 

Alt + H Access the Home tab. 

Esc End the slideshow. 

Shift + F5 Start the slideshow from the current slide. 

F5 Start the slideshow from the beginning. 

Ctrl + Move Item with Mouse Duplicate the item 

Shift + Select Item with Mouse Add to selection. 

Ctrl + Shift + G Ungroup objects. 
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PDF Portable Document Format  TCPIP Transmission control 
protocol internet 
protocol 

PING Packet Internet Groper URL Uniform resource 
locater 

RAM Random Access Memory  USB Universal Serial Bus 

VGA Video Graphic Array HDD Hard Disk Drive 

HDMI High Definition Media 
Interface 

MP3 MPEG (Motion picture 
Expert Group) layer 3 

Wifi Wireless Fidelity  MS Microsoft 

WLAN Wireless Local Area 
Network 

OS Operating System 

AVI Audio Video Interleave RGB Red, Green, Blue 

ALU Arithmetic logic Unit DSL Digital Subscriber Line 

Computer memory units: 

Basic memory unit  1 Bit 

8 bits 1 Byte  

1024 Byte 1 Kilobytes (KB) 

1024 Kilobytes  1 Megabytes (1MB) 

1024 Megabytes  1 Gigabytes (1GB) 

1024 Gigabytes  1 Terabyte (TB) 

1024 Terabyte  1 Petabyte (1PB) 

1024 Petabytes 1 Exabyte (EB) 
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One Liners: Keyboard and shortcut Keys 

1. A keyboard is a panel of keys used to operate a computer or typewriter. 

2. A keyboard is a piece of computer hardware used to input text, characters, and other 

commands. 

3. Keyboard shortcut keys are a set of one or more keys that generate a particular command to 

be executed. 

4. Shortcut keys are generally executed by using the Alt or Ctrl keys in combination with other 

keys. 

5. A plus (+) sign between keys indicates that those keys should be pressed in combination. 

6. Ctrl+Shift+A means press and hold Ctrl and Shift, then press A. 

7. The Alt key is a key modifier that enables a different input. 

8. The Escape (Esc) key cancels the current operation or exits the current window. 

9. The Spacebar moves the cursor one space forward. 

10. The Tab key moves the cursor several spaces forward or to the next text box on a form. 

11. The Control (Ctrl) key is a modifier key pressed in conjunction with another key to perform a 

specific task. 

12. The Backspace key moves the cursor one space backward. 

13. The Enter key moves the cursor to the beginning of the next line. 

14. The Enter key enables the highlighted option in a dialogue box. 
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177. Win + R opens the Run dialogue box. 

178. Win + S opens the search window. 

179. Win + T cycles through apps on the taskbar (focus of taskbar). 

180. Win + F1 opens the Microsoft Windows help and support center. 

181. Win + Left Arrow snaps the File Explorer window to the left side of the screen. 

182. Win + Right Arrow snaps the File Explorer window to the right side of the screen. 

183. Win + X opens the hidden menu. 

184. Win + Tab opens the Task View. 

185. Win + Prt Sc saves a screenshot in the Pictures folder. 

186. Win + Ctrl + Left/Right Arrow switches between virtual desktop screens. 

187. Win + Ctrl + D adds a new virtual desktop. 

188. Win + +/- zooms in or out in Magnifier. 

189. Win + Esc exits Magnifier. 

190. Win + D brings the desktop to the top of other windows. 

191. Win + Shift + M undoes the actions done by minimizing all windows. 

192. Win + E opens Microsoft Explorer. 

193. Win + Tab cycles through open programs on the taskbar. 

194. Win + F displays the Windows search/find feature. 
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Practice MCQs

1. What is the primary function of a 

keyboard? 

a) Display visual output 

b) Input text and commands 

c) Process data 

d) Store files 

Answer: b) Input text and commands 

2. In the shortcut notation "Ctrl+Shift+A", 

the plus sign (+) indicates: 

a) Press keys one after the other 

b) Press keys in sequence slowly 

c) Press and hold keys in combination 

d) Press the keys only once 

Answer: c) Press and hold keys in 

combination 

3. Which key is used to cancel the current 

operation or exit a window? 

a) Tab 

b) Alt 

c) Escape (Esc) 

d) Spacebar 

Answer: c) Escape (Esc) 

4. The function of the Tab key is NOT to: 

a) Move the cursor several spaces 

forward 

b) Move to the next text box on a form 

c) Move the cursor one space forward 

d) Navigate within a table 

Answer: c) Move the cursor one space 

forward 

5. What is the role of the Ctrl key? 

a) To type uppercase letters 

b) To move the cursor backward 

c) As a modifier key pressed with 

another key for a task 

d) To open the Start menu 

Answer: c) As a modifier key pressed 

with another key for a task 

6. Pressing Shift + F10 in Windows 

performs which action? 

a) Opens the Run dialog 

b) Saves the document 

c) Simulates a right-click 

d) Refreshes the page 

Answer: c) Simulates a right-click 

7. In Microsoft Word, which shortcut 

changes text to Heading 2? 

a) Ctrl + Alt + 1 

b) Ctrl + Alt + 2 

c) Ctrl + Alt + 3 

d) Ctrl + Alt + H 

Answer: b) Ctrl + Alt + 2 
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Data Communication and Networks 

Introduction to Data Communication 

We live in an era of an electronic global village, where computers, telephones, and wireless 
devices are interconnected worldwide. Data communication is the electronic exchange of data 
between two devices via a transmission medium such as a wire cable or wireless system. It 
enables the transfer of information from one location to another, forming the backbone of 
modern connectivity, collaboration, and information sharing. 

Components of Data Communication 

A data communication system consists of five fundamental components that work together to 
enable the transfer of information. 

Message 

The message is the information or data to be communicated. It can consist of text, numbers, 
pictures, sound, video, or any combination of these. 

Sender (Transmitter/Source) 

The sender is the device that originates and sends the data message. It can be a computer, 
workstation, telephone handset, video camera, mobile phone, or radio/TV station. The 
transmitter converts the message into a signal suitable for transmission over the chosen 
medium. 

Receiver (Sink/Destination) 

The receiver is the device that accepts the transmitted message. It can be a computer, 
workstation, telephone, television, printer, or fax machine. The receiver converts the received 
signal back into a form usable by the destination. 

Transmission Medium (Channel) 

The transmission medium is the physical path or channel through which the message travels 
from the sender to the receiver. It can be a guided (wired/bounded) medium like a cable or 
an unguided (wireless/unbounded) medium like air or space. 

Protocol 

Chapter 11 
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Need for Standards 

Standards provide common guidelines for manufacturers and vendors to ensure 
interoperability between different hardware and software. They define how devices identify 
each other, format data, and manage communication. Examples include IEEE 802 series 
(Ethernet, Wi-Fi), and protocols like TCP/IP. 

The OSI (Open Systems Interconnection) Reference Model 

Developed by ISO, the OSI model is a conceptual framework that standardizes the 
functions of a telecommunication or computing system into seven distinct layers. Each layer 
serves the layer above it and is served by the layer below it. 

Layer Name Function Protocols/Devices 
PDU 

(Protocol 
Data Unit) 

7 Application 

Provides network 
services directly to 
user applications 
(email, file 
transfer). 

HTTP, FTP, 
SMTP, DNS, 
Telnet 

Data/Messag
e 

6 
Presentatio
n 

Translates, 
encrypts, and 
compresses data for 
the application 
layer. 

SSL/TLS, JPEG, 
MPEG, ASCII to 
EBCDIC 
conversion 

Data/Messag
e 

5 Session 

Establishes, 
manages, and 
terminates 
connections 
(sessions) between 
applications. 

NetBIOS, RPC, 
SIP 

Data/Messag
e 
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One Liners: Data Communication and Networks 

1. Data communication is the electronic exchange of data between two devices via a 

transmission medium. 

2. The five fundamental components of a data communication system are Message, Sender, 

Receiver, Transmission Medium, and Protocol. 

3. A message can consist of text, numbers, pictures, sound, video, or any combination thereof. 

4. The sender, or transmitter, is the device that originates and sends the data message. 

5. The transmitter converts the message into a signal suitable for transmission over the chosen 

medium. 

6. The receiver, or destination, is the device that accepts the transmitted message. 

7. The receiver converts the received signal back into a form usable by the destination. 

8. The transmission medium is the physical path through which the message travels from 

sender to receiver. 

9. A protocol is a set of rules governing data communication, representing an agreement 

between communicating devices. 

10. Protocols handle aspects like error detection, synchronization, signaling, and 

authentication. 

11. An encoder converts digital signals into a form suitable for transmission, while a decoder 

converts them back. 

12. The three key properties of an effective data communication system are Delivery, 

Accuracy, and Timeliness. 

13. Delivery ensures data reaches the correct intended destination. 

14. Accuracy requires that data received is identical to data sent, without alteration. 

15. Timeliness for real-time data means delivery as it is produced, without significant delay or 

jitter. 

16. Signals are electromagnetic or light waves representing data used to transfer information. 

17. An analog signal is a continuous electrical wave that varies smoothly over time. 

18. The key characteristics of an analog signal are Amplitude, Frequency, and Phase. 
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Practice MCQs
1. Which of the following is NOT a 

fundamental component of a data 
communication system? 
a) Message 
b) Sender 
c) Router 
d) Protocol 
Answer: c) Router 

2. In data communication, what is the 
primary function of a protocol? 
a) To amplify the signal strength 
b) To convert analog signals to digital 
c) To govern the rules and conventions 
for communication 
d) To provide the physical transmission 
path 
Answer: c) To govern the rules and 
conventions for communication 

3. The property of a communication system 
that ensures data is delivered without 
alteration is called: 
a) Delivery 
b) Timeliness 
c) Accuracy 
d) Synchronization 
Answer: c) Accuracy 

4. Which characteristic of an analog signal 
refers to the number of cycles it 
completes in one second? 
a) Amplitude 
b) Wavelength 
c) Frequency 
d) Phase 
Answer: c) Frequency 

5. Unicode was developed primarily to 
address the limitation of ASCII in: 
a) Processing speed 

b) Representing characters from diverse 
world languages 
c) Error detection capabilities 
d) Signal transmission range 
Answer: b) Representing characters 
from diverse world languages 

6. The phenomenon where a signal loses 
energy and weakens as it travels over a 
distance is known as: 
a) Distortion 
b) Noise 
c) Attenuation 
d) Crosstalk 
Answer: c) Attenuation 

7. Which guided transmission medium 
operates on the principle of total internal 
reflection? 
a) Unshielded Twisted Pair (UTP) 
b) Coaxial Cable 
c) Shielded Twisted Pair (STP) 
d) Fiber Optic Cable 
Answer: d) Fiber Optic Cable 

8. A major disadvantage of Satellite 
Microwave communication is: 
a) Inability to penetrate walls 
b) High signal propagation delay 
c) Very short range 
d) Susceptibility to electromagnetic 
interference 
Answer: b) High signal propagation 
delay 

9. In which communication mode can both 
devices send and receive data, but not at 
the same time? 
a) Simplex 
b) Full-Duplex 
c) Half-Duplex 
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Computational Thinking and Algorithms 

Introduction to Computational Thinking 

Computational Thinking (CT) is a structured, problem-solving methodology that enables 
individuals to tackle complex problems by applying techniques and processes inspired by 
computer science. It is a universal skill, not limited to programming, applicable in fields such 
as mathematics, science, engineering, business, healthcare, and everyday life tasks like planning 
a trip or organizing an event. CT involves a mental framework for logical and creative problem-
solving, using specific techniques to think clearly, logically, and systematically. 

The primary goal is to design systematic, step-by-step solutions that can be executed by a 
human, a computer, or both. It prepares individuals to deconstruct complex challenges, identify 
patterns, focus on essentials, and design effective solutions. 

Core Components (Pillars) Of Computational Thinking 

Computational thinking is built upon four fundamental, interconnected pillars. 

Decomposition 

Definition: The process of breaking a large, complex problem into smaller, more manageable 
sub-problems or tasks. 
Purpose: Makes understanding, analyzing, and solving the problem significantly easier. It 
simplifies the overall task and allows for focused work on individual parts. 
Examples: 

• Everyday: Building a birdhouse can be decomposed into: designing, gathering materials, 
cutting wood, assembling, painting, and installing. Preparing a meal involves steps like 
deciding the menu, gathering ingredients, cooking, and serving. 

• Software: Building a mobile app is decomposed into designing the user interface, coding 
features (login, navigation), and implementing data storage. 

• Robotics: Solving a maze problem for a robot can be broken down into: determining the maze 
size, defining start/end points, identifying allowed moves, and recognizing dead ends. 

Pattern Recognition 

Definition: Identifying similarities, trends, or regularities within data or across different 
problems. 

Chapter 12 
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Example: Print Multiplication Table (using WHILE loop) 

1. START 

2. Declare integer A, counter. 

3. Read A. 

4. counter = 1. 

5. WHILE counter <= 10 

1. Print A * counter. 

2. counter = counter + 1. 

6. END WHILE 

7. END 

REPRESENTING ALGORITHMS: DESIGN METHODS 

Flowcharts 

A pictorial/graphical representation of an algorithm using standardized symbols connected 
by arrows (flowlines) to show the sequence of steps. 

Common Flowchart Symbols: 

Symbol Name Description 

Oval Terminal Start or Stop point of the process. 

Parallelogram Input/Output Used for reading input or displaying output. 

Rectangle Process Represents a computation or action step. 

Diamond Decision Branches the flow based on a Yes/No 
condition. 

Arrow Flowline Shows the direction of flow between steps. 
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Practice MCQs
1. Which of the following is NOT one of the 

four core pillars of Computational 
Thinking? 
a) Decomposition 
b) Pattern Recognition 
c) Data Encryption 
d) Algorithmic Design 
Answer: c) Data Encryption 

2. In the problem-solving process, the step 
that involves breaking down the problem 
into smaller parts to identify Facts, Input, 
Output, and Process is called: 
a) Identify the Problem 
b) Define the Problem 
c) Analyze the Problem 
d) Plan the Solution 
Answer: c) Analyze the Problem 

3. The IPO Model in computational 
problem-solving stands for: 
a) Input, Program, Outcome 
b) Instruction, Process, Output 
c) Input, Process, Output 
d) Initialize, Process, Operate 
Answer: c) Input, Process, Output 

4. A problem that asks, "Is this number a 
prime?" is best categorized as a: 
a) Search Problem 
b) Counting Problem 
c) Decision Problem 
d) Optimization Problem 
Answer: c) Decision Problem 

5. If you have 5 different shirts and 4 
different pairs of pants, and you want to 
find the total number of possible outfits 
(one shirt + one pant), you must apply 
the: 
a) Addition Principle 

b) Subtraction Principle 
c) Multiplication Principle 
d) Division Principle 
Answer: c) Multiplication Principle 

6. The formula nCr = n! / (r!(n-r)!) is used 
to calculate: 
a) The number of permutations 
of *r* items from *n* 
b) The number of combinations 
of *r* items from *n* 
c) The number of ways to 
arrange *n* items in a line 
d) The sum of all possible selections 
Answer: b) The number of 
combinations of *r* items from *n* 

7. The Pigeonhole Principle guarantees that 
if you have 15 students and only 12 
lockers, then: 
a) Every locker will be used. 
b) At least one locker will be empty. 
c) At least one locker will contain more 
than one item. 
d) The number of lockers must be 
increased. 
Answer: c) At least one locker will 
contain more than one item. 

8. Which characteristic of a good algorithm 
explicitly requires that it must stop after a 
finite number of steps? 
a) Definiteness 
b) Finiteness 
c) Feasibility 
d) Generality 
Answer: b) Finiteness 

9. An algorithm that solves a problem by 
dividing it into independent sub-
problems, solving each, and combining 
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Programming Fundamentals 

The Foundations of Computing & Programming 

Introduction to Computing & Binary 

Computers are universal machines that process information. At their most fundamental level, 

they operate on two states: ON and OFF, represented by the numbers 1 and 0. This binary 

foundation underpins all digital computing. 

Information Representation: The Binary System 

Everything a computer processes—text, images, sound, and programs—is ultimately 

represented as numbers using the binary number system, which has a base of 2 and uses 

only two digits: 0 and 1. 

• Bit: The smallest unit of data, short for Binary Digit. A single bit holds a value of either 0 or 

1. 

• Byte: A group of 8 bits. It is the standard unit for measuring data size. 

• Larger Units: Data storage scales up using binary multiples (based on 1024, which is 2¹⁰): 

o 1 Kilobyte (KB) = 1024 Bytes 

o 1 Megabyte (MB) = 1024 KB 

o 1 Gigabyte (GB) = 1024 MB 

o 1 Terabyte (TB) = 1024 GB 

Chapter 13 
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Aspect Front-End (Client-Side) Back-End (Server-Side) 

Focus 
What the user sees and interacts 

with. 
The server, databases, and application 

logic. 

Goal 
Create an attractive, user-friendly 

interface. 
Ensure data is processed, stored, and 

delivered correctly. 

Languages HTML, CSS, JavaScript. 
Python, PHP, Ruby, JavaScript 

(Node.js). 

Interaction 
Sends user requests to the back-

end. 
Processes requests, interacts with 

databases, sends content back. 

Static vs. Dynamic Websites 

• Static: Content unchanged unless manually edited. Simple and fast. 

• Dynamic: Content changes based on user input or real-time data using scripting languages 

(JavaScript, PHP). More interactive and engaging. 

Responsive Web Design 

Websites that automatically adjust layout and functionality to fit different screen sizes 

(desktop, tablet, mobile) using fluid grids and flexible images. 

Core Web Technologies: HTML & CSS 

HyperText Markup Language (HTML) 

The standard language for creating and structuring webpage content using tags. 

Basic Structure: 

html 
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One Liners: Programing Fundamentals 
1. At its core, a computer processes information using two states: ON (1) and OFF (0). 
2. The binary number system has a base of 2 and uses only the digits 0 and 1. 
3. A Bit (Binary Digit) is the smallest unit of data, holding a value of either 0 or 1. 
4. A Byte is a group of 8 bits and is the standard unit for measuring data size. 
5. Data storage scales using binary multiples: 1 Kilobyte (KB) = 1024 Bytes. 
6. In a binary number, the leftmost bit is the Most Significant Bit (MSB) and the rightmost is 

the Least Significant Bit (LSB). 
7. To convert binary to decimal, use positional notation: multiply each bit by 2 raised to its 

position power and sum the results. 
8. To convert decimal to binary, use the repeated division-by-2 method and read the 

remainders from the last to the first. 
9. ASCII is an 8-bit code representing 128 characters, where 'a' = 01100001₂ (97₁₀). 
10. Unicode is an extended system capable of representing over 65,000 characters from many 

world languages. 
11. In the RGB color model, each color component (Red, Green, Blue) is represented by an 8-

bit number (0-255). 
12. White in RGB is represented as (255,255,255) or (11111111, 11111111, 11111111)₂. 
13. Sound is converted from analogue to digital using an Analogue-to-Digital Converter 

(ADC). 
14. The quality of digital sound is determined by Sample Rate (samples per second) and Bit 

Depth (bits per sample). 
15. Problem analysis involves clearly defining the problem, identifying causes, and 

brainstorming solutions. 
16. Solution planning techniques include Abstraction, Divide and Conquer, Analogy, 

Brainstorming, and Research. 
17. The best solution is evaluated based on Speed/Time Efficiency, Cost (resources, memory), 

and Complexity (number of steps). 
18. An algorithm is a well-defined, step-by-step procedure that takes input, processes it, and 

produces an output. 
19. Algorithm efficiency is measured by Time Complexity (execution speed) and Space 

Complexity (memory usage). 
20. A flowchart is a diagrammatic representation of an algorithm using standardized symbols. 
21. In a flowchart, an Oval represents the Start or End terminal. 
22. In a flowchart, a Parallelogram represents an Input or Output operation. 
23. In a flowchart, a Rectangle represents a Process or calculation step. 
24. In a flowchart, a Diamond represents a Decision point (Yes/No, True/False). 
25. Before drawing a flowchart, determine the problem's inputs, processing, decisions, and 

outputs. 
26. A Program is a set of ordered instructions telling a computer how to perform a specific 

task. 
27. The concept of a stored program in memory was pioneered by John von Neumann. 
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Practice MCQs
1. Which of the following correctly defines 

the relationship between a bit and a byte? 
a) A bit is a group of 8 bytes. 
b) A byte is a group of 8 bits. 
c) A bit represents a decimal digit, while 
a byte represents a binary digit. 
d) A byte is always 1024 bits. 
Answer: b) A byte is a group of 8 bits. 

2. In the binary number 1101, the weight of 
the digit '1' in the leftmost position 
(assuming positions start at 0 from the 
right) is: 
a) 2^0 
b) 2^1 
c) 2^2 
d) 2^3 
Answer: d) 2^3 

3. Using the repeated division-by-2 method, 
the binary representation of the decimal 
number 29 is: 
a) 11100 
b) 11101 
c) 11011 
d) 10111 
Answer: b) 11101 

4. In the RGB color model, the binary 
representation for the color Red (255, 0, 
0) would be: 
a) (11111111, 00000000, 00000000) 
b) (00000000, 11111111, 00000000) 
c) (00000000, 00000000, 11111111) 
d) (11111111, 11111111, 11111111) 
Answer: a) (11111111, 00000000, 
00000000) 

5. When planning a software solution, the 
technique of creating a simplified model 
to focus on essential details is known as: 
a) Decomposition 

b) Pattern Recognition 
c) Abstraction 
d) Algorithmic Design 
Answer: c) Abstraction 

6. The primary purpose of a flowchart's 
diamond-shaped symbol is to represent a: 
a) Start or End point 
b) Input or Output operation 
c) Calculation or Process step 
d) Decision or Conditional branch 
Answer: d) Decision or Conditional 
branch 

7. The von Neumann architecture is most 
famous for introducing the concept of: 
a) Binary number system 
b) Stored-program computers 
c) Graphical user interfaces 
d) Object-oriented programming 
Answer: b) Stored-program computers 

8. A program that translates assembly 
language mnemonics into machine code 
is called a(n): 
a) Compiler 
b) Interpreter 
c) Assembler 
d) Linker 
Answer: c) Assembler 

9. In programming, a construct that allows a 
block of code to be executed repeatedly 
as long as a condition remains true is a: 
a) Sequence 
b) Selection 
c) Loop (Repetition) 
d) Event 
Answer: c) Loop (Repetition) 

10. In Scratch, a variable declared as "for this 
sprite only" has what kind of scope? 
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Data Base and Data Management (DBMS) 
Data and Database Fundamentals 

Data, Information, and Knowledge 

Data consists of raw facts and figures, such as numbers, words, measurements, observations, 
images, or sounds (e.g., daily temperature readings, list of student names and 
marks). Information is processed, organized, or structured data presented in a meaningful 
context (e.g., a weather forecast, student percentage and grade). Information is derived from data 
and is useful for decision-making. Knowledge is the actionable insight gained from 
understanding patterns in information. Data becomes information through processing, and 
information becomes knowledge through analysis and interpretation. 

Aspect Data Information 

Nature Raw, unprocessed facts 
Processed, organized, 
meaningful data 

Role in System Input to a computer system Output of data processing 

Usefulness May not be meaningful on its own 
Useful, valuable, supports 
decisions 

Reproducibility Difficult to reproduce if lost 
Easier to reproduce (e.g., 
recalculated) 

Dependence An independent entity Depends on data 

The Need for Databases: Evolution from File Systems 

Before databases, File Management Systems (FMS) were used. Data was stored in 
independent files, each a collection of records made up of fields. This approach led to 
significant problems: 

• Data Redundancy: The same data duplicated across multiple files. 

Chapter 14 
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One Liners: Data and Data Management (DBMS)
1. Data consists of raw, unprocessed facts and figures like numbers, words, measurements, 

observations, images, or sounds. 
2. Information is processed, organized, or structured data presented in a meaningful context, 

useful for decision-making. 
3. Knowledge is the actionable insight gained from understanding patterns in information. 
4. Data becomes information through processing; information becomes knowledge through 

analysis and interpretation. 
5. In a system, data is the input, and information is the output of data processing. 
6. Data may not be meaningful on its own, whereas information is valuable and supports 

decisions. 
7. Information is easier to reproduce (e.g., recalculated) compared to raw data. 
8. Information depends on data, but data is an independent entity. 
9. Before databases, File Management Systems (FMS) stored data in independent files. 
10. Data Redundancy in FMS means the same data is duplicated across multiple files. 
11. Data Inconsistency occurs when changes in one file are not updated in others, leading to 

conflicting information. 
12. Data-Program Dependence means changes in data structure require changes to all related 

programs. 
13. Data Isolation refers to data being scattered in various formats, making retrieval difficult. 
14. Integrity Problems in FMS involve manually ensuring data accuracy (e.g., account balance 

> 0). 
15. Atomicity Problems refer to the difficulty in ensuring transactions (like funds transfer) 

complete as a whole. 
16. Poor Data Security in FMS results from no centralized security control, making files 

vulnerable. 
17. Intensive coding and difficult data access in FMS required separate programs for each task. 
18. A database is a shared, integrated, and logically related collection of data, along with its 

description (metadata). 
19. A key principle of databases is that data is independent of the application programs that use 

it. 
20. A Database Management System (DBMS) is software that enables users to create, 

maintain, manipulate, and access a database. 
21. Manipulation in a DBMS includes adding, deleting, and changing data. 
22. Popular DBMS examples include Microsoft Access, Oracle, MySQL, Microsoft SQL 

Server, and IBM DB2. 
23. A DBMS provides controlled data redundancy, meaning data is stored logically only once. 
24. Data Consistency is achieved in DBMS as minimal redundancy ensures uniform data. 
25. Data Sharing in a DBMS means a centralized resource is accessible by authorized users. 
26. Enforcement of Standards is possible in DBMS through centralized control of naming, 

format, and structure. 
27. Enhanced Security in DBMS comes from centralized permissions and access controls. 
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Practice MCQs

1. What is the primary difference 
between data and information? 
A) Data is processed; information is raw 
B) Data is meaningful on its own; 
information requires context 
C) Data is raw facts; information is 
processed data in context 
D) Data is output; information is input 
Answer: C) Data is raw facts; 
information is processed data in context 

2. Which of the following was a major 
problem with File Management Systems 
(FMS)? 
A) Program-Data Independence 
B) Controlled Data Redundancy 
C) Data Inconsistency 
D) Enhanced Security 
Answer: C) Data Inconsistency 

3. What is the key principle that data in 
a database is independent of the 
application programs called? 
A) Data Redundancy 
B) Program-Data Dependence 
C) Data Isolation 
D) Program-Data Independence 
Answer: D) Program-Data 
Independence 

4. Which database model allows a child 
record to have more than one parent? 
A) Hierarchical Model 
B) Network Model 
C) Relational Model 
D) Object-Oriented Model 
Answer: B) Network Model 

5. In the relational model, what is a two-
dimensional structure of rows and 
columns called? 

A) Attribute 
B) Tuple 
C) Relation/Table 
D) Key 
Answer: C) Relation/Table 

6. Which property of a relation states 
that each row must be unique? 
A) Column Atomicity 
B) Order Insignificance 
C) No Duplicate Rows 
D) NULL Allowed 
Answer: C) No Duplicate Rows 

7. What is a set of one or more 
attributes that can uniquely identify all 
other attributes in a relation called? 
A) Candidate Key 
B) Super Key 
C) Primary Key 
D) Foreign Key 
Answer: B) Super Key 

8. Which key must be unique and 
cannot contain NULL values? 
A) Foreign Key 
B) Alternate Key 
C) Secondary Key 
D) Primary Key 
Answer: D) Primary Key 

9. What does a Foreign Key (FK) 
enforce between tables? 
A) Entity Integrity 
B) Referential Integrity 
C) Column Atomicity 
D) Data Redundancy 
Answer: B) Referential Integrity 

10. In an ER diagram, what does a 
diamond represent? 
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System Development, Troubleshooting and 
Maintenance 

Introduction 

Systems are created to solve problems. Modern systems are often large and complex, requiring 

collaboration between teams of architects, analysts, programmers, testers, and users to produce 

the software that drives organizations. To manage this complexity and ensure structured, high-

quality outcomes, a systematic process is essential. This process is known as the System 

Development Life Cycle (SDLC). This unit focuses on the SDLC, explaining its importance, 

objectives, key participants (stakeholders), and the logical phases followed to develop a 

software product from conception to maintenance. 

What is a System? 

The term "system" originates from the Greek word "systema," meaning to "place together." A 

system can be defined as a set of interrelated components with a clearly defined boundary that 

work together to achieve a common set of objectives. When these components are methods, 

procedures, and routines applied in a proper sequence to build software, it is called a software 

system. 

System Development Life Cycle (SDLC) and Its Importance 

The System Development Life Cycle (SDLC) is a conceptual model and a structured, 

stepwise process used in project management to guide the development of an information 

system. It encompasses all stages from an initial feasibility study through to the maintenance 

of the completed application. It is also known as information system development or 

application development. 

 

 

Chapter 15 
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One Liners: System Development Troubleshooting and 
Maintenance 

1. System troubleshooting is a systematic process to identify problems and find quick 
solutions to prevent costly downtime and system damage. 

2. The primary goal of troubleshooting is to maintain system reliability, security, and 
efficiency without always relying on professional help. 

3. The first step in the systematic troubleshooting process is to identify and clearly define 
what is not working as expected. 

4. After identifying the problem, the troubleshooter must establish a theory of probable cause 
based on the observed symptoms. 

5. Testing the theory to determine the cause involves performing specific checks to confirm 
or rule out the suspected issue. 

6. Once the cause is confirmed, the next step is to establish a detailed plan of action to 
resolve the problem. 

7. The implementation phase involves carrying out the planned actions to fix the identified 
issue. 

8. After implementing the solution, it is critical to verify full system functionality to ensure 
the problem is resolved. 

9. Documenting findings, actions, and outcomes creates a valuable knowledge base for 
future reference. 

10. Troubleshooting is crucial for preventing downtime, which can lead to lost productivity 
and revenue for businesses. 

11. Ensuring data integrity is a key reason for troubleshooting, as it helps identify and fix 
problems that could corrupt information. 

12. Effective troubleshooting can reveal security vulnerabilities and breaches, allowing for 
swift protective action. 

13. Troubleshooting enhances system performance by identifying causes of slowdowns, such 
as insufficient RAM or software conflicts. 

14. Regular troubleshooting and fixing small issues early can extend equipment life by 
preventing major failures. 

15. Mastering troubleshooting saves costs by reducing the need for expensive emergency 
repairs and prolonged downtime. 

16. A reliable, well-performing system resulting from good troubleshooting enhances the 
overall user experience. 

17. For an application freezing, a common solution is to use Task Manager (Ctrl+Alt+Delete) 
to end the unresponsive task. 

18. If an application freezing persists, reinstalling the application or checking for updates is 
recommended. 

19. For unresponsive peripherals, the first steps are to check physical connections and 
unplug/replug the device. 
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Practice MCQs

1. What is the primary goal of system 
troubleshooting? 
a) To increase software licensing costs 
b) To maintain system reliability, 
security, and efficiency 
c) To replace all hardware components 
periodically 
d) To reduce the need for user training 
Answer: b) To maintain system 
reliability, security, and efficiency 

2. Which of the following is the FIRST 
step in the systematic troubleshooting 
process? 
a) Test the theory 
b) Establish a plan of action 
c) Identify the problem 
d) Document findings 
Answer: c) Identify the problem 

3. A laptop does not turn on. According 
to troubleshooting steps, what should 
you do immediately after identifying 
this problem? 
a) Replace the motherboard 
b) Establish a theory of probable cause 
(e.g., dead battery) 
c) Immediately document the failure 
d) Reinstall the operating system 
Answer: b) Establish a theory of 
probable cause (e.g., dead battery) 

4. Why is documenting the 
troubleshooting process considered 
important? 
a) It increases the complexity of the 
solution 
b) It creates a bill for the client 
c) It creates a valuable knowledge base 
for future reference 
d) It is only required for auditing 

purposes 
Answer: c) It creates a valuable 
knowledge base for future reference 

5. Which troubleshooting benefit directly 
relates to minimizing financial loss for 
a business? 
a) Extending equipment life 
b) Preventing downtime 
c) Enhancing user experience 
d) Improving security 
Answer: b) Preventing downtime 

6. An application becomes unresponsive. 
What is the most common immediate 
software-based solution? 
a) Reformat the hard drive 
b) Use Task Manager to end the task 
c) Restart the web server 
d) Update the BIOS 
Answer: b) Use Task Manager to end 
the task 

7. For an unresponsive external mouse, 
which sequence of actions is most 
appropriate initially? 
a) Update the OS, then replace the mouse 
b) Check physical connections, then 
unplug and replug 
c) Reinstall all device drivers, then restart 
d) Scan for viruses, then check the power 
supply 
Answer: b) Check physical 
connections, then unplug and replug 

8. What is the primary technical reason 
restarting a computer often resolves 
software issues? 
a) It upgrades the hardware firmware 
b) It clears memory and stops conflicting 
processes 
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Emerging and Contemporary Technologies 
Introduction to Emerging Technologies 

Definition and Characteristics 

An Emerging Technology is a new technology or a significant advancement in an existing one, 
capable of bringing about profound technical, institutional, and social changes. These 
technologies are poised to replace current systems in the near future and will be integrated into 
every field, from education and IT to medicine, transportation, and communication. They are 
distinguished by key characteristics: 

• Innovation: Introduces novel ideas and methods. 

• Fast Growth: Develops and scales rapidly. 

• Consistency: Provides reliable and repeatable performance. 

• Prominent Impact: Creates significant changes in how tasks are performed and problems are 
solved. 

• Interdisciplinary Nature: Combines knowledge and methods from multiple fields like 
computer science, engineering, and biology. 

• Convergence: Merges different technologies to create new, synergistic capabilities. 

Detailed Exploration of Emerging Technologies 

Artificial Intelligence (AI) and Machine Learning (ML) 

Artificial Intelligence (AI) is a broad field of computer science focused on building intelligent 
machines and software capable of performing tasks that typically require human-like 
intelligence, such as reasoning, learning, problem-solving, and decision-making. The term was 
coined by John McCarthy in 1956. Key subfields include: 

• Machine Learning (ML): A subset of AI that gives computers the ability to learn from data and 
experience without being explicitly programmed. ML algorithms build models by identifying 
patterns in large datasets. 

o Supervised Learning: The algorithm learns from a labeled dataset where the correct output is 
known, used for making predictions on new data (e.g., predicting prices). 

o Unsupervised Learning: The algorithm finds hidden patterns or intrinsic structures in 
unlabeled data, often through clustering (e.g., grouping customers). 

Chapter 16 
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One Liners: Emerging and Contemporary Technologies 
1. An Emerging Technology is a new technology or a significant advancement in an existing 

one, capable of bringing profound technical, institutional, and social changes. 
2. Emerging technologies are poised to replace current systems in the near future and will be 

integrated into every field. 
3. Key characteristics of emerging technologies include Innovation, Fast Growth, Consistency, 

Prominent Impact, Interdisciplinary Nature, and Convergence. 
4. The Interdisciplinary Nature of emerging technologies combines knowledge from fields like 

computer science, engineering, and biology. 
5. Convergence refers to the merging of different technologies to create new, synergistic 

capabilities. 
6. Artificial Intelligence (AI) is a broad field of computer science focused on building 

intelligent machines capable of human-like tasks such as reasoning, learning, and decision-
making. 

7. The term "Artificial Intelligence" was coined by John McCarthy in 1956. 
8. Machine Learning (ML) is a subset of AI that gives computers the ability to learn from data 

and experience without being explicitly programmed. 
9. Supervised Learning involves algorithms learning from labeled datasets where the correct 

output is known, used for making predictions. 
10. Unsupervised Learning involves algorithms finding hidden patterns in unlabeled data, often 

through clustering. 
11. Deep Learning (DL) is a specialized subset of ML that uses Neural Networks with many 

hidden layers. 
12. A Neural Network is inspired by the human brain and consists of interconnected nodes 

(neurons). 
13. The layers of a Neural Network are Input Layer, Hidden Layers, and Output Layer. 
14. Weights in a neural network represent the importance of connections between neurons. 
15. Biases are threshold adjusters in neural networks that help the model fit the data better. 
16. Activation Functions in neural networks determine whether a neuron should be activated. 
17. Loss Functions measure the difference between the predicted output and the actual target. 
18. Training a neural network involves Feedforward Propagation and Backpropagation to 

minimize error. 
19. Deep Learning excels at autonomously extracting complex patterns from vast amounts of 

unstructured data like images and text. 
20. The hierarchical relationship is: AI ⊃ ML ⊃ Neural Networks ⊃ Deep Learning. 
21. Natural Language Processing (NLP) enables computers to understand, interpret, and generate 

human language. 
22. NLP applications include language translation, spam filtering, sentiment analysis, chatbots, 

and voice assistants. 
23. Speech Recognition converts spoken words into text or commands (e.g., dictation software, 

Siri). 
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Practice MCQs

1. Which of the following is NOT a 
characteristic of an emerging 
technology? 
A) Innovation 
B) Slow and steady growth 
C) Interdisciplinary nature 
D) Prominent impact 
Answer: B) Slow and steady growth 

2. Who coined the term "Artificial 
Intelligence"? 
A) Alan Turing 
B) John McCarthy 
C) Marvin Minsky 
D) Claude Shannon 
Answer: B) John McCarthy 

3. Which subset of AI gives computers 
the ability to learn from data without 
explicit programming? 
A) Natural Language Processing 
B) Machine Learning 
C) Computer Vision 
D) Expert Systems 
Answer: B) Machine Learning 

4. In machine learning, which type 
involves algorithms learning from 
labeled datasets? 
A) Unsupervised Learning 
B) Reinforcement Learning 
C) Supervised Learning 
D) Deep Learning 
Answer: C) Supervised Learning 

5. What is the hierarchical relationship 
between AI, ML, Neural Networks, and 
Deep Learning? 
A) AI ⊃ Neural Networks ⊃ ML ⊃ Deep 
Learning 
B) AI ⊃ ML ⊃ Neural Networks ⊃ Deep 

Learning 
C) ML ⊃ AI ⊃ Deep Learning ⊃ Neural 
Networks 
D) Deep Learning ⊃ Neural Networks ⊃ 
ML ⊃ AI 
Answer: B) AI ⊃ ML ⊃ Neural 
Networks ⊃ Deep Learning 

6. Which AI subfield enables computers 
to understand, interpret, and generate 
human language? 
A) Computer Vision 
B) Robotics 
C) Natural Language Processing 
D) Speech Recognition 
Answer: C) Natural Language 
Processing 

7. What is the key difference between 
speech recognition and voice 
recognition? 
A) Speech recognition identifies a person; 
voice recognition converts speech to text. 
B) Speech recognition converts speech to 
text; voice recognition identifies a person. 
C) Both are the same. 
D) Speech recognition is for commands; 
voice recognition is for transcription. 
Answer: B) Speech recognition converts 
speech to text; voice recognition 
identifies a person. 

8. Which technology creates a fully 
immersive, artificial three-dimensional 
environment? 
A) Augmented Reality 
B) Virtual Reality 
C) Holographic Imaging 
D) 3D Printing 
Answer: B) Virtual Reality 
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Digital Citizenship, Literacy and Ethics 

Introduction: Navigating the Modern Digital World 

The digital landscape is the cornerstone of modern society, transforming how we 
communicate, learn, work, and access entertainment. This evolution from traditional methods 
to a connected, technology-driven world brings immense power and convenience, but also 
introduces significant responsibilities, risks, and ethical dilemmas. This Master Chapter 
provides a complete, unified, and self-contained guide to becoming a competent, safe, 
responsible, and ethical participant in the digital world. It integrates foundational skills, 
security practices, ethical frameworks, societal impacts, and entrepreneurial thinking into a 
seamless professional textbook. 

The Digital Foundation – Hardware, Software, and Systems 

Understanding Software 

A computer consists of hardware—the physical components—and software, the set of 
instructions, data, and programs that operate the computer to perform specific tasks. 

Types of Software 

1. System Software: The essential set of programs that acts as the primary interface between 
hardware and the user. Its purpose is to simplify hardware use, control operations, and 
optimize performance. 

o Examples: Operating Systems (OS), Device Drivers, Utility Programs, Language 
Translators. 

2. Application Software: Programs written to carry out specific tasks for the user. 

o Examples: Word Processors (Microsoft Word), Spreadsheets (Excel), Presentation Software 
(PowerPoint), Web Browsers (Chrome), Email Clients (Gmail), Image Editors (Paint). 

System Software Deep Dive 

The Operating System (OS) 

The OS is the most critical system software that controls and manages all computer 
operations. A computer cannot function without it. 

Chapter 17 
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• Cyberterrorism, Cyberstalking, Phishing, Spoofing. 

Malicious Software (Malware) 

Software designed to harm, disrupt, or gain unauthorized access. 

Type Description Key Characteristics 

Virus 
Attaches to a legitimate 
file/program and replicates 
when executed. 

Requires user action, spreads via 
files, corrupts/deletes data. 

Worm 
A standalone program that self-
replicates across networks. 

Does not need a host file, consumes 
bandwidth/space. 

Trojan 
Horse 

Disguises as legitimate software 
but performs malicious actions. 

Does not self-replicate; creates 
backdoors, steals data. 

Spyware 
Secretly collects user 
information (habits, passwords). 

Tracks activity, changes settings, 
leads to identity theft. 

Adware 
Displays unwanted ads, often 
bundled with free software. 

Slows system, tracks browsing for 
targeted ads. 

Ransomware 
Encrypts victim's files, 
demanding payment for 
decryption. 

Makes data inaccessible, extorts 
money. 

Keylogger 
Records keystrokes to capture 
sensitive data like passwords. 

A type of spyware focused on 
logging input. 

How Malware Spreads: Infected removable media, pirated software, network/internet 
downloads, email attachments (most common). 

Symptoms of Infection: Slow performance, frequent crashes/freezes, unwanted pop-
ups/toolbars, programs opening/closing automatically, inaccessible files, unusual error 
messages, emails sent from your account without knowledge. 
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One Liners: Digital Citizenship, Ethics and Literacy 
1. The digital landscape is the cornerstone of modern society, transforming communication, 

learning, work, and entertainment. 
2. A computer consists of hardware (physical components) and software (instructions, data, 

and programs). 
3. System software acts as the primary interface between hardware and the user, simplifying 

hardware use, controlling operations, and optimizing performance. 
4. Application software carries out specific tasks for the user (e.g., word processors, 

spreadsheets). 
5. The Operating System (OS) is the most critical system software that controls and manages 

all computer operations; a computer cannot function without it. 
6. OS functions include Booting, Security Management, Application Management, Memory 

Management, File Management, Device Management, and providing a User Interface. 
7. Common OS examples are Microsoft Windows, macOS, Linux, Android, and iOS. 
8. Device Drivers are specialized programs enabling hardware components to communicate 

with the OS. 
9. Utility Programs perform management and maintenance tasks (e.g., antivirus, disk 

cleanup). 
10. Language Translators convert human-readable programming code into machine-

understandable code (Assemblers, Compilers, Interpreters). 
11. The desktop is the main screen after startup, containing icons, taskbar, Start button/menu, 

notification area, and background/wallpaper. 
12. A File is a common storage unit holding information; a Folder is a virtual container used 

to organize files. 
13. A Shortcut is a link providing quick access to a file, folder, or program without moving 

the original item. 
14. Essential file operations include Create, Rename, Cut/Copy/Paste, Delete & Restore, and 

Drag and Drop. 
15. Deleted files are sent to the Recycle Bin, from which they can be restored. 
16. A word processor is an application used to create, edit, format, save, and print text-based 

documents. 
17. Key word processor interface elements include the Quick Access Toolbar, Title Bar, 

Ribbon, and Document Workspace. 
18. Character formatting in a word processor includes changing Font Style, Size, Color, and 

applying Bold, Italic, Underline, and Text Alignment. 
19. Page Layout adjustments involve margins, orientation (Portrait/Landscape), and size. 
20. Lists can be bulleted (unordered) or numbered (sequential). 
21. Headers and Footers are areas at the top and bottom of every page for titles, page 

numbers, and dates. 
22. Spell & Grammar Check (F7) and Thesaurus are tools for error checking and finding 

synonyms. 
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Practice MCQs

1. What are the two main components 
of a computer system? 
A) CPU and RAM 
B) Hardware and Software 
C) Input and Output 
D) Operating System and Applications 
Answer: B) Hardware and Software 

2. Which type of software acts as the 
primary interface between hardware 
and the user? 
A) Application Software 
B) System Software 
C) Utility Software 
D) Programming Software 
Answer: B) System Software 

3. Which of the following is NOT a 
function of an Operating System? 
A) Booting 
B) Memory Management 
C) Word Processing 
D) File Management 
Answer: C) Word Processing 

4. What is the purpose of a Device 
Driver? 
A) To perform disk cleanup 
B) To enable hardware components to 
communicate with the OS 
C) To compile programming code 
D) To create documents 
Answer: B) To enable hardware 
components to communicate with the 
OS 

5. Where are deleted files typically 
stored before permanent deletion? 
A) Downloads folder 
B) Recycle Bin 
C) Temp folder 

D) Desktop 
Answer: B) Recycle Bin 

6. Which keyboard shortcut is used to 
copy selected text or files? 
A) Ctrl+X 
B) Ctrl+C 
C) Ctrl+V 
D) Ctrl+A 
Answer: B) Ctrl+C 

7. In a word processor, which tab is 
used to adjust page margins and 
orientation? 
A) Home 
B) Insert 
C) Layout 
D) Review 
Answer: C) Layout 

8. What does Bcc stand for in an 
email? 
A) Basic Carbon Copy 
B) Blind Carbon Copy 
C) Broad Copy Control 
D) Binary Copy Code 
Answer: B) Blind Carbon Copy 

9. Which email protocol downloads 
emails from the server to a single 
device and typically removes them 
from the server? 
A) SMTP 
B) IMAP 
C) POP 
D) HTTP 
Answer: C) POP 

10. What is the ability to effectively 
find, create, evaluate, communicate, 
and share content in a digital 
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Entrepreneurship in the Digital Age 

Introduction 

Entrepreneurship is the dynamic process of identifying a market opportunity, conceptualizing a 
solution, and undertaking the risk of launching and managing a new business venture to bring 
new products, services, or processes to life. It is the engine of innovation, job creation, and 
economic growth. In the contemporary world, this traditional process has been fundamentally 
transformed by digital technologies. The fusion of classic business acumen with tools like the 
internet, social media, cloud computing, and data analytics has created unprecedented 
opportunities while reshaping the entrepreneurial landscape. This Master Chapter provides a 
comprehensive, unified guide to understanding the complete journey of entrepreneurship—
from its core principles and initial idea validation to building, launching, and scaling a venture 
in the digital era. It is designed to be a self-contained, professional resource for students and 
aspiring entrepreneurs. 

The Foundation of Entrepreneurship 

Definition and Core Concepts 

• Entrepreneur: An individual who organizes, manages, and assumes the financial risks of a 
new business venture. An entrepreneur is commonly seen as an innovator, a source of new 
ideas, goods, services, and business procedures. The term originates from the French word 
meaning "to undertake." 

• Entrepreneurship: The process of designing, launching, and running this new business 
venture. It involves identifying a market need, taking calculated risks under conditions of 
uncertainty, and making strategic decisions to achieve business objectives and create value. 

Significance and Impact 

Entrepreneurship is a vital catalyst for any economy due to its multi-faceted role: 

• Economic Growth: Creates new jobs and introduces new products and services, stimulating 
economic activity. 

• Innovation and Progress: Drives groundbreaking ideas that transform lifestyles and 
industries (e.g., smartphones, digital platforms). 

• Job Creation: Generates employment opportunities directly and indirectly. 

Chapter 18 
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One Liners: Entrepreneurship in Digital Age 

1. Entrepreneurship is the dynamic process of identifying a market opportunity and 

undertaking the risk of launching a new business venture. 

2. An entrepreneur is an individual who organizes, manages, and assumes the financial risks of 

a new business venture. 

3. The term "entrepreneur" originates from the French word meaning "to undertake." 

4. Entrepreneurship is commonly seen as a source of innovation, introducing new ideas, goods, 

services, and business procedures. 

5. The process of entrepreneurship involves identifying a market need, taking calculated risks, 

and making strategic decisions to create value. 

6. Entrepreneurship acts as a vital catalyst for economic growth by creating new jobs. 

7. It drives economic growth by introducing new products and services that stimulate 

economic activity. 

8. Entrepreneurship is a primary driver of groundbreaking innovation that transforms lifestyles 

and industries. 

9. A major impact of entrepreneurship is job creation, generating employment opportunities 

both directly and indirectly. 

10. By introducing fresh ideas and competition, entrepreneurship leads to better products, 

services, and prices for consumers. 

11. Social entrepreneurship specifically addresses pressing societal and environmental 

challenges. 

12. A key characteristic of successful entrepreneurs is innovation and creativity. 

13. Entrepreneurs exhibit calculated risk-taking, understanding that failure is possible but great 

rewards can follow. 

14. Successful entrepreneurs are moderate risk-takers, not gamblers. 

15. Persistence and resilience are essential attributes for overcoming inevitable challenges and 

setbacks. 
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Practice MCQs

1. What is the core definition of an 
entrepreneur? 
a) An employee who follows company 
procedures 
b) An individual who organizes, 
manages, and assumes the financial risks 
of a new business venture 
c) A government official who regulates 
markets 
d) A consumer who buys innovative 
products 
Answer: b) An individual who 
organizes, manages, and assumes the 
financial risks of a new business 
venture 

2. The term "entrepreneur" originates 
from which language? 
a) Latin 
b) Greek 
c) French 
d) German 
Answer: c) French 

3. Which of the following is NOT a 
primary impact of entrepreneurship on 
an economy? 
a) Job Creation 
b) Economic Stagnation 
c) Innovation and Progress 
d) Increased Competition 
Answer: b) Economic Stagnation 

4. A successful entrepreneur who takes 
financial risks with an understanding 
of potential failure, but not recklessly, 
is best described as a: 
a) Gambler 
b) Calculated risk-taker 
c) Avoider of all risk 

d) Follower of trends 
Answer: b) Calculated risk-taker 

5. Which characteristic involves the 
ability to pivot strategies based on 
market feedback? 
a) Persistence 
b) Confidence 
c) Flexibility and Adaptability 
d) Future Orientation 
Answer: c) Flexibility and Adaptability 

6. What is a significant drawback of 
entrepreneurship? 
a) Unlimited profit potential 
b) Gaining control over one's career 
c) Uncertainty and variability of income 
d) Doing personally enjoyable work 
Answer: c) Uncertainty and variability 
of income 

7. A local grocery store that supports a 
family lifestyle without seeking venture 
capital is an example of: 
a) Scalable Startup 
b) Social Entrepreneurship 
c) Small Business Entrepreneurship 
d) Buyer Entrepreneurship 
Answer: c) Small Business 
Entrepreneurship 

8. Which type of entrepreneurship aims 
primarily for social good rather than 
profit maximization? 
a) Innovative Entrepreneurship 
b) Social Entrepreneurship 
c) Hustler Entrepreneurship 
d) Imitator Entrepreneurship 
Answer: b) Social Entrepreneurship 
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Miscellaneous Information: Quick Revision Notes 

1. Most Common Keyboard Shortcuts 

Windows 

• Ctrl + C → Copy selected item → Used to copy text/files. 

• Ctrl + X → Cut selected item → Removes and copies text/files. 

• Ctrl + V → Paste copied/cut item → Inserts clipboard content. 

• Ctrl + Z → Undo last action → Reverses previous operation. 

• Ctrl + Y / Ctrl + Shift + Z → Redo action → Reapplies undone action. 

• Ctrl + A → Select all items → Highlights all content in a window. 

• Ctrl + S → Save current document → Saves file in active application. 

• Ctrl + F → Open find/search box → Searches for text on a page. 

• Ctrl + P → Print current page/document → Opens print dialog. 

• Ctrl + N → Open new window/document → Creates new instance. 

• Ctrl + W → Close current window/tab → Shuts active tab/window. 

• Ctrl + T → Open new browser tab → Creates tab in browsers. 

• Ctrl + Shift + T → Reopen closed tab → Restores recently closed tab. 

• Alt + Tab → Switch between open apps → Toggles running applications. 

• Alt + F4 → Close active application → Quits current program. 

• Windows Key + D → Show/hide desktop → Minimizes all windows. 

• Windows Key + E → Open File Explorer → Launches file manager. 

• Windows Key + L → Lock computer → Locks screen quickly. 

• Windows Key + R → Open Run dialog → Executes commands. 

Chapter 19 



 

  MK PREPARATIONS  

 

P a g e  7 | 34 

 

  

1
9

. M
isce

lla
n

e
o

u
s In

fo
rm

a
tio

n
: Q

u
ick

 R
e

v
isio

n
 N

o
te

s 
  

M 
K 
 

P 
R 
E 
P 
A 
R 
A 
T 
I 
O 
N 
S 

MK PREPARATIONS: Let’s Make It Happen 
+92 333 2605045, +92 342 4470091 
 

o Founder: Marcos Galperin 

o Country of Origin: Argentina 

o Headquarters: Buenos Aires, Argentina 

o Current CEO: Marcos Galperin 

o Major Services: Online marketplace, payments (Mercado Pago), shipping, advertising. 

o Launch Year: 1999 

o Key Fact: Dominant e-commerce and fintech platform in Latin America. 

• JD.com (Jingdong) 

o Founder: Liu Qiangdong (Richard Liu) 

o Country of Origin: China 

o Headquarters: Beijing, China 

o Current CEO: Xu Ran 

o Major Services: Online direct sales marketplace, logistics, technology services. 

o Launch Year: 1998 

o Key Fact: China's largest retailer by revenue, known for its in-house logistics network. 

• Etsy 

o Founder: Rob Kalin, Chris Maguire, Haim Schoppik 

o Country of Origin: USA 

o Headquarters: Brooklyn, New York, USA 

o Current CEO: Josh Silverman 

o Major Services: Marketplace for handmade goods, vintage items, and craft supplies. 

o Launch Year: 2005 

o Key Fact: Leading global marketplace for unique and creative goods. 

• Zalando 

https://jd.com/
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• Networking: Practice of connecting computers to share resources and information. 

• IP Address: Numerical label assigned to each device on a network using IP. 

• MAC Address: Unique hardware identifier assigned to a network interface controller. 

• Protocol: Set of rules governing data communication between devices. 

• Router: Networking device that forwards data packets between computer networks. 

• Switch: Device that connects devices on a LAN and uses MAC addresses to forward data. 

• Firewall: Security system that monitors and controls network traffic based on rules. 

• Cloud Computing: Delivery of computing services over the internet ("the cloud"). 

• IaaS: Infrastructure as a Service – provides virtualized computing resources. 

• PaaS: Platform as a Service – provides platform for developing and deploying apps. 

• SaaS: Software as a Service – delivers software applications over the internet. 

• Virtualization: Creating a virtual version of something (server, OS, storage, network). 

• Hypervisor: Software that creates and runs virtual machines. 

• Artificial Intelligence (AI): Simulation of human intelligence in machines. 

• Machine Learning (ML): Subset of AI where machines learn from data without explicit 
programming. 

• Deep Learning (DL): Subset of ML using neural networks with many layers. 

• Neural Network: Computing system inspired by biological neural networks. 

• Supervised Learning: ML training using labeled data. 

• Unsupervised Learning: ML training using unlabeled data to find patterns. 

• Reinforcement Learning: ML where an agent learns by receiving rewards/punishments. 

• Algorithm: Step-by-step procedure for solving a problem or performing a computation. 

• Data Structure: Particular way of organizing data for efficient access and modification. 

• Array: Collection of items stored at contiguous memory locations. 
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• PHP was created by Rasmus Lerdorf in 1994. 

• SQL was initially developed by IBM researchers Donald Chamberlin and Raymond Boyce. 

• Swift programming language was created by Apple for iOS development (2014). 

• Kotlin is a statically typed language for modern multi-platform apps, developed by 
JetBrains. 

• WhatsApp was founded by Jan Koum and Brian Acton, acquired by Facebook in 2014. 

• Instagram was founded by Kevin Systrom and Mike Krieger, acquired by Facebook in 
2012. 

• TikTok is owned by ByteDance, a Chinese company founded by Zhang Yiming. 

• Zoom was founded by Eric Yuan, launched in 2013. 

• AWS (Amazon Web Services) is the leading cloud service provider by market share. 

• Microsoft Azure is Microsoft's cloud computing platform. 

• Google Cloud Platform (GCP) is Google's suite of cloud computing services. 

• IBM Cloud is IBM's cloud computing platform. 

• Oracle Cloud is Oracle's cloud service offering. 

• Router directs data packets between different networks (Internet to home network). 

• Switch connects devices within a single network, using MAC addresses. 

• Modem modulates and demodulates signals for transmission over telephone/cable lines. 

• Ethernet is a family of wired networking technologies for LANs, standardized as IEEE 
802.3. 

• Wi-Fi is a family of wireless networking protocols based on IEEE 802.11 standards. 

• Bluetooth is a short-range wireless technology standard (IEEE 802.15.1). 

• Firewall monitors and filters incoming/outgoing network traffic based on security rules. 

• Antivirus software is designed to detect, prevent, and remove malware. 

• VPN creates a secure, encrypted connection over a less secure network (like the internet). 
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• Launch Year of iPhone: 2007. 

• Launch Year of Android OS: 2008 (commercial release). 

• Launch Year of Facebook: 2004. 

• Launch Year of YouTube: 2005. 

• Launch Year of Bitcoin: 2009. 

• Key Product of Adobe: Photoshop, Creative Cloud. 

• Key Product of Salesforce: CRM software. 

• Key Product of Oracle: Oracle Database. 

• Key Product of SAP: ERP software. 

• Key Product of Cisco: Networking hardware. 

• Country of Origin for Nokia: Finland. 

• Country of Origin for Sony: Japan. 

• Country of Origin for Huawei: China. 

• Country of Origin for Ericsson: Sweden. 

• Country of Origin for Infosys: India. 

• First Computer Virus: The Creeper virus (1971). 

• First Graphical Web Browser: Mosaic (1993). 

• First Search Engine: Archie (1990). 

• First Social Media Site: Six Degrees (1997). 

• First Programmer: Ada Lovelace (wrote algorithm for Babbage's Analytical Engine). 

• Father of Computer Science: Alan Turing. 

• Father of the Internet: Vint Cerf and Bob Kahn (TCP/IP protocol). 

• Number of Bits in a Byte: 8 bits. 

• Port Number for HTTP: 80. 
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• CMS: Content Management System - Software application for creating and managing 
digital content. 

• ERP: Enterprise Resource Planning - Integrated management of main business processes. 

• CRM: Customer Relationship Management - System for managing company interactions 
with customers. 

• SCM: Supply Chain Management - Management of flow of goods and services. 

• BI: Business Intelligence - Technologies/applications for analyzing business information. 

• ETL: Extract, Transform, Load - Process in data warehousing for preparing data for 
analysis. 

• OLAP: Online Analytical Processing - Approach to answer multi-dimensional analytical 
queries. 

• OLTP: Online Transaction Processing - Class of systems facilitating transaction-oriented 
applications. 

• NoSQL: Not only SQL - Broad class of database management systems differing from 
relational databases. 

• MongoDB: A popular document-oriented NoSQL database. 

• Hadoop: Open-source framework for distributed storage/processing of big data. 

• Spark: Apache Spark - Unified analytics engine for large-scale data processing. 

• Kafka: Apache Kafka - Distributed event streaming platform. 

• DevOps: Development and Operations - Culture/practice combining software development 
and IT operations. 

• CI/CD: Continuous Integration/Continuous Deployment - Automating software delivery 
pipeline. 

• Agile: Iterative approach to project management and software development. 

• Scrum: Framework within which people can address complex adaptive problems in Agile. 

• Kanban: Visual system for managing work as it moves through a process in Agile. 

• JVM: Java Virtual Machine - Virtual machine enabling computer to run Java programs. 
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Past Papers Questions

1. How many rows in MS Excel Sheet? 
A) 86340 
B) 1048576 
C) 86400 
D) None of these 
Answer: B) 1048576 

2. Which Pane is not available in 
PowerPoint? 
A) WordArt 
B) Insert 
C) Animation 
D) None of these 
Answer: A) WordArt 

3. Deleted Items in file directly go to the: 
A) Recycle Bin 
B) Desktop 
C) Windows Folder 
D) None of these 
Answer: A) Recycle Bin 

4. Crop function is used to crop: 
A) Videos 
B) Images 
C) Files 
D) None of these 
Answer: B) Images 

5. Which key is used to move the cursor to 
end of the line? 
A) End 
B) Home 
C) Shift+ tab 
D) None of these 
Answer: A) End 

6. In MS-DOS, DOS stands for: 
A) Disk Operating System 
B) Device Operating System 
C) Driver Operating System 

D) None of these 
Answer: A) Disk Operating System 

7. HTML stands for hypertext markup 
language is used for creating: 
A) Web pages 
B) Web server 
C) Client server 
D) None of these 
Answer: A) Web pages 

8. Gmail, Hotmail and Yahoo are: 
A) Email Server 
B) Client Server 
C) Email Programmer 
D) None of these 
Answer: D) None of these 

9. Windows 9 and Windows 10 are known 
as: 
A) Operating system 
B) System software 
C) Application software 
D) None of these 
Answer: A) Operating system 

10. In PowerPoint the header and footer 
button can be found on the: 
A) Home tab 
B) Insert tab 
C) Draw tab 
D) None of these 
Answer: B) Insert tab 

11. Which of the following are word 
processing software? 
A) Browser 
B) PowerPoint 
C) MS Word 
D) None of these 
Answer: C) MS Word 
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126. Bar code reader is an __________ 
device. 
A) Input 
B) Output 
C) Display 
D) None of these 
Answer: A) Input 

127. Which is used in security system and 
criminal investigation? 
A) Computer 
B) Processor 
C) Fingerprint reader 
D) None of these 
Answer: C) Fingerprint reader 

128. Which is also known as mechanical 
agent? 
A) Computer 
B) Robots 
C) Processor 
D) None of these 
Answer: B) Robots 

129. __________ is the set of instructions 
given to the computer to perform a 
specific task. 
A) Monitor 
B) Software 
C) Hardware 
D) None of these 
Answer: B) Software 

130. Flat panels are usually used in: 
A) Supercomputer 
B) Personal computer 
C) Laptops 
D) None of these 
Answer: C) Laptops 

131. Cray T90 is an example of: 
A) IBM 
B) Hybrid computer 
C) Super computer 

D) None of these 
Answer: C) Super computer 

132. Which one is application software? 
A) Windows 
B) Linux 
C) MS Excel 
D) None of these 
Answer: C) MS Excel 

133. The language used for artificial 
intelligence is: 
A) Cobol 
B) Lisp 
C) Fortran 
D) None of these 
Answer: B) Lisp 

134. Which of the following is not a type 
of bus in the computer? 
A) Data bus 
B) Control bus 
C) Power bus 
D) None of these 
Answer: C) Power bus 

135. Decimal value of 2^-1 is equal to: 
A) 0.5 
B) 0.05 
C) 0.35 
D) None of these 
Answer: A) 0.5 

136. In a __________ topology, computer 
is directly linked to a center computer. 
A) Bus 
B) Star 
C) Node 
D) None of these 
Answer: B) Star 

137. MAN stands for: 
A) Metropolitan Area Network 
B) Metro Area Network 
C) Metropolitan Area Network 
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274. The full form of CSS is: 
A) Cascading Style Sheets 
B) Cascading Style Sheets 
C) Cascading Style Sheets 
D) None of these 
Answer: A) Cascading Style Sheets 

275. The full form of JS is: 
A) JavaScript 
B) JavaScript 
C) JavaScript 
D) None of these 
Answer: A) JavaScript 

276. The full form of PHP is: 
A) Hypertext Preprocessor 
B) Hypertext Preprocessor 
C) Hypertext Preprocessor 
D) None of these 
Answer: A) Hypertext Preprocessor 

277. The full form of ASP is: 
A) Active Server Pages 
B) Active Server Pages 
C) Active Server Pages 
D) None of these 
Answer: A) Active Server Pages 

278. The full form of JSP is: 
A) Java Server Pages 
B) Java Server Pages 
C) Java Server Pages 
D) None of these 
Answer: A) Java Server Pages 

279. The full form of ASP.NET is: 
A) Active Server Pages .NET 
B) Active Server Pages .NET 
C) Active Server Pages .NET 
D) None of these 
Answer: A) Active Server Pages .NET 

280. The full form of J2EE is: 
A) Java 2 Platform, Enterprise Edition 
B) Java 2 Platform, Enterprise Edition 

C) Java 2 Platform, Enterprise Edition 
D) None of these 
Answer: A) Java 2 Platform, Enterprise 
Edition 

281. The full form of J2ME is: 
A) Java 2 Platform, Micro Edition 
B) Java 2 Platform, Micro Edition 
C) Java 2 Platform, Micro Edition 
D) None of these 
Answer: A) Java 2 Platform, Micro Edition 

282. The full form of J2SE is: 
A) Java 2 Platform, Standard Edition 
B) Java 2 Platform, Standard Edition 
C) Java 2 Platform, Standard Edition 
D) None of these 
Answer: A) Java 2 Platform, Standard 
Edition 

283. The full form of JDK is: 
A) Java Development Kit 
B) Java Development Kit 
C) Java Development Kit 
D) None of these 
Answer: A) Java Development Kit 

284. The full form of JRE is: 
A) Java Runtime Environment 
B) Java Runtime Environment 
C) Java Runtime Environment 
D) None of these 
Answer: A) Java Runtime Environment 

285. The full form of JVM is: 
A) Java Virtual Machine 
B) Java Virtual Machine 
C) Java Virtual Machine 
D) None of these 
Answer: A) Java Virtual Machine 

286. The full form of IDE is: 
A) Integrated Development Environment 
B) Integrated Development Environment 
C) Integrated Development Environment 

https://asp.net/
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D) None of these 
Answer: A) Integrated Development 
Environment 

287. The full form of SDK is: 
A) Software Development Kit 
B) Software Development Kit 
C) Software Development Kit 
D) None of these 
Answer: A) Software Development Kit 

288. The full form of UI is: 
A) User Interface 
B) User Interface 
C) User Interface 
D) None of these 
Answer: A) User Interface 

289. The full form of UX is: 
A) User Experience 
B) User Experience 
C) User Experience 
D) None of these 
Answer: A) User Experience 

290. Which of the following is not a 
hardware? 
A) Monitor 
B) Mouse 
C) MS Word 
D) None of these 
Answer: C) MS Word 

291. Which of the following is not a 
software? 
A) Keyboard 
B) MS Excel 
C) Windows 
D) None of these 
Answer: A) Keyboard 

292. Which of the following is an input 
device? 
A) Printer 
B) Monitor 

C) Keyboard 
D) None of these 
Answer: C) Keyboard 

293. Which of the following is an output 
device? 
A) Printer 
B) Mouse 
C) Scanner 
D) None of these 
Answer: A) Printer 

294. Which of the following is a storage 
device? 
A) Hard Disk 
B) RAM 
C) CPU 
D) None of these 
Answer: A) Hard Disk 

295. Which of the following is a volatile 
memory? 
A) RAM 
B) ROM 
C) Hard Disk 
D) None of these 
Answer: A) RAM 
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